Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

This topic contains 9 respuestas, has 2 mensajes.

Last updated by Diego Pereira hace 7 meses.

Assigned support staff: Diego Pereira.

Autor Publicaciones
abril 30, 2019 a las 8:55 pm #3714893

developersP

Estoy tratando de acceder a translation management , porque necesito usar diferentes templates por idiomas para una misma página, sin embargo no aparece nada 🙁

mayo 1, 2019 a las 3:12 pm #3718721

Diego Pereira
Supporter

Languages: Inglés (English ) Español (Español ) Portugués, Brasil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hola @developersp, Bienvenido al foro de soporte de WPML.

Por favor, active WP_Debug, WP_Debug_log y WP_Debug_Display en su sitio web, mostrará más detalles sobre el error: https://wpml.org/documentation/support/debugging-wpml/ - e.g.

define ('WP_DEBUG', true);
define ('WP_DEBUG_LOG', true);
define ('WP_DEBUG_DISPLAY', true);

Después de esto, compruebe que un mensaje de error aparece en la página. Si es así, por favor envíenos una screenshot.

Sin embargo, creo que la solución de su problema es utilizando el manual editor:
- Ir a la pantalla de edición de la página (idioma original).
- Desactive la opción "Usar el Editor de traducción de WPML" en la barra lateral derecha
- Seleccione sus preferencias de editor y guarde
- Editar la traducción.
- Seleciona un template diferente para la traducción y guarde

Por favor dígame si funcionó para usted.

Saludos,
Diego

mayo 6, 2019 a las 5:07 pm #3751359

developersP

cuando activo el debug me sale este mensaje
WordPress database error: [Table 'peruhop_org.wp_xabs_icl_core_status' doesn't exist]
SHOW COLUMNS FROM wp_xabs_icl_core_status LIKE 'tp_revision'

Aún no he podido utilizar el template para la traducción.

mayo 7, 2019 a las 1:57 pm #3758965

Diego Pereira
Supporter

Languages: Inglés (English ) Español (Español ) Portugués, Brasil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hola,

Envié algunas instrucciones para replicar el sitio web a través de un mensaje privado (respuesta anterior).

Por favor déjame saber si funcionó para ti. Si es así, envíenos instrucciones claras sobre cómo ver / reproducir el problema.

Saludos cordiales,
Diego

mayo 7, 2019 a las 2:09 pm #3759153

developersP

Hola Diego,

Si activo este plugin la página igual se mantendrá activa verdad?

mayo 7, 2019 a las 3:46 pm #3759973

developersP

Diego,

acabo de realizar todo según me indicaste en el mensaje anterior, pero parece que hay un error, me sale esto cuando entro al sitio que me arroja el plugin Cloudways

mayo 7, 2019 a las 6:06 pm #3761075

Diego Pereira
Supporter

Languages: Inglés (English ) Español (Español ) Portugués, Brasil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hola,

Sí, su sitio continuará activo (no hay riesgos para su sitio web).

¿Ha recibido el correo electrónico de confirmación o la advertencia de que se ha completado la migración? Si es así, puedo comprobar el motivo del error en el sitio de pruebas.

Si no ha recibido el mensaje, podemos intentar duplicar de nuevo utilizando algún otro método.

Saludos cordiales,
Diego

mayo 7, 2019 a las 6:19 pm #3761147

developersP

Diego,

me llego este correo, supongo que si termino, pero no esta funcionando.

mayo 8, 2019 a las 3:04 pm #3768071

Diego Pereira
Supporter

Languages: Inglés (English ) Español (Español ) Portugués, Brasil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hola,

He podido acceder al sitio de pruebas deshabilitando el tema.

El mismo error se produce en esta instalación de prueba. He hecho algunas pruebas pero todavía no he encontrado una solución. Estoy comprobando junto a mi equipo y te envío una respuesta en breve.

Saludos cordiales,
Diego

mayo 9, 2019 a las 2:00 pm #3776855

Diego Pereira
Supporter

Languages: Inglés (English ) Español (Español ) Portugués, Brasil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hola,

He podido solucionar el problema en el sitio de pruebas creando la tabla que falta en la base de datos. Por favor siga los siguientes pasos:
- Haga una copia de seguridad del sitio y de la base de datos
- Acceda a la base de datos y ejecute el siguiente comando SQL:

CREATE TABLE IF NOT EXISTS wp_xabs_icl_core_status (
id bigint(20) NOT NULL AUTO_INCREMENT,
rid bigint(20) NOT NULL,
module varchar(16) COLLATE utf8mb4_unicode_520_ci NOT NULL,
origin varchar(64) COLLATE utf8mb4_unicode_520_ci NOT NULL,
target varchar(64) COLLATE utf8mb4_unicode_520_ci NOT NULL,
status smallint(6) NOT NULL,
tp_revision int(11) NOT NULL DEFAULT '1',
ts_status text COLLATE utf8mb4_unicode_520_ci,
PRIMARY KEY (id),
KEY rid (rid)
) ENGINE=MyISAM DEFAULT CHARSET=utf8mb4 COLLATE=utf8mb4_unicode_520_ci;
COMMIT;

Esto resolvió el problema en el sitio de pruebas. Por favor dígame si funciona para usted.

Saludos cordiales,
Diego