Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

Hoy no hay asistentes de soporte disponibles en el foro Spanish. Siéntase libre de enviar sus tiques y les daremos trámite tan pronto como estemos disponibles en línea. Gracias por su comprensión.

This thread is resolved. Here is a description of the problem and solution.

Problem:
I need to change the color of the links on the language switcher

Solution:
On this ticket, it was fixed using the following CSS snippets:

.wpml-ls-statics-shortcode_actions li a {
 color: #111 !important;
}

.wpml-ls-slot-footer a {
        color: #111 !important;
}

This topic contains 6 respuestas, has 3 mensajes.

Last updated by juan-carloC hace 5 meses, 1 semana.

Assigned support staff: Diego Pereira.

Autor Publicaciones
mayo 10, 2019 a las 10:56 am

juan-carloC

Estoy tratando de:
Situar las banderas con el nombre del pais en una zona de la web mediante un Shortcode

URL de (mi) sitio web donde aparece el problema:
hidden link

Yo esperaba ver:
El nombre junto a la bandera

En vez de eso, obtuve:
que no se ve el nombre

Gracias por la ayuda

mayo 10, 2019 a las 12:27 pm #3784147

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola,
Muchas gracias por contactar con el servicio de soporte de WPML.

Al parecer el nombre del idioma si aparece, pero se muestra en color blanco. Para cambiar el color del nombre del idioma debe ir a WPML -> Idiomas -> Editar el selector de idiomas y cambiar el color del nombre del idioma.

Le recomiendo que visite este enlace donde encontrará nuestra documentación oficial al respecto: https://wpml.org/documentation/getting-started-guide/language-setup/language-switcher-options/#full-control-over-each-language-switcher

Saludos cordiales,
Carlos

mayo 10, 2019 a las 12:57 pm #3784405

juan-carloC

Estoy comprobando el color del idioma y parece estar el color de la fuente en negro.
Ten en cuenta que esto utilizando El selector de idiomas personalizado mediante shortcodes.
¡Puedes acceder a la administracion de mi wp y comprobar si el color es como te digo.

Gracias

mayo 13, 2019 a las 1:51 pm #3799117

Diego Pereira
Supporter

Languages: Inglés (English ) Español (Español ) Portugués, Brasil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hola,

Como Carlos actualmente tiene algunos días de descanso, lo reemplazaré aquí en el foro. Espero que esto esté bien para ti.

Por favor añada este código CSS en Appearance > Customize > Additional CSS

.wpml-ls-statics-shortcode_actions li a {
 color: #111 !important;
}

Esto debería corregir el problema. Por favor dígame si funcionó para usted.

Saludos cordiales,
Diego

mayo 13, 2019 a las 3:42 pm #3800189

juan-carloC

Gracias Diego,

Añadiendo el código css se resuelve el color de la fuente en el Shortcode de la parte superior de la web.

Sin embargo, aún no puedo ver el título del idioma en las banderas situadas en el footer de la página.

Espero tu respuesta

Un saludo

Juan Camacho

mayo 13, 2019 a las 7:58 pm #3801441

Diego Pereira
Supporter

Languages: Inglés (English ) Español (Español ) Portugués, Brasil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hola,

Este código CSS debe resolver el problema en el footer. Por favor, añada junto al código anterior:

.wpml-ls-slot-footer a {
    	color: #111 !important;
}

Por favor dígame si funcionó para usted.

Saludos cordiales,
Diego

mayo 14, 2019 a las 2:51 pm #3808317

juan-carloC

My issue is resolved now. Thank you!