Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

Etiquetado: 

This topic contains 9 respuestas, has 2 mensajes.

Last updated by Otto hace 4 años, 2 meses.

Assigned support staff: Otto.

Autor Publicaciones
noviembre 5, 2015 a las 7:09 pm #740791

Escobosa

Hola Otto
En mi web hidden link he configurado el selector de idiomas de arriba como Lista de idiomas y en horizontal. En vez de eso me sale como desplegable en vertical.

El tema es the7.2

Muchas gracias!

noviembre 5, 2015 a las 7:48 pm #740830

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola nuevamente 🙂

Gracias por abrir un nuevo ticket para este problema.

Si no me equivoco, el selector de idiomas que estás utilizando no es el de WPML sino que es parte del tema.

Podrías verificar si el tema tiene opciones respecto del selector?

Por otro lado, para estar seguro que es del tema, podrías por favor mostrarme la configuración que tienes en:
WPML > Idiomas > Opciones del selector de idiomas > Selector de idioma en el menú de WP

Si quieres puedes usar la opción "subir una imagen" que está debajo del área de comentarios.

Un saludo cordial

noviembre 5, 2015 a las 8:03 pm #740847

Escobosa

Hola Otto
te mando 2 pantallas en el 1 sale la configuración del selector de idiomas en wpml
En la segunda foto sale como meter el wpml en el tema, en las opciones de la cabecera hay un cuadro Idioma WPML que he metido en el punto 4 donde dice "cerca de la zona de navegación". El wpml en este tema se mete así, de esa manera pero no da opciones de mostrarlo o editarlo solo la ubicación.

De hecho en otra web que he hecho con the7 el selector de idiomas si que se muestra como le digo en la configuración del plugin y si se muestra como lista de idiomas en horizontal: hidden link

A ver si me puedes ayudar

Gracias!

noviembre 5, 2015 a las 8:27 pm #740858

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola,

Gracias por la información.

Efectivamente, al ser un selector de idiomas del tema (no de WPML) las opciones que selecciones no tendrán efecto.

Haz la siguiente prueba por favor:
En WPML > Idiomas > Opciones del selector de idiomas > Selector de idioma en el menú de WP, elige esa opción y selecciona el menú principal. Funciona adecuadamente?

Quedo a la espera de tu respuesta.

Un saludo cordial

noviembre 5, 2015 a las 8:32 pm #740865

Escobosa

En efecto Otto ahora sale en el menu principal, le he puesto banderas para que se vea mejor. Y ahora como hago para que quede a la derecha del menu y el texto un poco más pequeño?

Gracias!!

noviembre 5, 2015 a las 8:39 pm #740870

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola,

Prueba lo siguiente por favor:

En WPML > Idiomas > Opciones del selector de idiomas > CSS adicional, agrega lo siguiente:

#main-nav > li.menu-item.menu-item-language.menu-item-language {
float: right;
}

#main-nav > li.menu-item.menu-item-language.menu-item-language a {
font-size: 15px;
}

Dime si funciona por favor.

Un saludo cordial

noviembre 6, 2015 a las 11:24 am #741259

Escobosa

Buenas Otto
disculpa pero no encuentro por ninguna parte lo del CSS adicional, antes si estaba (en otras versiones) ahora esa opcion no la encuentro. Lo he puesto en las css del tema y queda perfecto.
me podrias decir antes de cerrar el ticket donde estan las css del wpml?? Asi ya lo sabre para otras veces

Muchas gracias!

noviembre 6, 2015 a las 11:40 am #741279

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola,

Es extraño, debería estar en WPML > Idiomas > Opciones del selector de idiomas > CSS adicional, al final de la sección justo antes de Idioma de administración. Fíjate la captura de pantalla que adjunto.

Lo encuentras?

Un saludo cordial

noviembre 6, 2015 a las 11:52 am #741295

Escobosa

Hola
Pues como puedes ver en mi captura no me aparece, es muuuy raro no?

noviembre 6, 2015 a las 12:16 pm #741323

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola,

Puedes ser que tu tema lo esté limitando. Fíjate la nota que aparece al final de la sección.

Prueba cambiar de tema por un momento y fíjate si aparece por favor. Haz un back up de tu sitio antes, mejor prevenir que curar 😉

Dime como resulta por favor.

Un saludo cordial

El debate ‘[Cerrado] El selector de idomas no me sale en horizontal’ está cerrado y no admite más respuestas.