Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

This topic contains 6 respuestas, has 3 mensajes.

Last updated by Miquel Gabriel hace 5 meses, 3 semanas.

Assigned support staff: Carlos Rojas.

Autor Mensajes
abril 2, 2019 a las 8:32 am

Miquel Gabriel

Estoy montando un sitio web de una immobiliaria en idiomas castellano y catalan, mediante un archivo xml multilingue, y me encuentro con un problema. Despues de estar haciendo muchas pruebas, borré todas las propiedades para volver a importarlas de 0, y ahora me encuentro que:

Para importarlas al castellano (idioma nativo de la web y wpml) he de desactivar todo el wpml para que el servidor acepte la importación, sino termina antes de empezar.
Y para importar al catalan, he de activar wpml para que introduzca las traducciones. a parte en catalán sólo añade 1 imagen, cuando en castellano muchas mas.

Esto es un problema, porque quiero hacer que se actualice de forma automática cada vez que el cliente exporte el archivo xml.
Podrian ayudarme? Gracias

abril 2, 2019 a las 10:36 am #3516111

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola,

Bienvenido al soporte de WPML.

Con respecto a la importación en el idioma por defecto:

1. ¿Me podrías confirmar si estás utilizando los plugin WP All import y WPML All import?
https://wpml.org/documentation/related-projects/wpml-all-import-plugin-website-import-with-wpml/

2. De nuevo con respecto a la importación en el idioma por defecto: ¿de cuántas propiedades se compone tu archivo XML? ¿Qué pasa si reduces el número?

Un saludo,
Andrés

abril 11, 2019 a las 11:24 am #3586595

Miquel Gabriel

Hola Andrés, no habia visto tu respuesta.
La verdad es que sigo con el mismo problema. y ya me estoy volviendo loco y no se como solucionarlo.
He comprado la version pro de wpallimport, así que es la que uso juntamente con el tema wpresidence.
Hablando con arsys, el servidor, hemos detectado que si desactivamos los plugins de wpml la importación no se detiene y consigue descargar las 36 propiedades con sus respectivas imágenes. pero con los plugins activos no hay forma o yo no consigo encontrarla de que no se detenga.
te adjunto el xml para que veas como esta compuesto, ya que viene exportado de un programa de gestión: hidden link

porfavor, ya no se como seguir con esto y llevo un retraso de 1 mes para entregar esta web.
hidden link

abril 11, 2019 a las 3:22 pm #3589769

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Para aislar cualquier problema proveniente del servidor, he creado un sitio de pruebas para ti. Puedes acceder a este simplemente haciendo click en en siguiente enlace:
hidden link

La idea es que cargues tus plugin WP All import y tu tema WPResidence y nos ayudes a reproducir el problema. De esta manera, si efectivamente se trata de un problema de compatibilidad, podremos acelerar el proceso y contactar a nuestro Equipo de compatibilidad y trabajar con el autor en la resolución de tu problema.

1. Instala una versión actualizada de tu WPResidence.
2. Simplifica tu XML a 1-2 propiedades.
3. Realiza la importación.
¿Funciona esta vez?


No tienes que recrear tu sitio, simplemente instalar lo mínimo necesario para reproducir el problema.

abril 17, 2019 a las 10:57 am #3629899

Miquel Gabriel

Hola Andrés,
he montado todo lo que he podido el sitio en el sandbox que me has facilitado, y he intentado importar el xml. Son 36 propiedades solamente.
Me ha fallado 3 veces, no se si hay alguna limitación de capacidad y puede fallar por ese motivo.
de todas formas, de las 35 propiedades importadas, no las muestra en el frontend.

Mi pagina la estoy desarrollando en un entorno de pruebas también, podriamos mirar allí el error? Puedo facilitarte el acceso o instalar lo que sea necesario.

abril 17, 2019 a las 6:40 pm #3634317

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola,
Mi nombre es Carlos y voy a tomar este ticket pues nuestro colega Andrés está de vacaciones.

He aplicado algunos pasos de troubleshooting en el sitio de pruebas y me gustaría pedirle que volviera a intentar la importación.

Si el problema persiste entonces le pido que realice estos pasos:
- Active el modo de depuración del sitio siguiendo los pasos descritos en el siguiente enlace: https://codex.wordpress.org/Debugging_in_WordPress (pare realizar los cambios en el archivo wp-config.php puede instalar el plugin File Manager o conectarse via FTP).
- Actualice cualquier plugin o tema que pueda estar desactualizado.
- Borre cualquier memoria cache que pueda existir.
- Desactive todos los plugins excepto los de WPML y WP All Import.
- Active un tema por defecto de WordPress, por ejemplo Twenty Nineteen.
- Si el problema desapareció bajo estas condiciones mínimas entonces comience activando el tema y luego los plugins uno por uno hasta que el problema vuelva a aparecer.

Me puede decir el resultado de los pasos anteriores?

Saludos cordiales,
Carlos

abril 25, 2019 a las 10:45 am #3681311

Miquel Gabriel

hola carlos,
he vuelto a importar y ha subido todo correctamente.
como puedo aplicar esta configuración a mi sitio o en su defecto realizar el test contigo en mi servidor? porque en mi servidor, cuando hago la importación con los plugin de wpml activados da error.