Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

Our next available supporter will start replying to tickets in about 0.51 hours from now. Thank you for your understanding.

Etiquetado: 

This topic contains 39 respuestas, has 4 mensajes.

Last updated by Sumit hace 3 años, 3 meses.

Assigned support staff: Sumit.

Autor Publicaciones
septiembre 27, 2016 a las 7:02 am #1101772

marcalS

He creado con toolset un formulario para crear un tipo de posts especifico los cuales solo se suben en un idioma. Pero la interficie de la web está en tres idiomas.

La web esta configurada para tener un dominio distinto para cada idioma.

En el idioma principal no tengo ningún problema. Pero en los otros idiomas al intentar subir una imagen me aparece una ventana emergente que dice "Upload Failed!"

En la consola del navegador veo el siguiente mensaje:

OPTIONS XHR hidden link
[HTTP/1.1 403 Forbidden 487ms]

Entiendo que el dominio no es el correcto puesto que estoy en el formulario de un idioma secundario.

Me podeis ayudar?

septiembre 27, 2016 a las 1:28 pm #1102702

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola,

Gracias por contactarte con el foro de soporte!

En primer lugar, te pido que hagas la siguiente prueba:
-Haz un back up confiable y que puedas restaurar de tu sitio y base de datos antes de hacerlo
-Cambia por un momento a idiomas en directorios o idioma agregado como parámetro
-El problema persiste?

Por otro lado, podrías indicarme la ruta (relativa) al formulario? La url de tu sitio puedo verla en la información de debug (privada)

Muchas gracias por tu cooperación.

Un saludo cordial,

Otto

septiembre 27, 2016 a las 1:41 pm #1102725

marcalS

Hola

Efectivamente si cambio la configuración diferentes idiomas en directorios y la subida de archivos funciona correctamente.

Pero necessito que funcione bien con la configuración por dominios.

El formulario del que hablo se encuentra en la ruta:
/formulario-de-servicio-de-guia/

Pero és una pagina que solo pueden ver los usuarios registrados.
Puedo crear un usuario para que puedas entrar pero te lo enviaría por mensaje privado.

septiembre 27, 2016 a las 2:54 pm #1102863

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola,

Muchas gracias.

Habilito una respuesta privada para que me puedas crear un usuario para que pueda ver el formulario.

Muchas gracias por tu cooperación.

Un saludo cordial,

Otto

septiembre 27, 2016 a las 5:43 pm #1103041

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola,

Muchas gracias.

He podido crear un nuevo servicio desde el formulario habiendo seleccionado el Catalán como idioma del sitio.

Si no he entendido bien el problema, podrías por favor desarrollar un poco más la explicación para que pueda comprenderlo? Podrías indicarme los pasos que dobe seguir para poder reproducir el problema?

A veces una captura de pantalla es la solución ya que clarifica lo que las palabras no pueden transmitir fácilmente. Si quieres puedes usar la opción "subir una imagen" que está debajo del área de comentarios.

Muchas gracias por tu cooperación.

Un saludo cordial,

Otto

septiembre 27, 2016 a las 6:53 pm #1103093

marcalS

Por ejemplo en la url:
hidden link
Al intentar subir una Featured Image, clic en el boton "Browse...", aparece la ventana emergente, selecciono un archivo de imagen i le doy al boton "abrir". Aquí es donde aparece el error. aparece una ventana emergente con el mensaje "Upload Failed!"

Esto sucede con todos los campos de imagen pero solo en el formulario con el dominio del idioma catalan o español. En el formulario en ingles aparece la barra de progreso y sube los ficheros correctamente.

Como decia en el primer mensaje, es en ese momento cuando aparece el error en la consola del navegador:
OPTIONS XHR hidden link
[HTTP/1.1 403 Forbidden 487ms]

septiembre 27, 2016 a las 8:16 pm #1103158

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola,

Muchas gracias. Te pido disculpas, se me había pasado el detalle de la imagen.

Ahora si he podido ver el problema.

El error completo es el siguiente:

XMLHttpRequest cannot load ... Response to preflight request doesn't pass access control check: No 'Access-Control-Allow-Origin' header is present on the requested resource. Origin 'hidden link' is therefore not allowed access. The response had HTTP status code 403.

Por favor, revisa esta documentación para habilitar CORS en tu sitio:

hidden link

Esto permitirá subir una imagen desde un dominio al otro.

Quedo a la espera de tus resultados.

Un saludo cordial,

Otto

septiembre 28, 2016 a las 7:48 am #1103379

marcalS

Desde el servicio tecnico de mi servido dicen que la directiva CORS está activada por defecto en sus servidores pero que devo indicar los parámetros mediante .htaccess

He intentado con estas instrucciones en el .htaccess pero sigue sin funcionar

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
Header always set Access-Control-Allow-Origin "*"
Header always set Access-Control-Allow-Headers "origin, x-requested-with, content-type"
Header always set Access-Control-Allow-Methods "PUT, GET, POST, DELETE, OPTIONS"
</IfModule>

# END WordPress

me podeis ayudar?

septiembre 28, 2016 a las 1:00 pm #1103723

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola,

Si no me equivoco (no soy un experto en la materia) como habilitar CORS depende del servidor en el que tu sitio está alojado. Por lo que el soporte del hosting te podrá guiar mucho mejor que yo.

De todos modos, puedes tener en cuenta este workaround para activarlo:
hidden link

Dime por favor si has podido habilitar CORS y si esto soluciona el problema.

Muchas gracias por tu cooperación.

Un saludo cordial,

Otto

septiembre 28, 2016 a las 1:51 pm #1103800

marcalS

He seguido los pasos que menciona el enlace, modificando el header.php del theme y sigue obteniendo el mismo problema.

septiembre 28, 2016 a las 6:22 pm #1104043

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola,

Por lo que puedo ver sigue siendo un problema de CORS. Por algún motivo no lo está activando.

Es posible para ti consultarlo con el soporte del hosting? Tal vez haya algún bloqueo o configuración particular que se me está escapando.

Muchas gracias!

Dime que te contestan por favor.

Un saludo cordial,

Otto

septiembre 29, 2016 a las 7:21 am #1104301

marcalS

Desde el servicio tecnico de mi servidor me dicen que la directiva está activada i que és problema de programación. No dan soporte sobre este tema.

Sigo buscando soluciones...

septiembre 29, 2016 a las 11:45 am #1104654

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola,

Muchas gracias.

Me resulta extraño que este activada y siga apareciendo el error. Pero ellos saben más del tema que yo 🙁

Para poder investigar mejor el problema necesitaría, si fuera posible, que me permitas acceder a tu sitio temporalmente. Mucho mejor si tuvieras un sitio de pruebas en donde esté replicado el problema.

Encontrarás los campos necesarios debajo del área de comentarios. He marcado la próxima respuesta como privada, por lo que la información que ingreses solo la veremos tu y yo.

Es posible que necesite replicar tu sitio localmente. Para eso voy a necesitar instalar un plugin llamado "Duplicator". Con él podré crear una copia completa de tu web. Una vez que el problema esté resuelto, borraré la copia local. Dime por favor si estás de acuerdo.

** IMPORTANTE **

- Por favor haz un back up completo de tu sitio y base de datos antes de proveer los datos de acceso

- Si no ves este formulario para completar los campos confidenciales NO los publiques, ya que serán visibles en el foro:
hidden link

En ese caso, pídeme que vuelva a habilitar una respuesta privada.

Muchas gracias.

Un saludo cordial,

Otto

septiembre 29, 2016 a las 8:23 pm #1105175

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola,

Muchas gracias.

He clonado tu sitio y lo he instalado localmente. En mi servidor he podido reproducir el problema.

Estoy consultando el asunto con nuestro soporte de segundo nivel, en cuanto tenga novedades me pondré nuevamente en contacto contigo.

Muchas gracias por tu cooperación.

Un saludo cordial,

Otto

septiembre 30, 2016 a las 11:39 am #1105604

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola,

Te pido disculpas por la demora.

Por favor, prueba agregando esto en el comienzo del archivo .htaccess:

<IfModule mod_headers.c>
    Header set Access-Control-Allow-Origin <em><u>hidden link</u></em>
</IfModule>

Dime si esto lo soluciona por favor.

Un saludo cordial,

Otto

El debate ‘[Cerrado] En los idiomas secundarios no puedo subir imágenes.’ está cerrado y no admite más respuestas.