Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

Hoy no hay asistentes de soporte disponibles en el foro Spanish. Siéntase libre de enviar sus tiques y les daremos trámite tan pronto como estemos disponibles en línea. Gracias por su comprensión.

Etiquetado: 

This topic contains 39 respuestas, has 4 mensajes.

Last updated by Sumit hace 3 años, 3 meses.

Assigned support staff: Sumit.

Autor Publicaciones
septiembre 30, 2016 a las 1:32 pm #1105720

marcalS

No, sigue dando el mismo error.

Lo que me he fijado es que el método que da el error es OPTIONS pero el Access-Control-Request-Method es POST

No se si tendrá algo que ver.

septiembre 30, 2016 a las 7:29 pm #1106001

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola,

Muchas gracias por las pruebas realizadas.

He escalado el ticket a nuestro soporte de segundo nivel.

Ellos investigarán el problema y se pondrán en contacto contigo en cuanto tengan una respuesta.

Dado que no hay supporters de segundo nivel que hablen inglés, sería un problema para ti continuar en ese idioma? Sino yo puedo intermediar en la comunicación, solo que será algo más lento el proceso.

Un saludo cordial,

Otto

octubre 1, 2016 a las 2:39 pm #1106225

Sumit
Supporter

Languages: Inglés (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

I am Sumit from 2nd tier support.

This is the problem with CRED + WPML domain per language. I've forwarded this issue to 3rd tier and I will share the feedback with you once I have it.
For now I added this code to your theme functions.php

add_filter('allowed_http_origins', function($allowed){
    $allowed[] = '<em><u>hidden link</u></em>';
    $allowed[] = '<em><u>hidden link</u></em>';
    $allowed[] = '<em><u>hidden link</u></em>';
    $allowed[] = '<em><u>hidden link</u></em>';
    return $allowed;
});

Which allowed me to fix this issue. But now I am seeing invalid nonce issue. I suspect that it may be because of 500 error when WPML trying to share the session with other domain. You can see the 500 error in console.
I will try to narrow down the problem so first can you please disable all plugins those are unrelated with WPML and switch to one of default themes e.g. Twenty Fifteen (Please add the above code in default theme so we can fix the first problem), Are you seeing the same 500 error in console ?

NOTE:
Also make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

Thanks

octubre 3, 2016 a las 6:31 am #1106583

marcalS

Yes, I'm seeing 500 error in console with my theme and with default theme.

The code added to functions.php file does not solve the problem because when change language, the user not remains logged. Therefore can not access the form.

octubre 3, 2016 a las 8:46 am #1106672

Sumit
Supporter

Languages: Inglés (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Thanks for the information. This is because of 500 error and session can no be shared among the domains. Can you please provide me server error log (You can hosting to provide server error log) ? Because just with 500 error message I can not find that what causing the problem.
I hope I can get something by error log.

Thanks

octubre 3, 2016 a las 9:28 am #1106710

marcalS

The log of php:
[03-Oct-2016 09:22:39 UTC] PHP Notice: Array to string conversion in /usr/home/___domain___/web/wp-includes/class-wp.php on line 318

Not getting an error

octubre 3, 2016 a las 11:20 am #1106835

Sumit
Supporter

Languages: Inglés (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

I am sorry but this is PHP error log. I need apache error log. For this you can ask your hosting provider hidden link
Please let me know if it is possible for you?

Thanks

octubre 4, 2016 a las 6:30 am #1107523

marcalS

Ok, I have the Apache log.

The error that is repeated is this:

88.13.64.241 - - [03/Oct/2016:22:28:59 +0200] "GET /?gen_iframe=true&_wpml_gen_iframe_nonce=4fb168642c626a1fbf2b17049ec1fcd6199229423f830be7c7d574a20ef2e1bc HTTP/1.1" 500 2564 "hidden link" "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/53.0.2785.116 Safari/537.36"
88.13.64.241 - - [03/Oct/2016:22:28:59 +0200] "GET /?gen_iframe=true&_wpml_gen_iframe_nonce=5227fb7c47012d912bd9945213ac276402ca2ca793259783d0c232382cdd1cb5 HTTP/1.1" 500 2566 "hidden link" "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/53.0.2785.116 Safari/537.36"

The other mistake is repeated this:

123.236.183.197 - - [01/Oct/2016:15:33:22 +0200] "OPTIONS /wp-content/plugins/cred-frontend-editor/embedded/toolset/toolset-common/toolset-forms/classes/submit.php?id=752&formid=14&nonce=945a62b4ba HTTP/1.1" 403 290 "-" "Mozilla/5.0 (Windows NT 6.2; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0"
123.236.183.197 - - [01/Oct/2016:15:34:42 +0200] "OPTIONS /wp-content/plugins/cred-frontend-editor/embedded/toolset/toolset-common/toolset-forms/classes/submit.php?id=752&formid=14&nonce=945a62b4ba HTTP/1.1" 403 290 "-" "Mozilla/5.0 (Windows NT 6.2; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0"

octubre 4, 2016 a las 10:42 am #1107809

marcalS

He actualizado el WPML a la nueva version, que acaban de liberar, para ver si solucionaba el problema pero ahora cuando logueo un usuario si intento cambiar el idioma no mantiene el logueo.

Con lo que no es posible acceder a las paginas en ese idioma.

octubre 4, 2016 a las 12:50 pm #1107973

Sumit
Supporter

Languages: Inglés (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Thanks for the details.

This seems to access log instead of error log. No problem I will clone the site to my local system to see the actual problem.
I will get back to you when I am done with debugging.

Thanks

octubre 4, 2016 a las 3:30 pm #1108215

Sumit
Supporter

Languages: Inglés (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

I enabled session sharing on your website so you can see the form now. In new version WPML added a option WPML > Languages: where you can turn off/on this feature.

However, now I am seeing invalid nonce issue, I cloned the website and checked on my local system I am having the same issue.
I will request you to please open a new thread on toolset forum and include this ticket with below debug information. (I already informed toolset team but will be good if you also start a thread there.)

There is invalid nonce issue because wp_get_session_token(); is returning blank string in the toolset \plugins\cred-frontend-editor\embedded\toolset\toolset-common\toolset-forms\classes\submit.php file when you are secondary domain using WPML + language per domain. This might be because of custom WordPress loading.

Thanks

octubre 5, 2016 a las 6:37 am #1108556

marcalS

Ok, I have opened a ticket to the support forum Toolset.

octubre 5, 2016 a las 12:04 pm #1108911

Sumit
Supporter

Languages: Inglés (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Thank you very much! Can you please also share the ticket link I tried to find it but I couldn't find it.

Thanks

octubre 5, 2016 a las 1:30 pm #1109000

marcalS

https://toolset.com/forums/topic/upload-featured-image-failed-in-secondary-language

octubre 6, 2016 a las 10:57 am #1109779

Sumit
Supporter

Languages: Inglés (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Thanks for sharing link. This issue is being investigate by Toolset team and I've shared everything which I found so far.
I will keep you posted.

Thanks

El debate ‘[Cerrado] En los idiomas secundarios no puedo subir imágenes.’ está cerrado y no admite más respuestas.