Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

Etiquetado: 

This topic contains 39 respuestas, has 4 mensajes.

Last updated by Sumit hace 3 años, 3 meses.

Assigned support staff: Sumit.

Autor Publicaciones
octubre 6, 2016 a las 11:00 am #1109785

Sumit
Supporter

Languages: Inglés (English )

Timezone: Asia/Kolkata (GMT+05:30)

This message is just to set the correct ticket status!

octubre 13, 2016 a las 1:23 pm #1114728

marcalS

Donde puedo hacer el seguimiento del problema?

noviembre 3, 2016 a las 7:40 am #1128919

marcalS

There is something new about this?

noviembre 3, 2016 a las 8:03 am #1128929

Ankit

Hi,

This is Ankit from second tier support team. Since Sumit is unavailable at the moment, I will assist you with the issue, hope this is fine with you. 🙂

Issue has already been reported to our development team and they are still working on the solution. However, can you please try following for me?

Add following code to wp-config.php file.

// respond to preflights
header('Access-Control-Allow-Origin: *');
if ($_SERVER['REQUEST_METHOD'] == 'OPTIONS') {
    // return only the headers and not the content
    // only allow CORS if we're doing a GET - i.e. no saving for now.
    if (isset($_SERVER['HTTP_ACCESS_CONTROL_REQUEST_METHOD']) &&
            $_SERVER['HTTP_ACCESS_CONTROL_REQUEST_METHOD'] == 'POST') {

        header('Access-Control-Allow-Headers: X-Requested-With');
    }
    exit;
}

Save the file and upload.

Let me know, if placing this code helps resolve the issue.

Regards,
Ankit

noviembre 3, 2016 a las 8:18 am #1128939

marcalS

I've done the test and continues the same problem.

noviembre 8, 2016 a las 3:27 pm #1132547

marcalS

Empieza a ser urgente arreglar este problema ya que tenemos la web funcionando desde agosto sin que se puedan subir imágenes. I es una funcionalidad indispensable para los usuarios.

Hemos realizado las últimas actualizaciones de los plugins, puesto que hemos visto en la web de Toolset que el error ya estaba resuelto.

https://toolset.com/errata/file-upload-fails-custom-wordpress-directories-structure/

En nuestra web continuamos teniendo problemas, aunque ahora no aparece el error en la consola, nos sigue apareciendo el mensaje "Upload Error: invalid NONCE". I las imágenes no se suben.

Alguna solución?

noviembre 9, 2016 a las 6:53 am #1132926

Sumit
Supporter

Languages: Inglés (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

I am sorry for the troubles. Yes I know it is not solved yet. I just tested everything with latest toolset version yesterday.
I've informed toolset team about this issue again and I will share the feedback as soon as I have.

Thanks

noviembre 9, 2016 a las 11:51 am #1133147

marcalS

I managed to run the loaded image in form by making the following changes:

Add in wp-config:

header('Access-Control-Allow-Origin: *');
if ($_SERVER['REQUEST_METHOD'] == 'OPTIONS') {
// return only the headers and not the content
// only allow CORS if we're doing a GET - i.e. no saving for now.
if (isset($_SERVER['HTTP_ACCESS_CONTROL_REQUEST_METHOD']) &&
$_SERVER['HTTP_ACCESS_CONTROL_REQUEST_METHOD'] == 'POST') {

header('Access-Control-Allow-Headers: X-Requested-With');
}
exit;
}

In cred-frontend-editor/embedded/toolset/toolset-common/toolset-forms/classes/submit.php in row num 56 commented /* && check_ajax_referer('ajax_nonce', 'nonce', false)*/

But I guess this check is important. Is it like that?

noviembre 9, 2016 a las 1:20 pm #1133242

Sumit
Supporter

Languages: Inglés (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

You just turned off nonce checking. Nonce checking is important to avoid unauthorized form submission.
However, if you want to keep it for a while you can till our team is working on the issue.
I am sorry for the delay!

Thanks

diciembre 9, 2016 a las 7:54 am #1155607

Sumit
Supporter

Languages: Inglés (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

This is to inform you that Toolset team have has fixed this issue and they have published an errata about this https://toolset.com/errata/cred-uploading-fails-case-specific-wpml-language-url-format/
Please make the changes and let me know if it is working for you.
I have tested the same with your site duplicator package and it is working fine.

However, please note if you have updated the WPML version to 3.6 you may notice that you are not logged-in in secondary domain.
It is okay if you've not updated yet else please let me know.

Thanks

El debate ‘[Cerrado] En los idiomas secundarios no puedo subir imágenes.’ está cerrado y no admite más respuestas.