Skip Navigation

Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en los foros 6 días a la semana, 22 horas por día.

Hoy no hay asistentes de soporte disponibles en el foro Spanish. Siéntase libre de enviar sus tiques y les daremos trámite tan pronto como estemos disponibles en línea. Gracias por su comprensión.

This topic contains 21 respuestas, has 2 mensajes.

Last updated by Andrés hace 4 años, 3 meses.

Assigned support staff: Andrés.

Autor Mensajes
mayo 22, 2017 a las 9:44 am #1281385

santiagoT-5

Hola

hemos confirgurado la tienda hidden link y al acabar proeceso del checkout los endspoints nos enviaban a un error 404, luego de realizar la traduccion del order received nos envia a la pagina de inicio aunque con la URL del order-received( hidden link)
Estamos a punto de lanzar la web y necesitariamos saber a que se debe este problema. Gracias

mayo 22, 2017 a las 11:08 am #1281478

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola Santiago,

Bienvenido al soporte de WPML.

Podrías hacer un backup completo de tu sitio - base de datos y archivos y actualizar:
- Todo tu paquete WPML.
- WooCommerce.

¿Después de estas actualizaciones puedes traducir tu end point ?

Un saludo,
Andrés

mayo 22, 2017 a las 11:32 am #1281503

santiagoT-5

Hola
Decirte que no podemos actualizar Woocommerce a la version 3 ya que hemos tenido problemas y debemos salir esta semana a produccion.
En todo caso podemos actualizar WPML pero no Woocommerce.
Espero tus indicaciones.
Saludos Santiago

mayo 22, 2017 a las 1:10 pm #1281644

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Gracias por esta información, Santiago. Puedes intentar actualizar tu paquete WPML solamente, pero puede que sea necesario también la actualización de WooCommerce.

Lo otro que puedes hacer es hacer todas las actualizaciones necesarias en tu sitio de prueba y ver si el problema persiste. Sin embargo, por reglas de soporte, sólo podemos asistirte con las últimas versiones de WordPress, WooCommerce y WPML.

Saludos

mayo 23, 2017 a las 8:39 am #1282351

santiagoT-5

Hola Andrés.
Hemos actualizado el sistema, WPML y Woocommerce y el problema de los endpoints persiste.
He traducido el end point y sigue igual, nos redirige a la pagina de inicio pero con esta url:

hidden link

Nos ayudas a resolverlo por favor?
Gracias Santiago

mayo 23, 2017 a las 10:46 am #1282504

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Gracias Santiago. He tratado de replicar esta situación pero no tienes un modo de pago que pueda usar. 🙂

1. ¿Podrías ir a tus Ajustes > Enlaces permanentes, y guardar de nuevo tus ajustes? ¿La situación cambia?

2. ¿Podrías indicarme qué cadena estás utilizando para la traducción de tu end point?

3. Podrías revisar que esta situación se presenta cuando:
- Todos los plugins no relacionados con WPML están desactivados. Esto nos dirá si hay algún problema de interacción con otro plugin.
- Cambias a un tema por defecto de WordPress como el Twenty Fourteen. Esto nos dirá si hay un problema de interacción con tu tema.
- Si el problema desaparece, activa uno por uno para determinar quién genera esta situación.

Saludos

mayo 24, 2017 a las 8:10 am #1283344

santiagoT-5

Hola Andres,
Luego de volver a realizar todas las pruebas e indicaciones que nos has dado, seguimos teniendo problemas y esta situacion no varia. Incluso dejando pelada la instalacion NO FUNCIONA y eso no es correcto porque al menos el theme deberia estar funcionando.
Hemos montado hasta un entorno de pruebas para testear lo que dices y sigue dando erorres.
Te pido por favor accedas al sistema y vean cual es el problema ya que no podemos seguir asi.
Adjunta la captura.
Espero me digas que informacion debo proveerte para que puedan resolver este tema ASAP.
gracias
Santiago

Captura de pantalla 2017-05-24 a las 10.04.41.png
mayo 24, 2017 a las 9:21 am #1283446

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola Santiago,

Lamento este comportamiento, sin, embargo no me contestaste, ¿cómo o por cual término estás traduciendo tu end point? Por cierto, sigue siendo tu problema, ¿cierto?, no se a que te refieres con que al menos el theme debería estar funcionando..

¿Me podrías dar las credenciales de tu sitio web de prueba, de esta manera podemos dar un vistazo a tus ajustes, así como los pasos necesarios para reproducir este comportamiento?

Para esto, debes poder ver una forma protegida en la parte inferior de este tópico. (Te pide hacer un backup y un + Aviso legal). Una instalación de test es preferible y nos haría mucho más fácil hacer una evaluación. En cuanto tenga más información te lo haré saber

Importante: Haz un backup completo de tu sitio. Puedes usar un plugin como Duplicator para este propósito. Mira en: http://wordpress.org/plugins/duplicator/

Si no ves este formulario para completar los campos confidenciales NO los publiques, ya que serán visibles en el foro:
hidden link

Privacidad y seguridad al proporcionar información de Debug para soporte:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

mayo 24, 2017 a las 11:00 am #1283528

santiagoT-5

Hola
El slug se ha puesto como orden-recibida, me refiero a que despues de todo lo que nos habeis indicado sigue sin funcionar. Incluso desmontando 100% nuestro proyecto para verificar el problema.
Espero que tu ayuda nos indique que hay que hacer, he dejado toda la web con plantilla distinta y sin plugins-
Espero tus comentarios
Saludos
Santiago

mayo 24, 2017 a las 11:07 am #1283531

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Gracias, Santiago. Sin embargo has olvidado decirme como reproducir este comportamiento. He tratado de hacer la compra de un producto, pero ninguno de tus products es funcional (no se puede seleccionar la talla, incluso con WPML desactivado).

¿Me podrías indicar un producto con el que pueda hacer las pruebas, así como los pasos necesarios para reproducirlo?

Saludos

mayo 24, 2017 a las 11:15 am #1283539

santiagoT-5

Hola Andres
Este es el producto hidden link

Prueba la compra con tarjeta (en entorno de pruebas)

4548812049400004
Caducidad 12/20
Código CVV2 123
Código CIP 123456
Espero tus comentarios
Saludos
Santiago

mayo 24, 2017 a las 2:06 pm #1283722

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Después de algunas pruebas, el problema viene de una incompatibilidad con tu plugin WooCommerce Servired/RedSys Spain Gateway. Si utilizas uno de los métodos por defecto de WooCommerce, todo funciona correctamente.

He creado una copia de tu sitio y el problema persiste. He borrado la traducción del end-point y la situación no cambia para nada.

He tratado de acceder al sitio del autor del plugin pero no parece existir más, o tiene una URL errada. Bajo este panorama, no estaría mal que contactases al autor del plugin ya que puede estar al tanto de esta solución y ofrecerte una solución más rápida.

Por lo pronto, crearé una nueva instalación con este plugin para descartar cualquier otro factor de externo y luego de esto podremos contactar al autor del plugin para comenzar un proceso con nuestro Equipo de compatibilidad.

Como puedes ver esto puede tomar algo de tiempo, así que si tienes poco tiempo y tienes otras opciones de Gateway, no estaría mal.

Regreso tan pronto tenga nuevos resultados.

Saludos

1-woocommerce-standar-working.png
mayo 24, 2017 a las 2:37 pm #1283749

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola de nuevo,

He creado una nueva instalación de prueba y el problema se repite. Para asegurarnos que este tema/plugin sea compatible con WPML necesitamos contactar al autor del plugin y trabajar con él para resolver este problema.

¿Podrías darnos un link de la página donde descargaste (o compraste) tu plugin así como la información de contacto (email) del autor del plugin para que podamos contactarlo?

No necesitas hacer nada, sólo darnos el nombre y correo del auto. Nosotros lo contactaremos.

Saludos

mayo 24, 2017 a las 2:51 pm #1283761

santiagoT-5

Hola Andres,
Si o si nuestro metodo de pago es con tarjeta del proveedor Redsys. Es la primera vez en mi vida que hay problema con este tema. El plugin utilizado es WooCommerce One Page Shopping by OptArt | Piotr Szczygiel . The Plugin URL is hidden link vendido en Envato market y normalmente no tenemos problema alguno con ellos, por otro lado el plugin que viene por defecto del systema de redsys daba el mismo problema...
Espero tus comentarios
Saludos Santiago

mayo 24, 2017 a las 2:54 pm #1283763

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

No estoy seguro de entender, el problema es con el plugin WooCommerce Servired/RedSys Spain Gateway, ¿me podrías decir por qué me das la información del WooCommerce One Page Shopping?