Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

This thread is resolved. Here is a description of the problem and solution.

El problema: Quiero eliminar el slug /category/ de mi URL pero me genera errores 404.

La solución: - Ve a WPML > Settings > Traducción de taxonomías. - Traduce /category/ por /category/ ya que esto no va a aparecer en la URL. - Activé nuestro SEO Multilingual.

Documentación: https://wpml.org/documentation/plugins-compatibility/using-wordpress-seo-with-wpml/

Etiquetado: 

This topic contains 13 respuestas, has 2 mensajes.

Last updated by ma-carmenT hace 2 meses, 2 semanas.

Assigned support staff: Andrés.

Autor Publicaciones
agosto 6, 2019 a las 5:07 pm #4349689

ma-carmenT

Hola,

Tengo el blog traducido en catalán en

hidden link

el original en castellano se encuentra en

hidden link

He revisado y salvado varias veces la traducción del Blog en Taxonomías pero al acceder al enlace en catalán aparece el error 404 y no encuentro donde puede estar el problema.

Muchas gracias,

Saludos cordiales

agosto 6, 2019 a las 5:33 pm #4349769

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola,

Bienvenido al soporte de WPML.

1. Ve a tu Escritorio > Ajustes > Lectura y asegúrate de haber seleccionado una página blog en esta sección.

2. Si tu tema te permite manipular la asignación de una página Blog, asegúrate que allí también hayas seleccionado la misma página en tus diferentes idiomas.

3. Finalmente, ¿podrías ir a tus Ajustes > Enlaces permanentes y guardar tus ajustes de nuevo? No debes cambiar nada, sólo guardarlos de nuevo.

Un saludo,
Andrés

agosto 7, 2019 a las 11:46 am #4354531

ma-carmenT

Hola Andrés, gracias por tu respuesta.

He hecho lo que me has indicado, sigue sin funcionar, el blog en catalán no aparece, de hecho, ahora hay una diferencia.

Antes, al darle a la banderita en catalán, direccionaba a la url del blog en catalán, pero aparecía error 404. Ahora, al darle a la banderita en catalán, no hace absolutamente nada, se queda en el blog en castellano y tampoco aparece ni el error 404 claro.

Te comento que en mi web el BLOG no existe como página o como entrada, es simplemente una categoría que tiene configuradas unas características de presentación o visualización, pero como digo, no es ni una página ni una entrada. Pero si funciona en castellano debería funcionar también en catalán ¿no?

¿Puede tener algo que ver que el menú en catalán aún no esté hecho? Aunque los artículos del BLOG sí aparecen correctamente en catalán y no están asignados a ningún menú.

Muchas gracias,

Saludos,

agosto 7, 2019 a las 12:58 pm #4355255

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Gracias por la aclaración. En efecto, creo que el problema está ligado a tu configuración. Si revisas tu página original:
- hidden link
Verás que e el selector apunta a:
- hidden link

Por otra parte, si miras el código fuente, podrás ver que las etiquetas hreflang apuntan a:
- hidden link
- hidden link

¿Me podrías decribir de una manera detallada como configuraste tu página para que tu blog sea
- hidden link
y no
- hidden link

¿Acaso utilizas la opción de Yoast?

agosto 7, 2019 a las 3:53 pm #4356597

ma-carmenT

Hola Andrés, gracias por tu respuesta.

Antes de nada, indicarte que donde tú me dices al principio que la página original - hidden link

El selector apunta a: hidden link

A mí donde me apunta realmente es a: hidden link (sin las ‘ca’ del idioma catalán) no sé si ahí tenemos alguna diferencia o no te he entendido bien.

Luego al final de tu respuesta las dos url’s que me das son de hecho exactamente la misma por lo que veo. Supongo que en el primer caso te refieres a hidden link (sin que se visualice la ‘categoria’)

Y efectivamente, uso el componente Yoast SEO que en la opción URL’s de Categorias/Elimina el prefijo de las categorías está establecido en ‘Quitar’

Muchas gracias nuevamente,

Saludos,

agosto 7, 2019 a las 4:24 pm #4356753

ma-carmenT

Hola de nuevo,

He hecho estas comprobaciones adicionales:

En la opción de Yoast SEO que he mencionado ‘URL’s de Categoria/ he establecido la opción en ‘Conservar’

He comprobado que el blog en catalán ahora sí aparece.

Después, y creo que esto tenía mucho que ver, he ido a WPML/Traducción de taxonomías/Categorías y en la opción ‘Traducciones de etiquetas Categoría de taxonomía y slug’ He comprobado que tanto para español como para catalán el slug era exactamente el mismo: ‘categoria’ (como en realidad en ambos idiomas se escribe igual)

Luego lo que he hecho ha sido renombrar el slug en catalán a: ‘categoriaca’ diferenciándolo del español que está en: ‘categoria’

Después he ido a Ajustes/ Enlaces permanentes y he guardado de nuevo sin cambiar nada

He comprobado que el blog en catalán sigue apareciendo correctamente.

Lo que no entiendo es porqué, después, al volver a establecer en ‘Quitar’ la opción ‘URL’s de Categoria’ en Yoast SEO, vuelve a darme error 404 al intentar acceder al blog en catalán.

¿No se trata esta opción simplemente de ‘no visualizar’ la palabra ‘categoria’ en el slug?

Si en realidad están correctamente definidas, ¿Por qué falla?

Muchas gracias nuevamente,

Saludos,

agosto 7, 2019 a las 5:26 pm #4357145

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

¡Gracias por tus aclaraciones! 🙂

He creado un sitio de pruebas para ti. Puedes acceder a este simplemente haciendo click en en siguiente enlace:
hidden link

La idea es que cargues tu plugin Yoast SEO y nos ayudes a reproducir el problema. De esta manera, si efectivamente se trata de un problema de compatibilidad con esta funcionalidad, podremos acelerar el proceso y contactar a nuestro Equipo de compatibilidad y trabajar con el autor en la resolución de tu problema.


No tienes que recrear tu sitio, simplemente instalar lo mínimo necesario para reproducir el problema.

Saludos,
Andrés

agosto 8, 2019 a las 5:15 pm #4364991

ma-carmenT

Hola Andrés, muchas gracias, he hecho lo siguiente:

- He instalado y configurado Yoast SEO tal y como lo tengo en mi sitio
- He instalado la plantilla Premium que utilizo. Plantilla Cloe Brooks de Envato/THEMEREX
- He creado una página de pruebas que está anclada a un elemento de menú en el menú principal. Esta página sólo está en español en ningún otro idioma. De hecho, es así como está todavía en mi sitio, la página de Inicio la tengo en español, pero aún no he realizado la traducción al catalán.
- He creado en taxonomías la categoría Blog, esta categoría está en inglés, español y catalán. El slug de la categoría, en español es ‘categoria’ y en catalán es ‘categoriaca’ para diferenciarlos
- He creado un artículo de prueba para el Blog, el artículo está en inglés, español y catalán, en francés no.
- Hay un elemento de menú de nombre Blog y en su interior, un subelemento también con nombre Blog, así es como lo tengo en mi sitio ya que en realidad, en mi sitio, dentro del elemento principal Blog hay 3 subelementos más, uno de ellos el que lleva realmente al blog (a la categoría Blog claro está).

Entonces, en esta instalación, el artículo del Blog tanto en inglés como en español se visualizan correctamente, pero el catalán falla exactamente igual que lo hace en mi sitio, es decir, no se visualiza. He de decir que inicialmente me dio error 404 , ahora ya ni eso (igual que en mi sitio).

Al intentar acceder al catalán simplemente no pasa nada, se queda dónde está.

Muchas gracias nuevamente,

Saludos cordiales,

agosto 8, 2019 a las 5:27 pm #4365051

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Gracias por tu ayuda. Ahora bien, para simplificar el problema:

- He visto que con un tema por defecto de WordPress el problema persiste. Por tanto, borré tu tema ya que no interviene.

- Eliminé el francés ya que no interviene.

- Visité la categoría blog, sin embargo sus slugs son:
x blog-es
x blog-ca
x blog

Y no categoria y categoria-ca, ¿a qué te refieres con esto?

Por el momento, tengo la sensación que utilizas muchos elementos que repiten slugs y por ellos los errores 404. ¿No sería más fácil crear una página Blog y hacer el llamado de tus artículos allí?

agosto 8, 2019 a las 5:41 pm #4365197

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Creo entender a que te referías con la traducción del slug /category/, sin embargo, no se por qué es necesario si al mismo tiempo lo eliminas con Yoast.

- He ido a WPML > Settings > Traducción de taxonomías.
- Volvi a traducir /category/ por /category/ ya que esto no va a aparecer en la URL.
- Activé nuestro SEO Multilingual.
Todo funciona correctamente.
¿Podrías verificarlo?

agosto 8, 2019 a las 5:44 pm #4365201

ma-carmenT

Hola, te me adelantaste, te había escrito esto:
(ahora verifico lo que me dices ...)

Hola Andrés,

Con lo de ‘categoria’ y ‘categoriaca’ me refiero a la traducción en:
WPML/Traducción de taxonomía/categorias/Traducciones de etiquetas Categoria de taxonomía y slug

(abajo al final del todo de la pantalla) Te adjunto imagen

Por lo que me dices de los slugs, entiendo que se repiten si son exactamente los mismos, pero si hay caracteres que los diferencien entiendo que no debería haber repetición.

Tengo ya el trabajo hecho en categorías y sinceramente, si es posible, prefiero mantenerlo así en lugar de crear páginas para el Blog. Entiendo tu razonamiento.

Además, me llama la atención por ejemplo, en mi sitio solo hay 2 blogs, español y catalán. En el sitio de pruebas que hemos hecho, está en inglés, español y catalán y falla justamente con el mismo idioma.

Muchas gracias otra vez,

Saludos,

agosto 8, 2019 a las 6:00 pm #4365265

ma-carmenT

Hola,

Está verificado, ahora funciona correctamente ¡!!! Aunque tuve que volver a Ajustes y guardar nuevamente en Enlaces permanentes.

Parece que se me fue la mano en las traducciones ….

Muchísimas gracias por tu ayuda y atención Andrés,

Saludos cordiales,

agosto 8, 2019 a las 6:14 pm #4365333

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

¡Me alegra saber que puedes continuar con la traducción de tu sitio! 🙂
No dudes en cerrar este ticket y abrir uno nuevo si necesitas más ayuda.
Saludos

agosto 8, 2019 a las 6:19 pm #4365337

ma-carmenT

My issue is resolved now. Thank you!