Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

El problema: Hasta el otro día todo funcionaba pero ahora que lo único que hicimos fue añadir nuevos proyectos (portafolios del tema Avada) y solo se visualizan en inglés. Castellano y catalán dan error 404 aunque la URL es correcta.

La solución: - Verifica que la traducción del slug portafolio en WPML es la misma que utilizas en los ajustes de tema de Avada en todos tus idiomas.

Documentación: https://wpml.org/documentation/theme-compatibility/using-wpml-with-the-avada-theme/

Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en los foros 6 días a la semana, 22 horas por día.

Etiquetado: 

This topic contains 11 respuestas, has 2 mensajes.

Last updated by ireneL-3 hace 2 years, 4 months.

Assigned support staff: Andrés.

Autor Mensajes
mayo 8, 2018 a las 12:06 pm

ireneL-3

Estoy tratando de: publicar nuevos proyectos en la sección "Proyectos financiados". La web es en 3 idiomas. Nosotros creamos el nuevo proyecto inicialmente en castellano, luego lo traducimos al inglés y al catalán. Hasta el otro día todo funcionaba pero ahora que lo único que hicimos fue añadir nuevos proyectos solo se visualizan en inglés. Solo se ven correctamente en inglés. Castellano y catalán dan error 404 aunque la URL es correcta: Es la que aparece en el portfolio y la que aparece cuando se carga el link.
Además algunas veces clicando sobre el item del portfolio siempre en la pagina "Proyectos financiados", no se carga la url de su contenido si no que muestra todas las imágenes de esa categoría (adjunto pantallazo)... pero esto lo hace solo a veces de manera aleatoria... no he conseguido individuar ningún patrón de cuando pasa...

URL de (mi) sitio web donde aparece el problema: hidden link (por ejemplo)

Yo esperaba ver: el contenido insertado en la pagina

En vez de eso, obtuve: error 404

mayo 8, 2018 a las 6:33 pm #2038378

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola,

Bienvenido al soporte de WPML.

Esta situación se debe a que existe un conflicto entre el slug que has dado a tu portafolio y sus traducciones.

Como puedes ver en la primera captura de pantalla se encuentra en español y traducido a los otros idiomas. Pero si vas a Avada, éste está en inglés para todos los idiomas.

Una vez corriges esto, todo funciona correctamente.

Un saludo,
Andrés

mayo 9, 2018 a las 9:44 am #2047887

ireneL-3

Thanks Andrés!! Diría que lo había configurado también en Avada de hecho esto funcionaba correctamente hasta el otro día... puede ser que pierda alguna configuración actualizando AVADA?... También me pasa a menudo que no se guarde lo que inserto y guardo, sobre todo traduciendo a los otros idiomas... insertamos el texto en su idioma, guardamos y no se guarda nada... se queda en el idioma principal... ¿tienes idea de a que puede atribuirse?

gracias

mayo 9, 2018 a las 9:47 am #2047993

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

¡Me alegra saber que tu problema inicial ha sido resuelto! 🙂

Con respecto a tus comentarios, comenzaría por actualizar WPML y Avada. Luego de ello si el problema persiste y como por normas del foro sólo podemos tratar un asunto a la vez, te pediría que abrieras un nuevo ticket. Esto nos ayuda a brindarte un mejor servicio y también a otros usuarios con problemas similares a los tuyos a que encuentren la información aquí mostrada. Me lo puedes asignar directamente si así lo deseas y seguimos trabajando en ello inmediatamente.

Saludos

mayo 9, 2018 a las 9:47 am #2048048

ireneL-3

Gracias Andrés!! Diría que lo tenía configurado también en AVADA de hecho funcionaba correctamente la semana pasada.. actualicé el template.. ¿podría haberse perdido esa información actualizándolo? es lo único que se me ocurre porqué estaba puesto...

Otra cosa que nos está pasando a menudo es que no se guarden las traducciones que introducimos... traducimos una entrada y la guardamos, y no se guarda... ¿sabes a que podría ser atribuido esto?

gracias y saludos

mayo 9, 2018 a las 9:51 am #2048375

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Me alegra saber que tu problema inicial ha sido resuelto! ?

Con respecto a tus comentarios, comenzaría por actualizar WPML y Avada. Luego de ello si el problema persiste y como por normas del foro sólo podemos tratar un asunto a la vez, te pediría que abrieras un nuevo ticket. Esto nos ayuda a brindarte un mejor servicio y también a otros usuarios con problemas similares a los tuyos a que encuentren la información aquí mostrada. Me lo puedes asignar directamente si así lo deseas y seguimos trabajando en ello inmediatamente.

Saludos

mayo 9, 2018 a las 9:53 am #2048444

ireneL-3

ok perfecto así haré! gracias!!!

mayo 9, 2018 a las 10:12 am #2048847

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

¡Super! 🙂
Que tengas un buen día.

mayo 21, 2018 a las 8:42 am #2199547

ireneL-3

Hola Andrés...no me lo puedo creer pero vuelvo a tener el mismo problema que ya resolviste... está vez pero ya veo correcto lo que tu hiciste anteriormente... es decir que cada idioma tiene su slug bien puesto en su idioma correspondiente (mira capturas de pantallas). ¿que puede ser esta vez? La verdad es bastante estresante porqué creemos funcione correctamente y luego descubrimos que no por casualidad...

junio 6, 2018 a las 7:55 am #2278311

ireneL-3

Hola Andrés...no he recibido respuesta a este mensaje...

¿Me podéis ayudar?

no me lo puedo creer pero vuelvo a tener el mismo problema que ya resolviste... está vez pero ya veo correcto lo que tu hiciste anteriormente... es decir que cada idioma tiene su slug bien puesto en su idioma correspondiente (mira capturas de pantallas). ¿que puede ser esta vez? La verdad es bastante estresante porqué creemos funcione correctamente y luego descubrimos que no por casualidad...

junio 6, 2018 a las 8:13 am #2278566

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola,

Lamento haber perdido tu notificación anterior, como el ticket está marcado como resuelto a veces sucede. ¿Podrías abrir un ticket y asignármelo directamente?

Saludos

junio 6, 2018 a las 8:21 am #2278708

ireneL-3

ok gracias!