Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

Our next available supporter will start replying to tickets in about 5.10 hours from now. Thank you for your understanding.

Etiquetado: 

This topic contains 12 respuestas, has 2 mensajes.

Last updated by Andrés hace 2 meses, 3 semanas.

Assigned support staff: Andrés.

Autor Publicaciones
julio 29, 2019 a las 3:58 pm #4301559

johnB-41

Buenos dias,
Estoy teniendo problemas en mi pagina smallbusinessliability.com para poder realizar la traducción. no puedo crear las url personalizadas, según, no se puede sobreescribir, sin embargo ya verifique las instrucciones y si es sobreecribe. anexo una imagen,.

Ya desinstale el plugin y lo volvi a instalar, también genere nueva clave.

julio 30, 2019 a las 5:06 am #4304743

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola,

Bienvenido al soporte de WPML.

Si entiendo bien tu problema, te refieres a la alerta que te aparece en WPML > Idiomas. Si ese es el caso, pero la generación de enlaces permanentes funciona correctamente, puedes obviar dicho mensaje ya que se trata de un falso positivo al WPML no poder leer tus ajustes de servidor correctamente.

Un saludo,
Andrés

julio 30, 2019 a las 1:07 pm #4307807

johnB-41

Andres, mira la dirección o URL que crea, cuando realizo la traducción de un articulo. hay como un exceso de "hidden link"

julio 30, 2019 a las 2:42 pm #4308613

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Gracias por la aclaración. En ese caso:

1. ¿Podrías ir a tus Ajustes > Enlaces permanentes y guardar tus ajustes de nuevo? No debes cambiar nada, sólo guardarlos de nuevo.

2. ¿Podrías compartir el contenido de tu archivo .htaccess?

Saludos

julio 30, 2019 a las 2:46 pm #4308705

johnB-41

Perfecto,

1- Ya salve nuevamente la opción de enlaces permanentes.
2- Te anexo el contenido del archivo .htacess

# BEGIN DEFLATE COMPRESSION
<IfModule mod_deflate.c>
# Compress HTML, CSS, JavaScript, Text, XML and fonts
AddOutputFilterByType DEFLATE application/javascript
AddOutputFilterByType DEFLATE application/rss+xml
AddOutputFilterByType DEFLATE application/vnd.ms-fontobject
AddOutputFilterByType DEFLATE application/x-font
AddOutputFilterByType DEFLATE application/x-font-opentype
AddOutputFilterByType DEFLATE application/x-font-otf
AddOutputFilterByType DEFLATE application/x-font-truetype
AddOutputFilterByType DEFLATE application/x-font-ttf
AddOutputFilterByType DEFLATE application/x-javascript
AddOutputFilterByType DEFLATE application/xhtml+xml
AddOutputFilterByType DEFLATE application/xml
AddOutputFilterByType DEFLATE font/opentype
AddOutputFilterByType DEFLATE font/otf
AddOutputFilterByType DEFLATE font/ttf
AddOutputFilterByType DEFLATE image/svg+xml
AddOutputFilterByType DEFLATE image/x-icon
AddOutputFilterByType DEFLATE text/css
AddOutputFilterByType DEFLATE text/html
AddOutputFilterByType DEFLATE text/javascript
AddOutputFilterByType DEFLATE text/plain
AddOutputFilterByType DEFLATE text/xml
</IfModule>
# END DEFLATE COMPRESSION

# BEGIN GZIP COMPRESSION
<IfModule mod_gzip.c>
mod_gzip_on Yes
mod_gzip_dechunk Yes
mod_gzip_item_include file \.(html?|txt|css|js|php|pl)$
mod_gzip_item_include handler ^cgi-script$
mod_gzip_item_include mime ^text/.*
mod_gzip_item_include mime ^application/x-javascript.*
mod_gzip_item_exclude mime ^image/.*
mod_gzip_item_exclude rspheader ^Content-Encoding:.*gzip.*
</IfModule>
# END GZIP COMPRESSION

<IfModule mod_expires.c>
ExpiresActive On

# Images
ExpiresByType image/jpeg "access plus 1 year"
ExpiresByType image/gif "access plus 1 year"
ExpiresByType image/png "access plus 1 year"
ExpiresByType image/webp "access plus 1 year"
ExpiresByType image/svg+xml "access plus 1 year"
ExpiresByType image/x-icon "access plus 1 year"

# Video
ExpiresByType video/mp4 "access plus 1 year"
ExpiresByType video/mpeg "access plus 1 year"

# CSS, JavaScript
ExpiresByType text/css "access plus 1 month"
ExpiresByType text/javascript "access plus 1 month"
ExpiresByType application/javascript "access plus 1 month"

# Others
ExpiresByType application/pdf "access plus 1 month"
ExpiresByType application/x-shockwave-flash "access plus 1 month"
</IfModule>

# TN - BEGIN Cache-Control Headers
<ifModule mod_headers.c>
<filesMatch "\.(ico|jpeg|jpg|png|gif|swf|pdf|svg)$">
Header set Cache-Control "public"
</filesMatch>
<filesMatch "\.(css)$">
Header set Cache-Control "public"
</filesMatch>
<filesMatch "\.(js)$">
Header set Cache-Control "private"
</filesMatch>
<filesMatch "\.(x?html?|php)$">
Header set Cache-Control "private, must-revalidate"
</filesMatch>
</ifModule>
# TN - END Cache-Control Headers

#BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

#END WordPress

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

julio 30, 2019 a las 2:50 pm #4308715

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Gracias por compartir esta información. De tu archivo .htaccess puedo ver que tienes repetido dos veces la parte de reescritura y muy probablemente esto esté asociado a tu problema. Te recomiendo que reemplaces tu .htaccess por el archivo original y evites modificarlo.

julio 30, 2019 a las 3:14 pm #4309039

johnB-41

He reemplazado el archivo, actualmente el contenido es este:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

Posteriormente salve los enlaces permanentes nuevamente.
Procedí a crear la traducción de una pagina y te comparto el link que me ha creado.

Nose porque repite tantas veces el es/

julio 30, 2019 a las 3:24 pm #4309155

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

1. ¿Podrías verificar que el .htaccess sigue sin modificarse después de guardar los enlaces?

2. En tu sitio de prueba podrías revisar que esta situación se presenta cuando:
- Sólo el paquete WPML está activado. Esto nos dirá si hay algún problema de interacción con otro plugin.
- Cambias a un tema por defecto de WordPress como el Twenty Fourteen. Esto nos dirá si hay un problema de interacción con tu tema.
- Si el problema desaparece, activa uno por uno para determinar quién genera esta situación.

julio 31, 2019 a las 2:04 pm #4315121

johnB-41

1- el archivo .htaccess permanece sin modificación.
2- He realizado las pruebas indicadas y se repiten los errores.

Lo que he podido observar con respecto a mi otros sitios es que no se crea el nombre del dominio allí donde selecciono en rojo, en mis otras paginas alli esta el nombre del dominio, aquí por alguna razón no esta.

julio 31, 2019 a las 2:13 pm #4315183

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

¿Me podrías confirmar que no has comenzado a traducir tu contenido?

Si no lo has hecho, intentemos reinicializar tu WPML:
- Ve a WPML > Soporte.
- Solución de problemas.
- Reiniciar.
x Estoy a punto de restablecer todos los datos de traducción e idioma.
x Restablecer y desactivar WPML

¿Esta vez puedes terminar la instalación de tu WPML correctamente?

julio 31, 2019 a las 3:56 pm #4316281

johnB-41

Habia realizado ciertas traducciones, pero no importa, procedi a reiniciar el pluging como indico.
Lo active y termine la configuración.
Me salía el mismo error en rojo.
procedí igualemente a cambiarlo
salve los enlaces permanentes
realice una traduccion
y no funciono, la direeción creada fue esta:

hidden link

Verifique el archivo .htaccess y no tiene agregado nuevos datos como la primera vez. solamente este es el contenido.

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

julio 31, 2019 a las 3:57 pm #4316287

johnB-41

[removed]

julio 31, 2019 a las 4:16 pm #4316675

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Estos resultados parecen indicar que no tienes la sobreescritura activada o que algo en los ajustes de tu servidor no te está permitiendo la activación correcta de este ajuste.

Por esta razón he creado un sitio de prueba en nuestro servidor Cloudways. De esta manera puedes migrar tu contenido para así realizar la depuración necesaria y no poner tu sitio en riesgo.

Puedes encontrar las instrucciones para la migración en el mensaje privado anterior.