Skip Navigation

Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en los foros 6 días a la semana, 22 horas por día.

This topic contains 11 respuestas, has 2 mensajes.

Last updated by Andreas W. hace 2 meses, 1 semana.

Assigned support staff: Andreas W..

Autor Mensajes
julio 6, 2021 a las 3:58 pm #9141073

siroT-3

Al traducir el footer de mi web a través de las Plantillas de Elementor se rompen todos los estilos tanto en inglés como en español ¿Cuál es la forma correcta de hacerlo?

Gracias.

Captura de pantalla 2021-07-06 175515.png
Captura de pantalla 2021-07-06 175501.png
Captura de pantalla 2021-07-06 170543.png
julio 7, 2021 a las 1:22 am #9143385

Andreas W.
Supporter

Languages: Inglés (English ) Español (Español ) Alemán (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hola,

En este punto, no estoy seguro de si esto podría ser un problema de memoria de WP o un problema con la traducción de los íconos de redes sociales en el pie de página.

Puedo ofrecerme a echar un vistazo al sitio. Por favor, dame acceso como administrador. El formulario de respuesta privada está habilitado.

Asegúrate de realizar una copia de seguridad del sitio y la base de datos antes de proporcionar acceso.

Saludos codiales
Andreas

julio 7, 2021 a las 7:22 pm #9151307

Andreas W.
Supporter

Languages: Inglés (English ) Español (Español ) Alemán (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hola,

El Editor de traducción avanzado de WPML (ATE) no puede traducir el markup de HTML, que en este caso se utiliza dentro del pie de página.

Pude solucionarlo editando la plantilla de pie de página en inglés manualmente, simplemente reemplazando el código HTML y guardándolo.

Espero que esta sea una solución aceptable para ti.

Saludos cordiales
Andreas

julio 8, 2021 a las 8:12 am #9154145

siroT-3

¿Cómo podría hacer eso? Al editar la plantilla en inglés se replica también en español...

Gracias.

julio 8, 2021 a las 11:26 am #9157057

siroT-3

No veo el pie traducido en inglés como dices...

julio 8, 2021 a las 8:50 pm #9160233

Andreas W.
Supporter

Languages: Inglés (English ) Español (Español ) Alemán (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hola,

Esto parece ser un problema entre Rhyse Theme, Elementor y WPML.

Puedo ver que el tema principal está usando la versión 2.0.1
mientras que la última versión disponible es la 3.0.3.

Actualice el tema principal y avíseme si el problema persiste.

Saludos cordiales
Andreas

julio 9, 2021 a las 10:53 am #9164317

siroT-3

El problema es que si actualizo el tema perderé todas las modificaciones CSS que hemos hecho.
Lo hablaré con mi equipo de desarrollo por si hubiera alguna solución.

Gracias.

julio 9, 2021 a las 9:42 pm #9167709

Andreas W.
Supporter

Languages: Inglés (English ) Español (Español ) Alemán (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hola,

Para este propósito, el sitio web utiliza un tema secundario (Child Theme).

Debe asegurarse de que los cambios realizados se coloquen dentro del directorio del tema secundario, no dentro del tema principal (Parent Theme).

Así, no perderá ningún cambio al actualizar el tema principal.

De todos modos, siempre asegúrese de recuperar el sitio web y la base de datos antes de actualizar.

Si el problema persiste mientras usamos la última versión del tema, tomaremos más medidas.

Saludos cordiales
Andreas

julio 20, 2021 a las 8:38 am #9235047

siroT-3

Hola Andreas, ya he actualizado a la última versión. Cómo debería proceder ahora?

Gracias.

julio 21, 2021 a las 1:14 am #9240675

Andreas W.
Supporter

Languages: Inglés (English ) Español (Español ) Alemán (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hola,

¿Podría ser el caso de que haya estado utilizando contenido de demo para crear la página? Si es así, tenga en cuenta que no es recomendable utilizar el contenido de demo, ya que puede causar problemas con las traducciones.

He recreado el pie de página desde cero y ya no veo ningún problema. El único problema fue que los íconos sociales no aparecen en una línea horizontal, lo que se solucionó después de realizar una pequeña edición manual.

De alguna manera, la creación de este nuevo pie de página eliminó el encabezado del sitio.

¿Podrías agregarlo nuevamente y me dejes saber si hay mas problemas entre el tema, Elementor y WPML?

Saludos cordiales
Andreas

julio 21, 2021 a las 8:12 am #9242619

siroT-3

No hay forma de agregar nuevamente el menú, debería aparecer por sí solo. No tiene ningún sentido que al traducir el footer desaparezca el menú. Voy a recuperar la versión de la web anterior al cambio para que reaparezca el menú.

Gracias.

julio 21, 2021 a las 10:54 pm #9248103

Andreas W.
Supporter

Languages: Inglés (English ) Español (Español ) Alemán (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hola,

Si exacto, no está claro por qué ocurre este problema, pero como en realidad afecta el contenido original, es posible que no esté relacionado con WPML. ¿El header funciona como se esperaba si deshabilita todos los complementos de WPML?

Recuerdo que ya teníamos un ticket anterior sobre problemas con el header.

Mejor por ahora recuperes el sitio y luego crees un nuevo pie de página, que resolvió el problema en mi prueba. Incluso pude usar la plantilla de pie de página guardada anteriormente dentro del nuevo pie de página, por lo que no es necesario volver a crear desde cero.

Por favor, avíseme si necesita más ayuda.

Saludos cordiales
Andreas

El debate ‘[Cerrado] Error al traducir Footer con Elementor’ está cerrado y no admite más respuestas.