Skip Navigation

Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en los foros 6 días a la semana, 22 horas por día.

Etiquetado: 

This topic contains 6 respuestas, has 2 mensajes.

Last updated by Carlos Rojas hace 1 year, 7 months.

Assigned support staff: Carlos Rojas.

Autor Mensajes
marzo 5, 2019 a las 10:06 am

albaC

Estoy tratando de:

Traducir una página del portfolio del catalán al español.

URL de (mi) sitio web donde aparece el problema:

Mientras estoy haciendo la traducción, después de un cierto tiempo, aparece el siguiente error en el back-end: Se ha perdido la conexión. El guardado de los datos se ha desactivado hasta que vuelvas a conectar. Estamos haciendo una copia de seguridad de esta entrada en el navegador por si acaso. Y luego no me deja guardar los cambios.

Además, a veces, no siempre, al cargar el web aparece este otro error en el front-end:

Internal Server Error.

Por cierto, no tengo el plugin Installer instalado. He leído en otros tickets que a veces este es el origen del problema, no en mi caso. Tampoco tiene que ver con otros plugins, lo hemos comprobado.

Yo esperaba ver:

Poder traducir y guardar el post, como antes, que no había ningún problema.

Muchas gracias!

marzo 6, 2019 a las 3:05 pm #3279875

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hola,
Muchas gracias por contactar con el servicio de soporte de WPML.

1.- He intentado autenticarme en el sitio pero las credenciales suministradas no funcionaron. Su próxima respuesta será privada y en ella podrá volver a suministrar las credenciales de una manera segura.

2.- Por favor incremente el límite de memoria de PHP. El mínimo requerido es 128Mb: https://wpml.org/home/minimum-requirements/
Para ello puede agregar el siguiente código al archivo wp-config.php:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');

- Añádelo encima de la línea /* That's all, stop editing! Happy blogging. */

Me puede decir si el problema persiste luego de aumentar el límite de memoria?

Saludos cordiales,
Carlos

marzo 7, 2019 a las 10:37 am
marzo 7, 2019 a las 3:06 pm #3285113

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hola Alba,

Muchas gracias por la información suministrada, sin embargo sigo sin poder acceder. Cuando intento autenticarme el sitio se redirecciona a la misma página de autenticación.

Me gustaría pedirle que realice los siguientes pasos con el objetivo de aislar la causa del problema:
- Crea una copia de seguridad del sitio completo.
- Actualiza todos los plugins y/o plugins desactualizados, si corresponde.
- Borra cualquier memoria cache que pueda existir.
- Desactiva todos los plugins excepto los de WPML.
- Activa un tema por defecto de WordPress, por ejemplo: Twenty Nineteen.
- Si el problema desapareció comienza activando el tema y luego los plugins uno por uno hasta que el problema vuelva a aparecer.

Me puedes decir el resultado de los pasos anteriores?

Nota: También me gustaría pedirte que mantengas la consola de Javascript del navegador abierta por si aparece algún error.

Quedo a la espera de tu respuesta.
Saludos cordiales,
Carlos

marzo 8, 2019 a las 2:54 pm #3293378

albaC

Hemos hecho todo lo que nos has pedido y el error persiste.

Los accesos funcionan perfectamente. ¿Lo puedes volver a probar? No entiendo nada...

marzo 8, 2019 a las 4:08 pm #3294130

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hola,
Esta vez he podido entrar al sitio, en las veces anteriores no se autenticaba.

He intentado reproducir el problema pero no he podido. Me gustaría pedirle que activara el modo de depuración de WordPress siguiendo los pasos descritos en este enlace: https://codex.wordpress.org/Debugging_in_WordPress y me diga si aparece algún error en el archivo debug.log que debe aparecer dentro de la carpeta wp-content del sitio.

Quedo a la espera de su respuesta.
Saludos,
Carlos

marzo 11, 2019 a las 10:22 am #3309697

albaC

Hola!

Lo que sale en el debug:

Notice: ob_end_flush(): failed to send buffer of zlib output compression (1) in /home/joversoes/public_html/wp-includes/functions.php on line 4212

Notice: ob_end_flush(): failed to send buffer of zlib output compression (1) in /home/joversoes/public_html/wp-includes/functions.php on line 4212

Notice: ob_end_flush(): failed to send buffer of zlib output compression (1) in /home/joversoes/public_html/wp-content/plugins/really-simple-ssl/class-mixed-content-fixer.php on line 111

He intentado realizarte un vídeo para que puedas ver el error, pero va tan lento a cargar las páginas que no puedo. Para poder ver el error tienes que tener paciencia y esperarte una vez estás intentado editar la traducción de una página del portfolio. Sale pasados unos pocos minutos de edición y luego no puedes guardar.

Muchas gracias!

Saludos,

Alba

marzo 11, 2019 a las 5:17 pm #3314975

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hola Alba,
Muchas gracias por su respuesta.

De acuerdo a los mensaje de error del archivo debug.log la causa del problema no es WPML. En este caso le recomiendo que contacte al servicio de soporte de WordPress y pida ayuda a ellos, que de seguro le podrán guiar de manera mejor.

Por favor hágame saber si necesita más asistencia de mi parte y estaré más que dispuesto a seguir ayudándole.
Saludos cordiales,
Carlos