Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

This thread is resolved. Here is a description of the problem and solution.

Problema: Cuando traduzco una página, los estilos e Imagenes no se aplican a las traducciones.

Solución: Asegurate de seleccionar la opción "Duplicar imagen predeterminada" bajo el botón de guardar los cambios en WordPress y asegurate de tener los requisitos minimos de WPML antes de guardar los cambios.

Documentación Relevante: https://wpml.org/home/minimum-requirements/

This topic contains 4 respuestas, has 2 mensajes.

Last updated by Alejandro hace 5 meses.

Assigned support staff: Alejandro.

Autor Publicaciones
mayo 15, 2019 a las 2:41 pm #3817815

AOV

Buenas tardes,
necesito ayuda para este tema:

Al traducir las páginas al inglés (Inicio/Nosotros/Noticias/Contacto) se añaden títulos que están desactivados en español, aplica otros estilos CSS (le adjunto capturas para que vea las diferencias entre idiomas). En la página de Inicio hay texto que no aparece para traducir en el editor, todo lo que se ve en español desde la versión de ingles (home) y en la sección de Noticias (Blog) no parece el contenido, ni texto, ni imágenes, tampoco el Widget de menú lateral.

[REMOVED BY SUPPORTER]

Muchas gracias

mayo 15, 2019 a las 5:25 pm #3819095

Alejandro
Supporter

Languages: Inglés (English ) Español (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hola!
Bienvenido al Soporte WPML.
Haré mi mejor esfuerzo para ayudarte a resolver este problema.

Veamos, Accedí a tu página home y about us y vi que ambas tenían opciones como la del titulo, por ejemplo.

Éstas opciones usualmente vienen registradas en WordPress como "Custom Fields" (Campos personalizados) que no tenían configuración (eso usualmente lo hace el autor del tema).

Éstas opciones se encuentran en WPML > Configuración > Traducción de campos personalizados.

Las vas a reconocer facilmente porque vienen con el prefijo "ts_" y son bastante explicativas. la del titulo de la página por ejemplo se llama "ts_show_page_title" y basta cambiar su valor a "copiar" y presionar el botón "Aplicar" (ya yo hice esta por ti. Trata de configurar las demás).

Puedes encontrar más información en esta documentación: https://wpml.org/documentation/getting-started-guide/translating-custom-fields/

Luego tienes que actualizar las páginas con problemas (basta insertar un carácter al titulo y luego guardar la página. luego actualiza la traducción así el valor correcto pasará a la traducción.)

El problema de las imágenes del blog también puede ser un problema de configuración. si vas a WPML > Configuración y luego bajas hasta el final ("Traducción de multimedia"), podrás configurar que quieres que pase con las imágenes predeterminadas de los posts y páginas.

En este caso ya yo lo configuré por ti así que puedes dar una ojeada a las opciones que están activadas (yo activé "duplicar los elementos multimedia adjuntos para las traducciones" y "duplicar las imágenes destacadas para las traducciones" así que ya no debes hacer más nada).

Antes de proseguir te pido que desactives los sistemas de cache de tu páginas y que preguntes a tu hosting si ellos ofrecen también un sistema de cache a nivel de servidor y si es así, por favor te pido que lo desactives momentaneamente (sino, será dificl que procedimiento funciona y cuál no) porque al momento no logro acertarme al 100% que los procedimientos que te expliqué arriba sean los correctos para ti.

Saludos.

mayo 16, 2019 a las 12:03 pm #3825689
AOV

Hola Alejandro,
Muchas gracias por el esfuerzo.

Para la página de Noticias (Blog) y contacto ya se ve igual en inglés que español, mismas imágenes y estilos.

Para las páginas de Inicio y Nosotros sigue habiendo problemas de estilos, es como si no copiara los padding y margin de la de español.

He entrado en WPML > Configuración > Traducción de campos personalizados y marcado todos los prefijos “_ts” como copiar he hecho un cambio en español y después al traducir no me aparecen los campos para hacerlo, por ejemplo, en el primer slide de Inicio pone BOLSOS TOY & CLUTCHES y al entrar en el editor no veo la opción e traducir este texto.

Sobre Traducción de multimedia ¿la duplicación de imágenes significa que genera nuevas imágenes? siempre voy a usar las mismas imágenes, lo único que cambia es el texto. Si es así me gustaría eliminar el contenido duplicado para que pese menos la web y desactivarlo para siempre.

Muchas gracias!
Alberto

Los hilos nuevos creados por Alejandro y vinculados a este se encuentran a continuación:

https://wpml.org/es/forums/topic/dividir-errores-de-traduccion/

mayo 16, 2019 a las 3:09 pm #3827225

AOV

Hola Alejandro,
acabo de encontrar los campos que faltan para la página de Inicio, eran estos!
newts_product_brand
newts_product_brand_parent

Por otro lado, el caracter “&” lo muestra en HTML ¿cómo puedo arreglar esto?

Lo que no consigo es encontrar los errores de estilo de márgenes entre bloques (le adjunto capturas)

Muchas gracias!

mayo 16, 2019 a las 3:11 pm #3827317

Alejandro
Supporter

Languages: Inglés (English ) Español (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Acabo de dividir este ticket para tratar solo 1 problema por ticket, de acuerdo a las reglas de este forum.

Digamos que en este ticket resolvimos el problema del blog. así que cerraré este ticket y continuaré en el próximo.

Saludos.