Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

Hoy no hay asistentes de soporte disponibles en el foro Spanish. Siéntase libre de enviar sus tiques y les daremos trámite tan pronto como estemos disponibles en línea. Gracias por su comprensión.

Etiquetado: 

This topic contains 9 respuestas, has 2 mensajes.

Last updated by Andrés hace 2 años, 9 meses.

Assigned support staff: Andrés.

Autor Publicaciones
enero 18, 2017 a las 10:56 am #1184796

toniF-2

Los enlaces algunas veces no funcionan y me devuelve un error 404, página no encontrada. Sucede sobretodo en los productos: hidden link . Algunas veces al refrescar la ficha del producto se puede visualizar

¿Puede ser algun error de compatibilidad?, la plantilla utilizada Flatsome soporta WPML, gracias

saludos
Toni Fornés

enero 18, 2017 a las 11:59 am #1184853

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola Toni,

Bienvenido al soporte de WPML.

1. Veo que estás traduciendo to WooCommerce, ¿sabes que WPML tiene una aplicación especial para traducir e-commerce creados con WooCommerce?

Este plugin se llama WooCommerce multilingual, y es absolutamente necesario para traducir tu sitio con WooCommerce y WPML, así que antes de que procedas a traducir tu boutique, por favor lee esta guía e instálalo:
https://wpml.org/es/documentation-2/proyectos-relacionados/woocommerce-multilingual-ofrezca-sitios-web-con-ecomercio-en-varios-idiomas/

Necesitarás tener estos otros plugins instalados:
- WPML
- WPML String Translation
- WPML Translation Management
- WPML Media Translation
- WooCommerce Multilingual
- WooCommerce

2. ¿Podrías actualizar tu versión de WPML?

3. ¿Podrías actualizar tu versión de WordPress?

Un saludo,
Andrés

enero 18, 2017 a las 2:08 pm #1185009

toniF-2

Buenas tardes Andrés

He actualizado los plugins de WPML que comentas, pero al instalar el WPML Media Translation (la última versión), deja de funcionar el backoffice de wordpress, saliendo una pantalla en blanco y no pudiendo acceder al panel. ¿Sabes a que se puede deber?, gracias

Saludos
Toni Fornés

enero 18, 2017 a las 3:11 pm #1185099

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Toni, cuando tienes una pantalla en blanco por lo general tienes un error de PHP.

1. ¿Podrías revisar si existe algún error?

Sería genial si me puedes suministrar la información del debug.log de WordPress. Por favor, lee estas instrucciones:
https://wpml.org/documentation/support/debugging-wpml/

Por favor abre tu archivo wp-config.php y busca la línea que dice: define(‘WP_DEBUG’, false);. y cámbialo por:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

Luego busca en la carpeta /wp-content/ y mira si existe algún archivo debug.log.

Si puedes agregar la información del debug.log en pastebin.com y proveerme el link sería aún mejor (Es la manera más limpia porque algunas veces los logs pueden ser muy largos y la conversación se puede volver desordenar mucho).

2. Además, ¿podrías incrementar la memoria de tu sitio, sobre todo la WP Memory Limit a 256M? Si puedes suministrar más recursos, sería ideal.
Tus valores actuales son:
- MemoryLimit 128M
- WP Memory Limit 128M
https://wpml.org/home/minimum-requirements/

Muchas veces estos ajustes son bloqueados directamente desde la administración de tu hosting. En ese caso te recomiendo que los contactes directamente y si puedes pedir valores superiores a 128M, sería recomendable.

Nota: 128M es el mínimo necesario para WPML sin otros plugins y con un tema por defecto de WordPress.

enero 18, 2017 a las 5:35 pm #1185270

toniF-2

Hola Andrés

He seguido estos pasos:
1- Añadir estas líneas al archivo wp-config.php
2- Instalar el plugin WPML Media
3- Al comprobar que me sigue dando el error, pantalla en blanco y no poder acceder al backoffice de WP
4- He accedido por FTP a la carpeta wp-content y no hay ningún archivo debug
5- Por otro lado he contactado con mi proveedor de hosting para que aumente la Wp memory limit a 256MB

¿Que otras comprobaciones podemos realizar?, gracias

Saludos
Toni Fornés

enero 19, 2017 a las 10:06 am #1185744

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

¿Me podrías dar las credenciales de tu sitio web de prueba, de esta manera podemos dar un vistazo a tus ajustes, así como los pasos necesarios para reproducir este comportamiento?

Para esto, debes poder ver una forma protegida en la parte inferior de este tópico. (Te pide hacer un backup y un + Aviso legal). Una instalación de test es preferible y nos haría mucho más fácil hacer una evaluación. En cuanto tenga más información te lo haré saber

Importante: Haz un backup completo de tu sitio. Puedes usar un plugin como Duplicator para este propósito. Mira en: http://wordpress.org/plugins/duplicator/

Si no ves este formulario para completar los campos confidenciales NO los publiques, ya que serán visibles en el foro:
hidden link

Privacidad y seguridad al proporcionar información de Debug para soporte:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

enero 19, 2017 a las 12:06 pm #1185917

toniF-2

Hola Andrés

Recibides los datos de conexión FTP, backoffice worpdress...???? Me urge encontrar una solución puesto la web se tiene que dar de alta hoy mismo. A ver si podemos aclarar de donde viene la incidencia, muchas gracias por tu ayuda.

Saludos
Toni Fornés

enero 19, 2017 a las 12:06 pm #1185920

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Finalmente se había producido el siguiente error:

Fatal error: Uncaught exception 'InvalidArgumentException' with message 'element_id and type do not match for element_id:355 the database contains post_post while this function was called with post_attachment' in /Applications/MAMP/htdocs/onthegosystem/xococreo/wp-content/plugins/sitepress-multilingual-cms/classes/core-abstract-classes/class-wpml-set-language.php on line 28

Una vez corregido esta entrada en la tabla wp_icl_translations, pude activar WPML Media Translation.

¿Resuelve esto tu problema?

enero 19, 2017 a las 12:10 pm #1185927

toniF-2

Hola

Veo que en el backoffice de Wp el menu del plugin Woocommerce aún sale el simbolo de error (triángulo rojo), tengo que configurar algo más, por ejemplo el plugin WPML multilingual, perdere las traducciones ya hechas??, muchas gracias

saludos
Toni Fornés

enero 19, 2017 a las 12:13 pm #1185931

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Si, aún no has configurado tu WooCommerce Multilingual. Por favor sigue esta guía y no dudes en abrir un nuevo ticket si necesitas más ayuda:
https://wpml.org/es/documentation-2/proyectos-relacionados/woocommerce-multilingual-ofrezca-sitios-web-con-ecomercio-en-varios-idiomas/

Saludos