Skip Navigation

Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en los foros 6 días a la semana, 22 horas por día.

Our next available supporter will start replying to tickets in about 0.68 hours from now. Thank you for your understanding.

This topic contains 33 respuestas, has 2 mensajes.

Last updated by OscarO-3 hace 8 meses, 2 semanas.

Assigned support staff: Andrés.

Autor Mensajes
noviembre 7, 2019 a las 10:34 am #4904899

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola Oscar,

Como podrás imaginar, ha pasado más de 1 año desde que tratamos este asunto:

1. ¿Me podrías decir paso a paso cómo reproducir el problema?

2. ¿Me podrías compartir tus credenciales para que tengamos el mismo acceso en nuestro servidor?

Saludos

noviembre 8, 2019 a las 10:06 am #4911995

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

¡Muchas gracias, Oscar! 🙂
En efecto, he podido reproducir este comportamiento, sin embargo no he podido encontrar una solución hasta el momento. He contactado a nuestro 2nd tier y regreso cuando tenga novedades.
Saludos

noviembre 8, 2019 a las 10:37 am #4912305

OscarO-3

Hola Andrés,

Muchas gracias, esperemos que esta vez no tardemos tanto como en el anterior problema... :'(

Buen fin de semana!

noviembre 8, 2019 a las 11:23 am #4912747

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

En efecto, tendré que escalar tu caso.
Regreso tan pronto tenga novedades.
Saludos

noviembre 19, 2019 a las 8:17 am #4969321

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola Oscar,

Justo hemos lanzado una nueva versión de WPML 4.3.4 que podría haber resuelto tu problema. ¿Podrías hacer una copia completa de tu sitio y realizar la actulización?

Saludos

noviembre 19, 2019 a las 1:22 pm #4972629

OscarO-3

Hola Andrés,

Acabo de acceder al Portal y he actualizado los plugins: WPML Multilingual CMS, WPML String Translation, WPML Translation Management (aunque la versión a la que se me ha actualizado es la 4.3.3, no me aparece la 4.3.4, ¿a qué puede ser debido?).

En cuaquier caso, tras hacer esta actualización, el sistema no funciona, sigue pasando lo mismo.

Saludos,

noviembre 19, 2019 a las 2:25 pm #4973267

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

En caso que la última versión de WPML 4.3.4 no aparezca en tu sección de Plugins, por favor:
- Ve a Plugins -> Add new -> Commercial -> y haz click en el botón "check for updates".
Las nuevas versiones deberían estar ahora disponibles en dicha sección o también puedes regresar a la sección de Plugins y actualizar como lo haces con cualquier otro Plugin de WordPress.

Saludos

noviembre 19, 2019 a las 2:29 pm #4973285

OscarO-3

Hola Andrés,

Ahora sí la veo, muchas gracias.

No creo que pueda probarlo esta tarde, intento mañana a ver si hay suerte.

Saludos y gracias por tu ayuda,

noviembre 19, 2019 a las 2:32 pm #4973349

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Entiendo completamente. 🙂
Quedo atento a tus pruebas.
Saludos

noviembre 20, 2019 a las 9:15 am #4977975

OscarO-3

Hola Andrés, buenos días,

Acabo de hacer unas pruebas rápidas y tengo buenas y malas noticias.

Para empezar, he actualizado los siguientes plugins: WPML Multilingual CMS, WPML String Translation, WPML Translation Management a la última versión disponible.

He hecho pruebas con un pequeño set de formularios (4 o 5) y la funcionalidad Save and Continue se traducía tanto en los mensajes por pantalla como en las notificaciones por correo.

Hecha esta prueba, he pasado a la siguiente: actualizar a la última versión el plugin Gravity Forms Multilingual. Cuando lo he hecho, la funcionalidad de Save and Continue se traducía en los mensajes por pantalla pero no se traducía en las notificaciones por correo.

Así pues, parece que nos vamos acercando pero no acabamos de cerrar el tema :p

Saludos,

noviembre 20, 2019 a las 9:23 am #4978033

OscarO-3

Hola Andrés,

Más novedades, esta vez buenas parece.

He aplicado la antigua solución (https://wpml.org/es/forums/topic/funcionalidad-save-and-continue-no-se-traduce-gravity-forms/page/2/#post-2749252) a los ficheros actualizados y, entonces, todo vuelve a funcionar como debería.

Quiero probarlo todo en profundidad para asegurar que funciona, pero es una tarea larga, te aviso cuando la haya podido completar (a ver si mañana a última hora o el viernes).

De todas formas, tened en cuenta que sin este parche las traducciones por correo no se traducen, no sé si es un problema específico mío ni por qué no habéis incoporado esta solución a las últimas actualizaciones.

Hasta pronto,

noviembre 20, 2019 a las 10:48 am #4978897

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola Oscar,

¡Gracias por tu ayuda! Espero el resultado de tus pruebas para continuar.
Saludos

noviembre 21, 2019 a las 10:34 am #4986815

OscarO-3

Hola Andrés, buenos días,

Lamentablemente, no traigo buenas noticias.

He actualizado todos los plugins de WPML (incluído el Gravity Forms Multilingual). He vuelto a reproducir el truco que te indiqué ayer y sí, efectivamente, la funcionalidad de salvar y continuar parece funcionar (no lo he probado en todos los formularios), pero es que ahora cadenas que estaban traducidas y funcionaban sin problema no se traducen.

He probado a traducir dichas cadenas problemáticas a través de Traducción de cadenas y no parece funcionar.

He probado entonces a enviar dicho formulario a través del Administrador de Traducción. Cuando lo he editado, he visto que había varias cadenas que Traducción de cadenas daba como traducidas que el Administrador no las reconocía como tal. He traducido estas cadenas problemáticas pero, cuando pulso en Guardar, se queda pensando y pensando y pensando y tengo que acabar cerrando la pantalla sin que me haya aparecido el mensaje de guardado correctamente.

Sólo lo he probado con un formulario (el 13) para ver si así conseguía traducir las cadenas, por lo que no te puedo garantizar que este comportamiento sea así con todos (pero como comprenderás no voy a probarlo con todos....)

En cualquier caso, un sistema que estaba funcionando ha dejado de funcionar con las actualizaciones, esto es un fastidio 🙁

¿Cómo seguimos para solucionar este problema?

Saludos,

noviembre 21, 2019 a las 5:23 pm #4991711

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Gracias por tus comentarios, Oscar. Sin embargo, no estoy muy seguro de entender tu situación:
- El problema del correo y del Save and continue está resuelto. ¿Correcto?
- Sin embargo, otras cadenas del Gravity Form han dejado de funcionar. ¿Es eso lo que sucede?

Saludos

noviembre 21, 2019 a las 5:31 pm #4992021
OscarO-3

Hola Andrés,

Sí, lo que comentas es lo que sucede.

Sólo he revisado un par de formularios completos cuando he visto que aparecían problemas que antes no existían.

En esos dos formularios que he revisado, el problema de Save and Continue estaba resuelto pero cadenas que antes estaban traducidas ahora ya no lo estaban.

He intentado traducir esas cadenas mediante Traducción de Cadenas y en la interfaz del CMS me decía que estaban traducidas y en el frontend seguían sin traducirse.

Luego he probado con el Administrador de Traducción y cadenas que por Traducción de Cadenas se daban como traducidas por el Administrador me decía que no. Al traducirlas todas e intentar guardar, el sistema se colgaba (mensaje de Guardando eterno, cerraba pestaña, volvía a abrirla y las cadenas seguían sin traducir).

Como te digo, sólo he hecho pruebas con 2 formularios y este ha sido el resultado. Supongo que pasará en todos los demás, pero no lo puedo certificar (ya sería mala pata que sólo pasara en estos dos, pero igualmente, esos errores tal y como está ahora el Portal, no sucedían).

Espero haber aclarado algo.

Saludos,

Los hilos nuevos creados por Andrés y vinculados a este se encuentran a continuación:

https://wpml.org/es/forums/topic/split-funcionalidad-save-and-continue-no-se-traduce-tras-upgrade/