Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

Hoy no hay asistentes de soporte disponibles en el foro Spanish. Siéntase libre de enviar sus tiques y les daremos trámite tan pronto como estemos disponibles en línea. Gracias por su comprensión.

This topic contains 15 respuestas, has 2 mensajes.

Last updated by Andrés hace 2 meses.

Assigned support staff: Andrés.

Autor Publicaciones
noviembre 20, 2019 a las 6:53 pm #4983439

pabloT-8

Estoy tratando de traducir el sitio hidden link pero apenas instalo WPML, las pages se ven sin el header.

URL de (mi) sitio web donde aparece el problema: hidden link

Yo esperaba que se pueda incluir una imagen de header en cada página (así esta originalmente)

Pero al instalar WPML esa lógica se rompe y no permite agregar imágenes

noviembre 21, 2019 a las 6:37 am #4985373

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+01:00)

Hola,

Bienvenido al soporte de WPML.

1. Acabo de visitar tu sitio pero no estoy muy seguro de entender dónde radica el problema. ¿Me podrías indicar paso a paso cómo reproducir el mismo?

2. Por favor revisa que tienes la extensión instalada y activada. Luego de eso ve a WPML > Configuración -> Traducción de multimedia.
y verifica que tus ajustes han sido correctamente activados.

En este sección podrás actualizar y traducir tu contenido anterior:
- Definir información de idioma para los elementos multimedia existentes
x Traducir los elementos multimedia existentes a todos los idiomas
x Duplicar los elementos multimedia existentes para el contenido traducido
x Duplicar las imágenes destacadas para el contenido traducido
- Da click en el botón "Iniciar".

Ahora, para el nuevo contenido verifica que estas opciones también han sido seleccionadas:
- Instrucciones para gestionar elementos multimedia para contenido nuevo:
x Los elementos multimedia subidos a la biblioteca de medios estarán disponibles en todos los idiomas
x Duplicar los elementos multimedia adjuntos para las traducciones
x Duplicar las imágenes destacadas para las traducciones

En el siguiente artículo podrás encontrar más información al respecto:
https://wpml.org/documentation/getting-started-guide/media-translation/

Un saludo,
Andrés

noviembre 21, 2019 a las 1:19 pm #4988321

pabloT-8

Hola Andrés, gracias x tu pronta respuesta.
El tema Glytch permite definir distintos tipos de headers a las páginas. Si bien hay una configuración global en Apariencia > Header Layout, uno puede asignarle a cada página un tipo de header distinto. En mi caso, cada categoría del sitio es una página que tiene un header con un video o foto como background y un texto como título. En la configuración global el header está puesto como Small, para qué todas las páginas lleven ese tipo de header, menos en la Home page donde configuré que esa única pagina no lleve header (el Page Builder permite configurar a cada página un tipo de header: Standard, Big, Small, Full Height y No Header).
Bueno, todo esto se comportaba correctamente hasta que instalé WPML Multilingual CMS, que genera los siguientes problemas:
Home: muestra el header aunque la página esta configurada con No Header.
Demás Páginas: el header no muestra el video o foto, solo el texto.
Página Videos: además del problema anterior, se rompe el grid.

Te adjunto algunas imágenes para que veas el comportamiento correcto VS el erróneo.

Como dato adicional: el mismo tema lo uso junto con WPML en el sitio hidden link y todo funciona correctamente.

Espero tus novedades.
Saludos
Pablo

noviembre 21, 2019 a las 2:36 pm #4989471

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+01:00)

Gracias por la explicación, Pablo. Por el momento revisemos el problema de los headers. ¿Me puedes confirmar de haber instalado el plugin y haber seguido las instrucciones de mi respuesta anterior?

Saludos

noviembre 21, 2019 a las 4:45 pm #4991097

pabloT-8

Hola Andrés,
Te confirmo que seguí tus instrucciones. Solo un comentario más: no llegué a traducir ningún post ni página. Apenas instalado el WPML ya se empezó a ver con errores.
Saludos

noviembre 21, 2019 a las 4:49 pm #4991251

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+01:00)

Si entiendo correctamente aún no has comenzado a traducir tu sitio, por tanto los errores se presentan entonces en el idioma original, ¿es correcto?

Si es así, ¿si desactivas WPML el problema desaparece?

Saludos

noviembre 21, 2019 a las 4:52 pm #4991315

pabloT-8

Exacto! Si desactivo WPML el sitio se ve perfecto. En este momento esta con WPML desactivado y se ve bien: hidden link

noviembre 21, 2019 a las 4:56 pm #4991337

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+01:00)

Perfecto, en ese caso comencemos por actualizar el tema a su última versión.
hidden link

Por otra parte, ten en cuenta que tu tema Glytch no se encuentra en nuestra lista de compatibilidad. Sin embargo esto no significa necesariamente que no lo sea, simplemente nuestro equipo no lo ha probado hasta el momento.
https://wpml.org/documentation/theme-compatibility/

Saludos

noviembre 21, 2019 a las 4:59 pm #4991347

pabloT-8

Dale Andrés, era una de las opciones que tenía para seguir probando. Voy a actualizar el tema y te cuento cómo me va.
Saludos

noviembre 21, 2019 a las 5:10 pm #4991587

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+01:00)

Quedo atento. 🙂
Saludos

noviembre 24, 2019 a las 1:36 am #5005713

pabloT-8

Hola Andres,
He actualizado el tema y pluguins pero el problema sigue. Creo que se trata de una incompatibilidad entre Glytch y WPML. El problema se presenta cuando se utilizan imagenes o videos en los headers de Pages (no en los de posts).
Lo resolvi reformulando el sition utilizando contents block.
Agradezco tu ayuda.
Saludos
Pablo

noviembre 24, 2019 a las 5:14 pm #5007259

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+01:00)

Gracias Pablo, ¿quieres decir que ya encontraste una solución?

Si no es el caso, he creado un sitio de pruebas para ti. Puedes acceder a este simplemente haciendo click en en siguiente enlace:
hidden link

La idea es que cargues tu tema Glytch y nos ayudes a reproducir el problema. De esta manera, si efectivamente se trata de un problema de compatibilidad, podremos acelerar el proceso y contactar a nuestro Equipo de compatibilidad y trabajar con el autor en la resolución de tu problema.


No tienes que recrear tu sitio, simplemente instalar lo mínimo necesario para reproducir el problema.

Saludos

noviembre 24, 2019 a las 11:22 pm #5007987

pabloT-8

Hola Andres,
No, no he encontrado la solución. Lo que hice fue no usar imagenes o videos en los headers.
Voy a intentar reproducir el error en el escenario de pruebas así colaboro a encontrar una solucion.
Saludos

noviembre 25, 2019 a las 6:18 am #5008465

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+01:00)

¡Perfecto! 🙂
Quedo atento a tus resultados.
Saludos

noviembre 26, 2019 a las 12:28 pm #5021409

pabloT-8

Hola Andrés.
Ya cree en en el sitio de pruebas una página para intentar repetir el error, sin embargo, no he podido y el comportamiento fue exitoso. Deduzco entonces que debe ser algún problema con mi instalacion de wordpress o algun plugin que está molestando o algo con la base de datos.

De todos modos, como te comentaba, reemplacé los headers con algo que trae el tema Glytch llamado Contents Block que permite generar bloques de contenidos que reemplazan los headers.

Me quedo con la intriga de cuál es la razon por la que en mi WP se rompen los headers y en el sitio de pruebas funciona.

Saludos
Pablo