Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

This topic contains 3 respuestas, has 2 mensajes.

Last updated by jaimeP-2 hace 3 meses, 1 semana.

Assigned support staff: Andrés.

Autor Mensajes
julio 5, 2019 a las 12:12 am

jaimeP-2

- Me aparece un botón diciendo que debería configurar WPML para empezar a traducir, cuando en realidad llevo varios años añadiendo traducciones en Francés.

- Aparece los siguientes mensajes de error:

"This version of WPML allows the use of taxonomy terms with the same name across multiple languages. Your site currently has 2 taxonomy terms that require an update, so they will not be displayed with language suffixes." con el botón "Open terms update page". Cuando lo presiono no ocurre nada.

- "WPML is missing some records in the languages tables and it cannot fully work until this issue is fixed.
Please go to the Troubleshooting page and click on "Clear language information and repopulate languages" to fix this problem."

- "WPML String Translation is enabled but not effective. Please finish the installation of WPML first."

Ha desaparecido el selector de idiomas en el frontend y backend y no puedo cambiar de idioma ni gestionar o añadir traducciones.

He actualizado a PHP 7.2, Mysql 5.7, Y WordPress y todos los plugins a sus últimas versiones pero no ha servido de nada.

julio 5, 2019 a las 5:36 am #4147657

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola,

Bienvenido al soporte de WPML.

Acabo de visitar tu sitio y he seguido las instrucciones de la alerta "Please go to the Troubleshooting page and click on "Clear language information and repopulate languages" to fix this problem.

Después de ello, todo parece funcionar correctamente. ¿Podrías verificarlo?

Un saludo,
Andrés

julio 5, 2019 a las 10:49 am #4150423

jaimeP-2

Hola Andrés, gracias por tu ayuda. En el sitio de producción hidden link no me aparece el botón "Clear language information and repopulate languages"...

y en el sitio de prueba seguían apareciendo los otros errores:

"This version of WPML allows the use of taxonomy terms with the same name across multiple languages. Your site currently has 2 taxonomy terms that require an update, so they will not be displayed with language suffixes." con el botón "Open terms update page". Cuando lo presiono no ocurre nada.

- "WPML is missing some records in the languages tables and it cannot fully work until this issue is fixed.
Please go to the Troubleshooting page and click on "Clear language information and repopulate languages" to fix this problem."

Como se habían duplicado todas las imágenes del sitio en producción he restaurado una copia de la web de hace una semana y así, de momento, dejo la web sin errores. Retomaré las actualizaciones sobre una copia de seguridad después de las vacaciones (que comienzo mañana).

Gracias y un saludo,

Jaime.

julio 5, 2019 a las 10:56 am #4150449

jaimeP-2

As I had errors in my production site, I have restored a server backup and I will try to update WPML in test site and with more time to solve all the errors that WPML throw. I feel WPML is very unstable and I am always scared of update it.