Skip Navigation

Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en los foros 6 días a la semana, 22 horas por día.

Etiquetado: 

This topic contains 15 respuestas, has 2 mensajes.

Last updated by Andrés hace 5 meses, 2 semanas.

Assigned support staff: Andrés.

Autor Mensajes
diciembre 11, 2020 a las 5:01 pm #7646587

arantzazuL

Tell us what you are trying to do? Tengo header y footer en dos idiomas pero solo carga en uno.

What is the link to your site? hidden link

diciembre 14, 2020 a las 6:26 am #7657787

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola,

Bienvenido al soporte de WPML.

Acabo de visitar tu sitio y el header se carga correctamente en los dos idiomas, ¿has podido solucionar tu problema durante el fin de semana?

Un saludo,
Andrés

diciembre 14, 2020 a las 11:19 am #7659527

arantzazuL

Buenos días:

El menú sí lo muestra en el idioma correcto, pero no el botón en el caso del "header": hidden link

Y ninguno del resto de elementos en el footer: hidden link

Saludos y gracias de antemano.

diciembre 14, 2020 a las 3:39 pm #7661923

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Gracias por la alcaración. Este mañana que accedí al sitio y el header lucía diferente, comecemos entonces a traducir el botón "GURASOEN TXOKOA".

1. ¿Me podrías decir cómo lo creaste? ¿Hacer parte de un plugin?

2. ¿Has intentado traducirlo desde WPML > Traducción de cadenas?

Saludos

diciembre 15, 2020 a las 1:13 pm #7669097

arantzazuL

Hola!

Ese header y ese footer son páginas creadas con Beaver Builder y después se asignan como header y footer para todo el sitio web.

He intentado traducirlo desde la traducción de cadenas pero no localiza nada.

Saludos!

diciembre 15, 2020 a las 3:40 pm #7670153

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Gracias por la aclaración. ¿Me podrías decir si cuando traduces el header tienes la posibilidad de traducir el botón ""GURASOEN TXOKOA" o el problema es que no te aparece el botón para traducir?
https://wpml.org/documentation/plugins-compatibility/beaver-builder/#adding-new-module-and-do-the-translation

Saludos

diciembre 18, 2020 a las 9:51 am #7691603

arantzazuL

Buenos días!

Lo que hago normalmente es crear 2 headers y 2 footers ya con sus textos correspondientes, en este caso en euskera y castellano.

Al usar el editor de traducción de WPML para probar si lo podía lograr, me aparece el campo para traducir sin problema.

Saludos!

diciembre 18, 2020 a las 10:46 am #7692205

arantzazuL

hidden link

diciembre 18, 2020 a las 4:22 pm #7695939

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola,

1. Para asegurarnos que WPML funcione correctamente, ¿podrías incrementar la Memory Limit y WP Memory Limit a 256M? Si puedes suministrar más recursos, sería ideal.
Tus valores actuales son:
- MemoryLimit 192M
- WP Memory Limit 192M
https://wpml.org/home/minimum-requirements/

Muchas veces estos ajustes son bloqueados directamente desde la administración de tu hosting. En ese caso te recomiendo que los contactes directamente y si puedes pedir valores superiores a 128M, sería recomendable.

2. ¿Podrías seguir el siguiente procedimiento?
- Ve a tu Escritorio > Páginas.
- Completa la traducción de tu header como está. Traduce los campos disponibles, márcalos como completos al 100% y guarda.
- En tu header original debería aparecer un símbolo de lápiz en el bloque derecho de traducciones. Esto indica que la traducción ha sido completada al 100%.
- Luego haz una pequeña edición en el header original, por ejemplo, agrega un espacio en blanco en el contenido.
- Guarda. El lápiz debería convertirse en una flecha circular.
- Vuelve a editar la traducción y márcala al 100%.
- Guarda.
¿Aparece esta vez el contenido faltante listo para ser traducido?

Saludos

diciembre 18, 2020 a las 6:47 pm #7696585

arantzazuL

Hola!
Gracias por tu ayuda.
He seguido todos los pasos, he aumentado memoria y despúes realicé las traducciones, pero continúa igual, no sé qué puede ser.
Saludos!

diciembre 20, 2020 a las 5:28 pm #7704411

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola,

¿Me podrías dar las credenciales de tu sitio web de prueba, de esta manera podemos dar un vistazo a tus ajustes, así como los pasos necesarios para reproducir este comportamiento?

Para esto, debes poder ver una forma protegida en la parte inferior de este tópico. (Te pide hacer un backup y un + Aviso legal). Una instalación de test es preferible y nos haría mucho más fácil hacer una evaluación. En cuanto tenga más información te lo haré saber

Importante: Haz un backup completo de tu sitio. Puedes usar un plugin como Duplicator para este propósito. Mira en: http://wordpress.org/plugins/duplicator/

Si no ves este formulario para completar los campos confidenciales NO los publiques, ya que serán visibles en el foro:
hidden link

Privacidad y seguridad al proporcionar información de Debug para soporte:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

diciembre 21, 2020 a las 6:00 pm #7711639

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Gracias por tus credenciales. Ahora bien, parece que esta situación está ligada a la utilización del plugin botón PowerPack Smart button del PowerPack for Beaver Builder.

He tratado de crear una nueva página y agregar dicho botón, sin embargo, no es visible en el front-end. Pero si agrego un botón por defecto del Beaver Builder funciona correctamente.

¿Me podrías indicar que paso falta?

2-solo-un-boton-visible.png
1-dos-botones.png
diciembre 22, 2020 a las 12:18 pm #7716095

arantzazuL

Hola!

En su día yo creé una cabecera y un footer cada uno en su idioma, con su traducción, pero a la hora de cambiar de idioma, no sé por qué no cambia esa cabecera y ese footer. En teoría tal y como has hecho estaría correcto.

Saludos!

diciembre 22, 2020 a las 1:56 pm #7716981

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola,

Gracias por tu confirmación, pero este comportamiento no es en la traducción si no en la página principal y primero tendríamos que hacer que el plugin funcione correctamente, luego, entramos a ver la traducción. ¿Podrías revisarlo por si me he saltado algún paso?

En paralelo te recomiendo que contactes al autor del plugin ya que tal vez esté al tanto de esta situación y te pueda ayudar más rápido.

Saludos

diciembre 29, 2020 a las 10:07 am #7747139

arantzazuL

Buenos días:

He informado a los creadores del plugin, a priori parece que todo funciona como debe, van a revisarlo.

Saludos!

El debate ‘[Cerrado] Header y footer no cargan en español’ está cerrado y no admite más respuestas.