Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem:
Using the language selector in the menu, no arrows are displayed along with WPML.

Solution:
This is how your theme displays the dropdown menus. As a workaround, you can try to use this code in As a workaround you can add this CSS in WPML > Languages > Language switcher options > Additional CSS:

.wpml-ls-current-language {
    background: url('/wp-content/plugins/sitepress-multilingual-cms/res/img/nav-arrow-down.png') 41px 37% no-repeat;
    padding-right: 10px;
}

If the arrow is not aligned as desired, you can customize the code above, as you want.

Relevant Documentation:
https://wpml.org/documentation/getting-started-guide/language-setup/custom-language-switcher/

Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en los foros 6 días a la semana, 22 horas por día.

Hoy no hay asistentes de soporte disponibles en el foro Spanish. Siéntase libre de enviar sus tiques y les daremos trámite tan pronto como estemos disponibles en línea. Gracias por su comprensión.

Etiquetado: 

This topic contains 2 respuestas, has 2 mensajes.

Last updated by angelR hace 3 años.

Assigned support staff: Bruno.

Autor Mensajes
julio 26, 2017 a las 11:09 am #1327460

angelR

I want to show the arrow icon in the switch language selector, but I don't see it
hidden link

julio 26, 2017 a las 1:16 pm #1327585

Bruno

Hi,

Thank you for contacting us.

That's the way your theme is done. These arrows are probably not added next to dropdown menus.

As a workaround you can add this CSS in WPML > Languages > Language switcher options > Additional CSS:

.wpml-ls-current-language {
    background: url('<em><u>hidden link</u></em>') 41px 37% no-repeat;
    padding-right: 10px;
}

If the arrow is not aligned as desired, you can customize the code above, as you want.

After following these steps, please let me know if your website is showing up as desired.

Thank you.

julio 26, 2017 a las 1:25 pm #1327592

angelR

It worked properly, thank you!