Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

This topic contains 8 respuestas, has 2 mensajes.

Last updated by Andrés hace 8 meses, 3 semanas.

Assigned support staff: Andrés.

Autor Mensajes
enero 21, 2019 a las 6:47 pm #3113774

javierA-13

Hola, hace 2 meses nos paso el mismo problema a la hora de instalar el modulo WPML. cuando lo instalo no da ningun error pero a la hora de cargar la web da un error 500.

La última vez que nos disteis soporte nos comentasteis que en la base de datos habían restos de otra instalación, pero no llegamos a comentar mas.

Actualmente nos pasa lo mismo con hidden link

Nos gustaría si es posible mirar de instalar el modulo.

enero 22, 2019 a las 6:34 am #3114953

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola,

Bienvenido al soporte de WPML.

Para saber si el problema es el mismo, debemos activar la información de depuración. ¿Podrías revisar si existe algún error PHP?

Sería genial si me puedes suministrar la información del debug.log de WordPress (No la confundas con la información de depuración de WPML).

Por favor abre tu archivo wp-config.php y busca la línea que dice: define(‘WP_DEBUG’, false);. y cámbialo por:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

Luego busca en la carpeta /wp-content/ y mira si existe algún archivo debug.log.

Si puedes agregar la información del debug.log en pastebin.com y proveerme el link sería aún mejor (Es la manera más limpia porque algunas veces los logs pueden ser muy largos y la conversación se puede volver desordenar mucho).
https://wpml.org/documentation/support/debugging-wpml/

Un saludo,
Andrés

enero 22, 2019 a las 4:03 pm #3117340

javierA-13

Adjuntamos la información que aparece al instalar el modulo.

https://pastebin.com/embed_iframe/T1H0gY0J

enero 23, 2019 a las 7:19 am #3119120

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

En efecto, el error parece similar al de la vez pasada:

=========================
*Realiza un backup de la base de datos*
=========================

1. Por favor ve a WPML > Soporte.
- Solución de problemas.
- Reiniciar.
x Estoy a punto de restablecer todos los datos de traducción e idioma.
x Restablecer y desactivar WPML

¿Esta vez puedes terminar la instalación de tu WPML?

2. Si esto no funciona, entonces:
- Accede a tu base de datos.
- Elimina las tablas que tienen el prefijo icl_xxx.
- Abre la tabla wp_options.
- Borra las filas que tengan el prefijo icl_xxx.
- Instala de nuevo tu WPML.

¿Funciona esta vez?

enero 23, 2019 a las 3:20 pm #3121195

javierA-13

Hola de nuevo, te contesto a continuación:

1. Por favor ve a WPML > Soporte.
No puedo acceder al backoffice una vez instalado.

2. Si esto no funciona, entonces:
- Accede a tu base de datos.
- Elimina las tablas que tienen el prefijo icl_xxx.
- Abre la tabla wp_options.
- Borra las filas que tengan el prefijo icl_xxx.
- Instala de nuevo tu WPML.

He accedido a la Base de datos y no tengo ninguna tabla con el prefijo icl_xxx a parte al entrar al wp_options tampoco me aparece nada con icl.

enero 23, 2019 a las 3:57 pm #3121381

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

¿Me podrías dar las credenciales de tu sitio web de prueba, de esta manera podemos dar un vistazo a tus ajustes, así como los pasos necesarios para reproducir este comportamiento?

Para esto, debes poder ver una forma protegida en la parte inferior de este tópico. (Te pide hacer un backup y un + Aviso legal). Una instalación de test es preferible y nos haría mucho más fácil hacer una evaluación. En cuanto tenga más información te lo haré saber

Importante: Haz un backup completo de tu sitio. Puedes usar un plugin como Duplicator para este propósito. Mira en: http://wordpress.org/plugins/duplicator/

Si no ves este formulario para completar los campos confidenciales NO los publiques, ya que serán visibles en el foro:
hidden link

Privacidad y seguridad al proporcionar información de Debug para soporte:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

enero 24, 2019 a las 7:10 am #3123638

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Gracias por tus credenciales, sin embargo, las del FTP no funcionan.

He instalado temporalmente el plugin ARI Adminer para analizar tu base de datos, y puedo ver varias entradas relacionadas con una instalación antigua de WPML (3.3.6) que provocan este conflicto.

Por el momento las he eliminado y no deberías tener problema para instalar una versión reciente de WPML. Sin enbargo, al no tener credenciales FTP, debo solicitarte que realices la instalación.

¿Funciona esta vez?

enero 24, 2019 a las 8:30 am #3123931

javierA-13

Hola ahora de momento lo he podido instalar y estoy mirando de configurar.
Me puedes indicar que tabla es donde has encontrado la informacion icl? porque tenemos mas instalaciones que hacer y antes de preguntar intentar mirar la tabla.

Saludos

enero 24, 2019 a las 9:15 am #3124163

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Me alegra saber que has podido resolver tu problema. Las entradas se encontraban en la tabla wp_options como había indicado anteriormente.

Si tienes dificultades para encontrarlas, tal vez un plugin como el Search and Replace te pueda ayudar.
https://wordpress.org/plugins/search-and-replace/

Saludos,
Andrés