Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

Etiquetado: 

This topic contains 8 respuestas, has 3 mensajes.

Last updated by Diego Pereira hace 2 meses.

Assigned support staff: Diego Pereira.

Autor Publicaciones
agosto 14, 2019 a las 1:36 pm #4395505

soniaD-3

Estoy tratando de: Trato de que aparezcan las plantillas de Elementor traducidas

URL de (mi) sitio web donde aparece el problema: chipychop.es

Yo esperaba ver: Las plantillas correspondientes a su idioma

En vez de eso, obtuve: Siguen apareciendo las plantillas en español

agosto 15, 2019 a las 11:12 am #4400393

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola,

Por favor, podrías confirmar que has seguido esta documentación:
https://wpml.org/documentation/plugins-compatibility/elementor/#translate-elementor-templates

Dime si esto te orienta en la dirección correcta.

Por otro lado, te sugiero incrementar la Memory Limit y WP Memory Limit a 256M.
Tus valores actuales son:
- MemoryLimit 256M
- WP Memory Limit 40M
https://wpml.org/home/minimum-requirements/

Edita tu archivo wp-config.php y agrega la siguiente línea:

define('WP_MEMORY_LIMIT', '256M');

Muchas veces estos ajustes son bloqueados directamente desde la administración de tu hosting. En ese caso te recomiendo que los contactes directamente y si puedes pedir valores superiores a 128M, sería recomendable.

Nota: 128M es el mínimo necesario para WPML sin otros plugins y con un tema por defecto de WordPress.

Un saludo cordial,

Otto

agosto 16, 2019 a las 8:40 am #4405465

soniaD-3

Buenos días. Puedo confirmar que he seguido la documentación para configurar WPML con Elementor.

También he cambiado la variable WP MEMORY LIMIT a 256 en el archivo wp-config.php y he hecho consulta al proveedor de hosting para comprobar que también está correcto: hidden link

Están hechas todas las traducciones necesarias y lo único que no detecta son las plantillas (son 4 en la página de inicio), el header y el footer. El resto lo hace todo correctamente.

Me da un error la página de inicio que en vez de ponerse la traducción al 100% se queda en 99% y no se donde corregirlo porque están todos los check marcados.

agosto 16, 2019 a las 2:55 pm #4407151

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola,

Gracias.

Para poder investigar mejor el problema necesitaría, si fuera posible, que me permitas acceder a tu sitio temporalmente. Mucho mejor si tuvieras un sitio de pruebas en donde esté replicado el problema.

Encontrarás los campos necesarios debajo del área de comentarios. He marcado la próxima respuesta como privada, por lo que la información que ingreses solo la veremos tu y yo.

Es posible que necesite replicar tu sitio localmente. Para eso voy a necesitar instalar un plugin llamado "Duplicator". Con él podré crear una copia completa de tu web. Una vez que el problema esté resuelto, borraré la copia local. Dime por favor si estás de acuerdo.

** IMPORTANTE **

- Por favor haz un back up completo de tu sitio y base de datos antes de proveer los datos de acceso

- Si no ves este formulario para completar los campos confidenciales NO los publiques, ya que serán visibles en el foro:
hidden link

En ese caso, pídeme que vuelva a habilitar una respuesta privada.

Muchas gracias.

Un saludo cordial,

Otto

agosto 19, 2019 a las 3:44 pm #4417177

Diego Pereira
Supporter

Languages: Inglés (English ) Español (Español ) Portugués, Brasil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hola,

Mi colega Otto no está trabajando hoy, así que lo reemplazaré temporalmente en el foro. Espero que esté bien para ti.

Creé una copia del sitio web en mi servidor para examinar el problema y descubrí que uno de los campos no está traducido, lo que dejó la traducción con un status del 99%. Para ser publicada, la traducción debe tener el status del 100%.

Después de marcar todos los campos como "traducción terminada", la traducción se mostró correctamente en mi servidor local.

Por favor dime si te funciona.

Saludos cordiales,
Diego

agosto 19, 2019 a las 5:29 pm #4417707

soniaD-3

Buenas tardes,
Primero muchas gracias por detectar el fallo del campo sin traducir, no lo veía y no entendía porqué no marcaba el 100% de traducción.
De todas formas el problema sigue sin resolverse, tiene que haber algún tipo de incompatibilidad con las plantillas de Elementor porque siguen sin aparecer traducidas.
Adjunto capturas para que te des cuenta, son 4 plantillas en el apartado "Sobre Nosotros" del "Inicio" las traducciones están al 100% en PLANTILLAS -> PLANTILLAS GUARDADAS.
Tampoco aparecen las traducciones del "Header" y el "Footer", las plantillas están en CLEVERIES --> MY LIBRARY
Gracias por tu atención.

agosto 20, 2019 a las 5:29 pm #4425705

Diego Pereira
Supporter

Languages: Inglés (English ) Español (Español ) Portugués, Brasil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hola,

Aparentemente, esto se debe a un problema de compatibilidad entre el tema de complementos / Jet y WPML.

Descubrí que la plantilla está seleccionada en el elemento de tabs, que no está registrado para la traducción.

Una solución rápida sería usar el editor manual para arreglar la plantilla cargada en la traducción:
- Vaya a la pantalla de edición de la página (idioma original).
- Cambie el idioma usando el selector de idioma en la barra de administración superior
- si muestra una advertencia, haga clic en "Editar de todos modos"
- Haga clic en "Editar con Elementor"
- Edite cada tab, seleccione el template correcto y guarde

Esto funcionó en el sitio de prueba: hidden link

Por favor, dígame si funciona para usted y si también funciona para el header y footer de página.

Sería genial si también puede contactar al autor y referirlo a nuestro programa Go Global para que podamos ayudarlo a hacer que su producto sea compatible con WPML: https://wpml.org/documentation/theme-compatibility/go-global- programa/

Saludos cordiales,
Diego

agosto 21, 2019 a las 10:29 am #4430161
soniaD-3

Buenos días,

El apartado de las plantillas de Elementor queda solucionado con las instrucciones anteriores (adjunto imagen). Muchas gracias por la ayuda.
Pero esto no funciona con el header y el footer ya que en la página de inicio no hay ninguna opción para asignar el header y el footer según el idioma (por lo menos yo no la encuentro).
He enviado la info del programa Go Global a Template Monster que es el sitio donde compré la plantilla.

Los hilos nuevos creados por Diego Pereira y vinculados a este se encuentran a continuación:

https://wpml.org/es/forums/topic/split-la-pagina-de-inicio-no-detecta-las-plantillas-traducidas/

agosto 21, 2019 a las 4:00 pm #4433877

Diego Pereira
Supporter

Languages: Inglés (English ) Español (Español ) Portugués, Brasil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hola

Esto parece ser un problema diferente, por lo que crearé un nuevo ticket para este nuevo problema (https://wpml.org/es/forums/topic/split-la-pagina-de-inicio-no-detecta-las-plantillas-traducidas/).

Enviaré una respuesta en el nuevo ticket.

Saludos,
Diego