Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: Al adjudicar las cadenas de traducción dándole a "Agregar pedido de traducción" desaparecen del apartado "Traducción de cadenas". Sí son enviadas por mail al traductor, pero desaparecen del apartado. Además, el traductor tampoco consigue verlas al pulsar en el botón "tomarlo" del mail que recibe.

Solution: - Modificar el archivo XML al que se accede mediante WPML > Configuracion > Configuración XML personalizada - Guadar la modificación - Desactivar y activar el plugin 'WPML Multilingual CMS' - Ir a WPML > Paquetes > Borrar el paquete referente a cada página (vienen señalados por el ID de cada página) - Ir a 'Páginas' y volver a traducir

Relevant Documentation: - https://wpml.org/es/documentation-2/traducir-los-contenidos/traduccion-de-contenido-creado-con-constructores-de-paginas/ - https://wpml.org/documentation/plugins-compatibility/how-to-build-multilingual-sites-with-wpbakery-page-builder-and-wpml/ - https://wpml.org/documentation/support/language-configuration-files/#page-builder-content

Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en los foros 6 días a la semana, 22 horas por día.

This topic contains 9 respuestas, has 2 mensajes.

Last updated by Carlos Rojas hace 3 años.

Assigned support staff: Carlos Rojas.

Autor Mensajes
noviembre 5, 2018 a las 3:58 pm #2877453

giulieteA

Al adjudicar las cadenas de traducción dándole a "Agregar pedido de traducción" desaparecen del apartado "Traducción de cadenas". Sí son enviadas por mail al traductor, pero desaparecen del apartado. Además, el traductor tampoco consigue verlas al pulsar en el botón "tomarlo" del mail que recibe.

Por otro lado, el apartado "Traducción de cadenas" tampoco está permitiendo la "selección por dominios". Creo que algo no está funcionando como era de esperar.

Además, también he tenido problemas a la hora de crear el "wpml-config.xml" para Visual Composer.

noviembre 6, 2018 a las 12:30 pm #2880809

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hola,
Muchas gracias por contactar con el servicio de soporte de WPML. Haré mi mejor esfuerzo por ayudarle a resolver estos problemas.

Siguiendo las políticas del foro, se debe crear un ticket por problema y en este caso veo que hay al menos tres problemas en su ticket inicial. Me gustaría pedirle que cree un ticket para el problema relacionado con 'la selección por dominios' y otro para el problema relacionado con los archivos de configuración (wpml-config.xml).

En estos nuevos tickets puede describir los pasos a seguir para reproducir el problema y de esta manera nos brindará más información para resolverlos. Cuando cree los tickets puede asignarmelos directamente y yo estaré más que contento de seguir ayudandole.

Con respecto al problema original, según su descripción, las cadenas desaparecen del apartado "Traducción de cadenas" cuando las adjudica a un traductor. Si comprendí bien el problema, entonces este comportamiento es correcto, pues las cadenas se mostrarán solo al traductor asignado. De todas maneras me gustaría pedirle que describa los pasos a seguir para reproducir el problema y adjunte algunas capturas de pantalla donde pueda verse el problema.

Quedo a la espera de su respuesta.
Saludos cordiales,
Carlos

noviembre 6, 2018 a las 2:30 pm #2881304

giulieteA

Ok, como nos indicas, acabamos de crear nuevos tickets.

Respecto al tema de las cadenas que desaparecían (ahora ya ni aparecen), entiendo que cuando se adjudican a un traductor se muestran sólo al traductor asignado, pero en este caso el traductor asignado tampoco las podía ver, ya que cuando pulsaba en el enlace del mail aparecían todas las cadenas y era imposible encontrar esas cadenas asignadas.

Hemos llegado a pensar que quizás puede ser por el "límite de memoria" (adjuntamos captura), pero no lo tenemos muy claro.

Gracias

nuevacaptura-01.png
noviembre 6, 2018 a las 3:13 pm #2881567

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hola,
Muchas gracias por su respuesta.

El límite de memoria mínimo es de 128M, para aumentarlo debe editar el archivo wp-config.php que se encuentra en la raíz del sitio y añadir el siguiente código sobre la línea "/* That's all, stop editing! Happy blogging. */"

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');

- Guardar los cambios.

Me puede decir si el problema desapareció luego de aumentar el límite de memoria?

Saludos cordiales,
Carlos

noviembre 6, 2018 a las 3:50 pm #2881669

giulieteA

Muchas gracias por las indicaciones para aumentar el límite de memoria mínimo, pero lamento comentarte que este cambio no nos ha solucionado el problema.

Como se muestra en la imagen, aunque en la web se pueden ver varias cadenas, estas no aparecen después en el "Traductor de cadenas" (denotr del paquete de esa página) ¿Nos podrías decir cuál es la razón? ¿Cómo podríamos hacer que aparecieran?

Además, ¿esta es la forma adecuada de realizar esta traducción, a través del "traductor de cadenas"?

Gracias

traduccion-cadenas.png
inicio-frontend.png
noviembre 6, 2018 a las 4:45 pm #2881951

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hola,

De acuerdo con las imágenes adjuntas, se está utilizando un 'page builder'. Si este es el caso entonces la manera correcta de traducir las páginas es a través del Editor de Traducción, para ello le recomiendo que visite este enlace en donde encontrará un tutorial sobre cómo traducir el contenido en este caso: https://wpml.org/es/documentation-2/traducir-los-contenidos/traduccion-de-contenido-creado-con-constructores-de-paginas/

Por favor hágame saber si necesita más ayuda de mi parte.
Saludos cordiales,
Carlos

noviembre 7, 2018 a las 9:35 am #2884472

giulieteA

Sí, contamos con el plugin Visual Composer y hemos seguido los pasos que indican en su web https://wpml.org/documentation/translating-your-contents/page-builders/ y https://wpml.org/documentation/plugins-compatibility/how-to-build-multilingual-sites-with-wpbakery-page-builder-and-wpml/, además intentamos hacer lo que se indica en este hilo https://wpml.org/forums/topic/visual-composer-add-on-info-box-not-appearing-in-wpml-product-translation/ pero no lo hemos conseguido del todo. Por este motivo y como se muestra en las capturas adjuntas, no conseguimos ver el texto de alguno de los módulo (captura-01) a la hora de la traducción (captura-02) y tampoco en el "traductor de cadenas" (captura-03).

Después de estudiar varias opciones, creemos que sería más fácil a través del "traductor de cadenas", pero cualquier opción es válida.

Muchas gracias

captura-03.png
captura-02.png
captura-01.png
noviembre 7, 2018 a las 12:52 pm #2885249

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hola,
Muchas gracias por su mensaje.

Me gustaría pedirle que realice los siguientes pasos:
- Identifique cuales son los elementos (shortcodes) de Visual Composer que no aparecen en el Editor de Traducción.
- Realice los pasos descritos en el siguiente enlace para añadir dichos elementos en el Archivo de Configuración de Idioma: https://wpml.org/documentation/support/language-configuration-files/#page-builder-content
- Edite la página donde aparece dicho elemento -> Haga algún pequeño cambio -> Guarde los cambios -> Actualice la traducción.

Me puede decir si el problema se resolvió?

Nota: En caso de que necesite asistencia para realizar cualquiera de los pasos anteriores no dude en mencionarlo y yo estaré mas que dispuesto a ayudarle.

Saludos cordiales,
Carlos

noviembre 13, 2018 a las 11:51 am #2902302

giulieteA

Finalmente conseguimos solucionar el problema por nuestra cuenta. Tras muchas pruebas y errores, pongo a continuación la solución que nos ha funcionado para la traducción los elementos (shortcodes) de Visual Composer:

- Modificar el archivo XML al que se accede mediante WPML > Configuracion > Configuración XML personalizada
- Guadar la modificación
- Desactivar y activar el plugin 'WPML Multilingual CMS'
- Ir a WPML > Paquetes > Borrar el paquete referente a cada página (vienen señalados por el ID de cada página)
- Ir a 'Páginas' y volver a traducir

Gracias.
Saludos

noviembre 13, 2018 a las 12:34 pm #2902547

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hola,
Me alegra saber que el problema se resolvió.

Muchas gracias por describir los pasos de la solución, pues esto pude ayudar a futuro clientes con algún problema similar.

Por favor no dude en contactarnos si necesita nuestra asistencia con WPML. Estaremos más que dispuestos a ayudar.
Saludos cordiales,
Carlos