Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

This topic contains 11 respuestas, has 3 mensajes.

Last updated by Andrés hace 5 meses, 3 semanas.

Assigned support staff: Andrés.

Autor Publicaciones
mayo 27, 2019 a las 2:00 pm #3898045

asierR

Estoy tratando de: estamos traduciendo nuestro sitio a varios idiomas usando ATE.

URL de (mi) sitio web donde aparece el problema: pre.paraninfo.com

Yo esperaba ver: hemos creado contenido con Páginas y con Custom Post Types creados con Toolset. Ese contenido en español ya está publicado.

En vez de eso, obtuve: Muchas traducciones ya están hechas al 100%. Sin embargo, no aparecen los post traducidos, pero seguimos pudiendo acceder al contenido traducido. Por ejemplo, hemos creado un custom post type, "Cursos de español", creado con Toolset. Por ejemplo, hemos publicado el post "Clases particulares de preparación al examen SIELE". Nuestra traductora completó la traducción al inglés, pero el post no aparece publicado y al cambiar el idioma en la página publicada, no se muestra tampoco. Esto es así a tal punto que sólo aparecen 4 posten inglés a pesar de que están casi todos traducidos. El mismo problema suceda con contenido publicado en Páginas.

En Configuración, en el apartado "Cómo traducir entradas y páginas", la opción "Usar el Editor de traducción avanzado de WPML" muestra este mensaje: "El Editor de traducción avanzado está habilitado pero no activo".

Gracias por su ayuda.

mayo 28, 2019 a las 5:34 am #3902803

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+01:00)

Hola,

Bienvenido al soporte de WPML.

De acuerdo con tus capturas de pantalla, la gran mayoría de tus artículos en inglés tienen un ícono con dos ruedas dentadas. Esto indica que la traducción aún no ha sido terminada. ¿Podrías acceder a una de tus traducciones con este símbolo y verificar que esté al 100%? Una vez esté al 100%, ¿qué sucede cuando das la traducción como terminada?

Un saludo,
Andrés

mayo 28, 2019 a las 5:45 am #3902857

nestorB-4

En mi caso la pagina antes salia traducido el tema completo al español y ahora no sale nada. Anteriormente se podía ver toda la pagina traducida y cuando se venció la licencia dejó de verse traducida, se ha pagado la licencia y ahora simplemente no la traduce como la hacía anteriormente. Ya tengo más de un mes tratando de que aparezca como antes pero mis esfuerzos han sido en vano. De verdad que ya estoy desesperado, porque nuestros clientes no tienen acceso a la pagina en español. Gracias.

mayo 28, 2019 a las 8:02 am #3903755

asierR

Hola Andrés, el problema no es con los artículos que mencionas. En la captura verás que hay muchos artículos que no tiene la rueda dentada. Aún así, no se muestra la traducción. Puedes comprobarlo con el ejemplo que indiqué: "Clases particulares de preparación al examen SIELE" está traducido al 100%, no muestra la rueda dentada, pero no aparece en la lista de artículos en inglés. El artículo publicado, al cambiar al inglés, sigue mostrándose en español:
hidden link
hidden link

mayo 28, 2019 a las 1:31 pm #3907509

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+01:00)

Gracias por la aclaración.

1. ¿Podrías verificar que dicho artículo aparezca como 100% traducido y agregar una captura de pantalla?

2. Solo si estás utilizando nuestro ATE (Advanced Translated Editor), ve a WPML > Settings > How to translate posts and pages y sincroniza tus traductores con traducciones. Luego de esto, revisita tu página traducción y guarda de nuevo. ¿Funciona esta vez?

Saludos

mayo 29, 2019 a las 8:48 am #3913403

asierR

1. Lo hemos hecho varias veces, siempre aparece al 100%.
2. Sí, como comenté en mi primer mensaje usamos ATE pero aparece el mensaje "El Editor de traducción avanzado está habilitado pero no activo". He sincronizado tus traductores con traducciones. No funciona. Agredo capturas.

mayo 29, 2019 a las 10:25 am #3914173

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+01:00)

Gracias por tu aclaración. El error al que te refieres puede ser un falso positivo, sin embargo, ¿podrías realizar las siguientes dos pruebas?

1. ¿Podrías revisar si existe algún error PHP?

Sería genial si me puedes suministrar la información del debug.log de WordPress (No la confundas con la información de depuración de WPML).

Por favor abre tu archivo wp-config.php y busca la línea que dice: define(‘WP_DEBUG’, false);. y cámbialo por:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

Luego busca en la carpeta /wp-content/ y mira si existe algún archivo debug.log.

Si puedes agregar la información del debug.log en pastebin.com y proveerme el link sería aún mejor (Es la manera más limpia porque algunas veces los logs pueden ser muy largos y la conversación se puede volver desordenar mucho).
https://wpml.org/documentation/support/debugging-wpml/

2. En tu sitio de prueba podrías revisar que esta situación se presenta cuando:
- Sólo el paquete WPML está activado. Esto nos dirá si hay algún problema de interacción con otro plugin.
- Cambias a un tema por defecto de WordPress como el Twenty Fourteen. Esto nos dirá si hay un problema de interacción con tu tema.
- Si el problema desaparece, activa uno por uno para determinar quién genera esta situación.

Saludos

mayo 29, 2019 a las 10:51 am #3914339

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+01:00)

Adicionalmente, por favor revisa lo siguiente:

1. Asegúrate que estás activado como traductor.

2. Ve al ATE y asegúrate que todos tus traductores estén allí y activados.

3. Verifica que el serial de ATE es correcto en la DB. Para ello, sigue este screenshot: hidden link y luego este: hidden link

4. Accede a tu base de datos y asegura que estas entradas de la table wp_options coinciden:
hidden link

mayo 30, 2019 a las 11:34 am #3922629

asierR

Hola Andrés, gracias por tus indicaciones.

De tu primer mensaje:
1. Cambie wp_config para añadir las líneas, pero no se genera ningún archivo en la carpeta wp_content
2. Desactivé todos los plug-ins, excepto los de WPML y Toolset Types (desactivé todos los de Toolset excepto este, de lo contrario desaparece el custom post typt. El error persiste. A continuación, con los plug-ins aun desactivados, cambié al tema por defecto de WordPress. Seguimos con el error. Por eso, he vuelto a activar los plug-ins y el tema Avada.

De tu segundo mensaje:
1. Estoy activado como traductor para todos los idiomas.
2. Todos los traductores estén en ATE y activados, cada uno en su idioma.
3. Al seguir los pasos que indicas, aparece este mensaje en la parte superior: Cannot merge organization with itself. Please contact support (adjunto imagen).
4. Las claves no coinciden con tu captura. Me sale (adjunto imagen):
WPML_SITE_ID:global 65366436-3033-5439-a331-306235383966
WPML_SITE_ID:ate 65653537-6637-5533-b734-373937366466
El segundo código es el que se muestra en la pantalla del paso 3.
¿Debo poner los códigos que aparecen en la imagen que me enviaste?

---------------

Por otra parte, al buscar las opciones que me has comentado, he visto lo siguiente. Las traducciones se guardan haciendo estos pasos.

1. Traducir el artículo con ATE, al 100%, y publicar. Lo probé con este: "Curso de Español y Experiencia de Arte en Madrid"

2. Inmediatamente, ir al apartado "Traducciones" del menú de WPML. El artículo recién traducido se muestra en la lista, en la parte superior, adjunto captura. En la parte superior se muestra este mensaje:

Notice: Trying to get property 'post_type' of non-object in /usr/home/paraninfo.com/web/pre/wp-content/plugins/sitepress-multilingual-cms/inc/absolute-links/absolute-links.class.php on line 559 Notice: Trying to get property 'post_content' of non-object in /usr/home/paraninfo.com/web/pre/wp-content/plugins/sitepress-multilingual-cms/inc/absolute-links/absolute-links.class.php on line 563 Notice: Trying to get property 'post_content' of non-object in /usr/home/paraninfo.com/web/pre/wp-content/plugins/sitepress-multilingual-cms/inc/absolute-links/absolute-links.class.php on line 567 Notice: Trying to get property 'post_content' of non-object in /usr/home/paraninfo.com/web/pre/wp-content/plugins/wpml-translation-management/inc/translation-proxy/wpml-pro-translation.class.php on line 456 Notice: Trying to get property 'post_type' of non-object in /usr/home/paraninfo.com/web/pre/wp-content/plugins/wpml-translation-management/inc/translation-proxy/wpml-pro-translation.class.php on line 457

3. En la lista de traducciones, hago clic en el botón Editar del artículo recién traducido. Vuelve a abrirse el ATE, la traducción aparece ya completa al 100%. Hago clic en Finish y después, el artículo sí aparece en el listado en inglés, y sí se muestra el post.
En la lista de los cursos en español, el curso aparece ahora con el icono del lápiz, pero la traducción en el ATE está al 100%.
Además, al hacer un cambio en el texto en español, y volver a traducir al inglés, hay que repetir todo el proceso.

Gracias por tu ayuda.

mayo 30, 2019 a las 1:52 pm #3923511

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+01:00)

Hola,

Gracias por tu ayuda. 🙂

Si entiendo bien, todo parece funcionar ahora. Sin embargo, hay algo que debemos corregir. Como puedes ver tu WPML_SITE_ID:global y WPML_SITE_ID:ate son diferentes.

- Haz un backup completo de tu base de datos.
- Copia el valor del WPML_SITE_ID:global y reemplaza el valor del WPML_SITE_ID:ate.
- Ve a WPML > Settings y sincroniza tus traductores ATE.

Saludos,
Andrés

mayo 31, 2019 a las 9:32 am #3929071

asierR

Hola Andrés,

1. Copié el valor del WPML_SITE_ID:global y reemplacé el valor del WPML_SITE_ID:ate. Me dio un error, adjunto captura. Lo he hecho al revés, copié WPML_SITE_ID:ate y lo puse en WPML_SITE_ID:global. En este caso no me da error, ¿lo dejo así o recupero las claves anteriores?

2. Sincronicé los traductores pero sigue apareciendo el mensaje "El Editor de traducción avanzado está habilitado pero no activo". ¿Es esto normal?

3. El problema NO está resuelto. En mi mensaje anterior te indiqué un procedimiento con el que consigo que se muestre el contenido traducido, pero no es la solución correcta. Al finalizar la traducción, debería mostrarse directamente el artículo traducido sin tener que ir a WPML > Traducción, y allí volver a enviar la traducción.

Además, al entrar en WPML > Traducción, aparece el mensaje que ya te indiqué en mi mensaje anterior. Este mensaje indica que algo va mal. Te lo vuelvo a copiar:

Notice: Trying to get property 'post_type' of non-object in /usr/home/paraninfo.com/web/pre/wp-content/plugins/sitepress-multilingual-cms/inc/absolute-links/absolute-links.class.php on line 559 Notice: Trying to get property 'post_content' of non-object in /usr/home/paraninfo.com/web/pre/wp-content/plugins/sitepress-multilingual-cms/inc/absolute-links/absolute-links.class.php on line 563 Notice: Trying to get property 'post_content' of non-object in /usr/home/paraninfo.com/web/pre/wp-content/plugins/sitepress-multilingual-cms/inc/absolute-links/absolute-links.class.php on line 567 Notice: Trying to get property 'post_content' of non-object in /usr/home/paraninfo.com/web/pre/wp-content/plugins/wpml-translation-management/inc/translation-proxy/wpml-pro-translation.class.php on line 456 Notice: Trying to get property 'post_type' of non-object in /usr/home/paraninfo.com/web/pre/wp-content/plugins/wpml-translation-management/inc/translation-proxy/wpml-pro-translation.class.php on line 457

Un saludo

mayo 31, 2019 a las 1:13 pm #3930783

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+01:00)

Gracias por la aclaración.

El error que se muestra en esta pantalla debe tratarse en un ticket separado, ya que hemos mencionado muchos tópicos y corremos el riesgo de que se dificulte seguir el hilo del problema central.

Ahora bien:
- Deja los datos de la base de datos con la modificación.
- Puedes omitir el mensaje de alerta.

Volviendo al problema central, el procedimiento que realizas sirve para refrescar los trabajos de traducción y por ello es efectiva. Si dicha solución no te parece efectiva, entonces:
- Ve a WPML > Translation management > Translation jobs.
- Borra todos los trabajos de traducción problema.
- Envíalos de nuevo. Con la memoria de traducción no deberías perder con los trabajos ya traducidos.

¿Funciona esta vez?