Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

Etiquetado: 

This topic contains 19 respuestas, has 3 mensajes.

Last updated by Carlos Rojas hace 10 meses, 3 semanas.

Assigned support staff: Carlos Rojas.

Autor Publicaciones
febrero 1, 2019 a las 12:18 pm

albertoG-18

Estoy tratando de: Localizar una cadena de texto de un elemento Header de GeneratePress

URL de (mi) sitio web donde aparece el problema: hidden link

Yo esperaba ver: La cadena de texto "Servicios de limpieza profesional eficaz y segura"

En vez de eso, obtuve:No la localizo.

Se trata de una cadena de texto que se encuentra en el Header del Elemento de GeneratePress. La cadena de texto dice "Servicios de limpieza profesional eficaz y segura."
No la localizo entre las cadenas a traducir. He buscado cadena nuevas en Localización de temas y plugines pero tampoco puedo localizarla. He buscado el texto en la pantalla de administración pero tampoco lo encuentro. He intentado subir a esta solicitud de soporte imágenes que reflejan mejor el problema pero me da HTTP error.

febrero 1, 2019 a las 3:42 pm #3152305

Yvette
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hola

Me ha costado entender - pero ahora veo que este información viene de un "elemento" de Generate Press:

Appearance > Elements

Veo el contenido de "Home Page Header" tiene el texto que quieres traducir.
Parece que es nuevo con este versión de GP:
hidden link

Normalmente, como esta traducido este elemento, tendría que mostrar el elemento correspondiente al idioma activo. Pero, vero que este no sucede.

Así que parece ser un problema de compatabilidad.
Pido si puedes subir tu tema aquí para recrear el problema en un instalación nuevo:
hidden link

Este instalación esta pre-configurado con los plugins WPML.
Si coneguimos recrear el elemento tal como lo tienes en tu sistema, puedo enviar el problema a nuestro equipo de compatibilidad para más investigación.

Gracias por tu colaboracion.

febrero 2, 2019 a las 11:50 am #3154197

albertoG-18

Muchas gracias Yvette.

Por favor, indícame los pasos que debo realizar en hidden link para subir el tema.

Gracias.

febrero 3, 2019 a las 3:00 pm #3155542

Yvette
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+01:00)

Ir a
Appearance > Themes > Add new

Cargar el zip de tu tema.
Leugo, configiurarlo para poder crear un ejemplo sencillo de esta elemento.

Avisame cuando está hecho
Gracias!

febrero 4, 2019 a las 10:40 am #3157130

albertoG-18

Hola Yvette.

Ya he subido el tema e instalado todos los plugins propios de tema que recomienda Generatte Press. Si necesitas algo más, házmelo saber, gracias.

febrero 5, 2019 a las 8:53 am #3160757

Yvette
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hola

Si - necesito que actualizas el plugin "GP Premium" (ver imagen).

He podido replicar el problema y en cuanto confirmamos que el mismo problema sucede con el último versión de este plugin, podemos enviar el problema a nuestro equipo de compatiblidad para resolución.

Gracias

febrero 6, 2019 a las 1:28 pm #3165749

albertoG-18

Hola Yvette.

Gracias por tu paciencia y atención.

Acabo de entrar al Dashboard y veo que el plugin ya está actualizado. Me mantengo a la espera de tus noticias al respecto.

Saludos cordiales.

Alberto.

febrero 7, 2019 a las 2:14 pm #3170617

Yvette
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+01:00)

Creo que no estas enfocando en el buen plugin.

Acabo de verificar que el plugin "GP Premium" del sanbox sigue al nivel 1.7.2
Necesita actulaizarlo a version 1.7.7 . por favor.

febrero 11, 2019 a las 3:35 pm #3183855

albertoG-18

Hola Yvette.

GP Premium ya está actualizado a la versión 1.7.7

Disculpa el error.

Permanezco a la espera de noticias tuyas al respecto, gracias.

Saludos, Alberto.

febrero 14, 2019 a las 11:36 am #3199157

Yvette
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+01:00)

Gracias de nuevo. Ya esta escalado al equipo de compatabilidad para más investigación.

febrero 19, 2019 a las 7:47 pm #3218732

albertoG-18

Hola Yvette.

Agradezco mucho la atención e interés, tan sola una pregunta...... ¿Cuanto tiempo puede tardar esta situación?

Saludos, Alberto

febrero 20, 2019 a las 10:04 am #3220686

Yvette
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+01:00)

Lamento que puede tardar mucho - sobre todo como este es un nuevo "feature" de GeneratePress. Veo que estén investigando - pero cual quier solución, vendrá últimamente desde el autor de tu tema y no nosotros.

PIensa que, para nuestro equipo, es una esfuerza "plus" de tener que leer/entender como está construido este nueve módulo que no está escrito por nosotros.

Si hay un "workaround" descubierto, claro que te lo comunicamos, pero no es nuestra politica de tocar/cambiar código no escrito por nuestros propios programadores.

Para tener un respuesta más rápido, recomiendo que te pongas en contacto con el soporte de tu tema para que haya presión sobre los dos lados. Como ellos tienen un relación ya abierto con WPML, será el canal más rápido.

febrero 21, 2019 a las 4:21 pm #3228843

albertoG-18

Perfecto. entiendo.

Muchas gracias por todo.

Saludos, Alberto.

febrero 25, 2019 a las 11:50 am #3239527

Yvette
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hola

Tengo noticias. Han loacalizado el problema y ofrecen este como un "workaround" temporal.

Puedes intentarlo y avisarme si funciona para ti?
Mientras tanto, el autor del plugin ha sido notifiicado del problema.

Puedes verlo aquí:
hidden link

=====================================
As temporary workaround, user can remove is_admin check
Archivo: gp-premium/elements/elements.php
Linea: #12

//if ( is_admin() ) {
require plugin_dir_path( __FILE__ ) . 'class-post-type.php';
//}

Y en el mismo archivo, linea: 23
Función: generate_premium_do_elements()
cambiar estas lineas

$args = array(
		'post_type'     => 'gp_elements',
		'no_found_rows' => true,
		'post_status'   => 'publish',
		'numberposts'	=> 500,
		'fields'		=> 'ids',
		'order'			=> 'ASC',
	);

a

$args = array(
		'post_type'     => 'gp_elements',
		'no_found_rows' => true,
		'post_status'   => 'publish',
		'numberposts'	=> 500,
		'fields'		=> 'ids',
		'order'			=> 'ASC',
		'suppress_filters' => false,
	);
marzo 5, 2019 a las 11:13 am #3273243

albertoG-18

Hola Yvette.

Lo siento, no funciona la opción propuesta.

También he descargado actualizaciones del plugin y tampoco funciona

Permanezco a la espera.

Gracias.