Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

Etiquetado: 

This topic contains 6 respuestas, has 3 mensajes.

Last updated by optika.es hace 3 años, 7 meses.

Assigned support staff: Yvette.

Autor Publicaciones
marzo 16, 2016 a las 1:06 pm #839265

carlos

Hola,

En mi web estoy utilizando WPML + Wocommerce con el plug-in Redsys Woocommerce, y tengo el problema descrito en estos hilos:

https://wpml.org/es/forums/topic/anade-directorio-de-idioma-a-imagenes-de-plugins/
https://wpml.org/es/forums/topic/imagen-enlace-roto-ogotipo-de-redsys-i-paypal/

Me gustaría saber si se ha llegado a alguna solución ya que los hilos aparecen como resueltos.

Saludos

marzo 17, 2016 a las 9:35 am #839993

Yvette
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+02:00)

Veo en estos hilos que nunca han ido más lejos que identificar el problema. Supongo que estos dos hilos han optado para ir con el solución alternativa que sugerió mi colega:

" Sin embargo existe otra que tal vez puedas utilizar:
https://wordpress.org/plugins/redsys-gateway-for-woocommerce/
"

Confirmo que en este momento, no estamos en contacto con los autores de "Redsys woocommerce" plugin. En cambio, con Redsys Gateway for Woocommerce - entramos en los últimos fases de testing.

Así que, en respuesta a tu pregunta original: no hay solución aún.

Espero que he podido responder a tu duda. Si optas para abrir el proceso de compatibilizar el plugin Redsys Gateway for Woocommerce, me podrías dar las credenciales de tu sitio web de prueba, de esta manera podemos dar un vistazo a tus ajustes, así como los pasos necesarios para reproducir este comportamiento ?

marzo 17, 2016 a las 11:06 am #840107

carlos

Hola Yvette,

Gracias por tu respuesta. La verdad es que preferiría continuar utilizando el plug-in "Redsys woocommerce" ya que está desarrollado por el propio Redsys. Creo que sería bueno que os pusierais en contacto ya que este problema puede estar bastante extendido. También he escrito a Redsys informando del problema.

En esta página puedes encontrar la información y descarga del plug-in de Redsys hidden link

Gracias

marzo 17, 2016 a las 11:57 am #840166

Yvette
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+02:00)

Ok!

Para facilitar la comunicación del problema exacta - podrías subir imágenes que illustra el problema y también pasos como :
1. realizar una configuración básica del plugin
2. replicar el problema.

Gracias.

marzo 17, 2016 a las 12:53 pm #840235

carlos

Claro, aquí tienes.

Adjunto una captura de pantalla con la configuración actual del plug-in, otra de WPML strings y otra del propio error.

En español, que es el idioma principal de la web, funciona correctamente. Pero en inglés no se muestra el logo de Redsys. Te indico además otro error, y es que no se puede traducir el texto que lo acompaña al logo.

Lo explico:

1. LOGO
En inglés la imagen del logo aparece rota ya que se genera esta URL de forma automática.
hidden link

El logo realmente se encuentra ubicado en:
hidden link

El plug-in no permite modificar la imagen o su ruta.

2. TEXTO
No puedo traducir el texto que acompaña el logo ("Tarjeta de crédito") y la descripción que aparece al pulsar.

Por algún motivo el plug-in añade el texto que se incorpora en las casillas Título y Descripción que aparece en la pantalla de configuración como texto en Inglés (el idioma secundario de mi site) y es posible cambiar la traducción a Español con la traducción de cadenas de WPML. Una vez guardado el texto del apartado configuración, aunque lo cambie posteriormente, por algún motivo no se actualiza original en string.

Espero que más o menos esté clara la explicación. Si necesitas más información no dudes en indicármelo.

Gracias de nuevo!

marzo 18, 2016 a las 11:59 am #841106

Yvette
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hola.

Al final el problema ha sido fácil solucionar. Tendrás que cambiar el código en
../plugins/redsys/class-wc-redsys.php linea 56

de

$this->icon  = home_url() . '/wp-content/plugins/redsys/pages/assets/images/Redsys.png';

a

$this->icon  = site_url() . '/wp-content/plugins/redsys/pages/assets/images/Redsys.png';

Espero que este solución responde a tu problema.

septiembre 2, 2019 a las 11:32 am #4496585

optika.es

Gracias lo he hecho y funciona. De paso he hecho un png con sentido, he quitado el fondo blanco que traía la imagen.
Por cierto, ya le puedes decir lo que quieras al SAT que te recomiendan comprar un plugin de terceros, confiesan que el suyo es una cosita de andar por casa (me lo han dicho y no supe qué responder, no quise seguir hablando).
Cuando tengo problemas con alguna tienda, recurro a modulosdepago y me lo han resuelto.
Saludos y gracias de nuevo.