Skip Navigation

Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en los foros 6 días a la semana, 22 horas por día.

Hoy no hay asistentes de soporte disponibles en el foro Spanish. Siéntase libre de enviar sus tiques y les daremos trámite tan pronto como estemos disponibles en línea. Gracias por su comprensión.

This topic contains 6 respuestas, has 2 mensajes.

Last updated by Otto hace 4 años, 6 meses.

Assigned support staff: Otto.

Autor Mensajes
enero 27, 2016 a las 10:34 am #797436

andoni larrañaga

Hola;

Utilizo la Versión 2.1.18 de WPML Media.

Necesito mantener la misma ID a la hora de duplicar el contenido de los posts.

Tengo las siguientes opciones de Media desactivadas:

*Los elementos multimedia subidos a la biblioteca de medios estarán disponibles en todos los idiomas
*Duplicar los elementos multimedia adjuntos para las traducciones
*Duplicar las imágenes destacadas para las traducciones

Pero al duplicar un post con imagen destacada en el duplicado la imagen tiene un ID diferente.

Como puedo hacer esto sin desactivar el WPML Media?

Gracias!

enero 27, 2016 a las 1:27 pm #797658

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola,

Gracias por contactarte con el foro de soporte!

Para poder ayudarte mejor, podrías proveerme la información de WPML Debug?
http://wpml.org/faq/provide-debug-information-faster-support/
He habilitado los campos necesarios para que lo hagas en tu próxima respuesta.

Puedo preguntarte por qué necesitas que tengan el mismo ID? Tal vez haya un hook que pueda ayudarte:
https://wpml.org/documentation/support/wpml-coding-api/wpml-hooks-reference/#top

Quedo a la espera de tu información.

Un saludo cordial,

Otto

enero 28, 2016 a las 10:49 am #798598

andoni larrañaga

Hola!

Tenemos una compleja red de webs que se sincronizan remotamente entre si.

Usamos WPML desde el principio, y estamos actualizando todo el sistema a las ultimas versiones.

La cuestion es que antes WPML nos asignaba el mismo ID a la imagen y ahora no...
Hemos revisado la configuración pero no encontramos nada que nos sirva.

¿Se puede hacer que WPML use el mismo ID con las imagenes?

Gracias!

enero 28, 2016 a las 1:56 pm #798871

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola,

Muchas gracias por la explicación.

He escalado el ticket a nuestro soporte de segundo nivel. Ya que no estoy seguro que esto se trate de un bug o del comportamiento esperado.

Ellos investigarán el problema y se pondrán en contacto contigo en cuanto tengan una solución.

Dado que no hay supporters de segundo nivel que hablen inglés, sería un problema para ti continuar en ese idioma? Sino yo puedo intermediar en la comunicación, solo que será algo más lento el proceso.

Un saludo cordial,

Otto

enero 29, 2016 a las 10:28 am #799651

andoni larrañaga

Hola Otto;

No creo que sea un bug, sino un cambio en la actuación del plugin.

Pero me gustaria saber si es posible recuperar el comportamiento anterior.

Sin ningun problema para continuar el soporte en Ingles.

Muchas gracias!

enero 29, 2016 a las 11:00 am #799702

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Perfecto, muchas gracias.

Un saludo cordial,

Otto

febrero 2, 2016 a las 11:50 am #802348

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola,

Nuestro soporte de segundo nivel ha realizado pruebas con versiones anteriores de WPML y el comportamiento es el mismo. Por lo que este sería el comportamiento esperado al duplicar entradas.

Puedes comprobarlo descargando las versiones anteriores y activándolas en una instalación nueva de WP.
https://wpml.org/download/wpml-multilingual-cms/?section=changelog

Dime si en un contexto mínimo (sin otros plugins y con un tema de WP por defecto) con alguna versión obtienes otro comportamiento por favor.

Un saludo cordial,

Otto

El debate ‘[Cerrado] Media: Necesito mantener el ID de la imagen destacada al duplicar post’ está cerrado y no admite más respuestas.