Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

Etiquetado: 

This topic contains 11 respuestas, has 2 mensajes.

Last updated by Andreas W. hace 3 semanas, 1 día.

Assigned support staff: Andreas W..

Autor Publicaciones
septiembre 16, 2019 a las 3:38 pm #4582101

jonG-6

Estoy tratando de: He creado una página Onepage en castellano (predeterminado) y euskera (traducido). En uno de los apartados hay enlaces a otras páginas. En el idioma traducido, estando en esta página, el menú lleva a la home del idioma predeterminado, no al traducido

URL de (mi) sitio web donde aparece el problema: hidden link

Yo esperaba ver: hidden link

En vez de eso, obtuve: hidden link

septiembre 16, 2019 a las 10:11 pm #4584399

Andreas W.
Supporter

Languages: Inglés (English ) Español (Español ) Alemán (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hola,

Gracias por contactar con el Foro de soporte de WPML.

Tenga en cuenta que el menú solo funcionará para páginas que ya están traducidas al 100%.

Vaya a WPML -> WP Menus Sync y sincronice los menús. Entonces debería ver en la parte inferior de la página algunos enlaces a la traducción de cadenas para traducir los elementos del menú que faltan. Traduce las cadenas en la traducción de cadenas.

¿Esto resolvió el problema?

Saludos cordiales
Andreas

septiembre 17, 2019 a las 8:07 am #4586243

jonG-6

Hola Andreas,

Los menús están sincronizados y las páginas traducidas al 100%, pero me sigue dando el mismo error. En la página de inicio (onepage) el menú funciona correctamente en los dos idiomas. Pero en otra de las páginas no.

septiembre 17, 2019 a las 3:16 pm #4589615

Andreas W.
Supporter

Languages: Inglés (English ) Español (Español ) Alemán (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hola,

para poder investigar mejor el problema necesitaría, si fuera posible, que me permitas acceder a tu sitio temporalmente. Mucho mejor si tuvieras un sitio de pruebas en donde esté replicado el problema.

Encontrarás los campos necesarios debajo del área de comentarios. He marcado la próxima respuesta como privada, por lo que la información que ingreses solo la veremos tu y yo.

Es posible que necesite replicar tu sitio localmente. Para eso voy a necesitar instalar un plugin llamado "Duplicator". Con él podré crear una copia completa de tu web. Una vez que el problema esté resuelto, borraré la copia local. Dime por favor si estás de acuerdo.

IMPORTANTE

Por favor haz un back up completo de tu sitio y base de datos antes de proveer los datos de acceso
Si no ves este formulario para completar los campos confidenciales NO los publiques, ya que serán visibles en el foro:
hidden link

En ese caso, pídeme que vuelva a habilitar una respuesta privada.

Muchas gracias.
Un saludo cordial,
Andreas

septiembre 17, 2019 a las 5:44 pm #4590497

Andreas W.
Supporter

Languages: Inglés (English ) Español (Español ) Alemán (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hola,

Hay un solo menú en el sitio llamado: "menú feria stock" y se asigna como menú principal.

Este menú utiliza accesos directos a enlaces internos del sitio pegados en el diseño de la página de inicio.

El menú se traduce en Apariencia -> Menús.

En ambas páginas de inicio, el menú funciona como se esperaba.

Ahora, no veo enlaces o menús en la página de inicio que me guíen a páginas adicionales como, por ejemplo, "Markak".

Cuando voy a hidden link, me doy cuenta de que los elementos del menú se vinculan al idioma predeterminado.

Disculpe mi pregunta, pero realmente no entiendo por qué hay páginas individuales para las secciones que ya están incluidas en la página de inicio. ¿Podrías clarificarme, ya que el menú principal no está vinculado a páginas diferentes que la página de inicio, como los visitantes van a llegar a estos paginas?

Lo que estoy tratando de decir es que el menú principal que incluye enlaces que se basan en el diseño de la página de inicio en sí no podrá vincular a otras páginas de esta manera.

Sería aconsejable crear menús individuales para las otras páginas en este caso. POr ejemplo dar accesso a las paginas con un button en los seccion de la pagina inicial y creer un segundo menu para aceder todo los paginas existentes y para retroser al inicio.

https://wpml.org/es/documentation-2/guia-de-inicio/traduccion-de-menues/

Saludos cordiales
Andreas

septiembre 18, 2019 a las 8:08 am #4593523

jonG-6

Buenos días,
Los usuarios de esta web sólo tienen que ir a la página de inicio y a las páginas adicionales "fitxa..." (ejemplo: hidden link) que se accede desde el apartado 'non' de la página de inicio. Y es en estas páginas donde los elementos del menú se vinculan al idioma predeterminado.

Existen páginas adicionales como bien dices, por ejemplo "Markak". Pero los usuarios no tienen que llegar a esta página, no hace falta ningún vinculo. Están creadas porque la plantilla de WP funciona a modo de secciones. Se crean esas páginas, y en Apariencia > Menús, se aplica 'Menu type > Onepage Section'. Así funciona la plantilla.

Tampoco creo que la plantilla me deje crear otro menú y aplicarlo solo a las páginas individuales... No sé si me explico...

Saludos

septiembre 18, 2019 a las 9:10 pm #4599973

Andreas W.
Supporter

Languages: Inglés (English ) Español (Español ) Alemán (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hola,

Lamento la confusión. Ahora veo que el tema de hecho no es compatible con varias secciones del menú.

Me gustaría pedirte que instales el tema en el siguiente sitio de prueba para que pueda probar su compatibilidad.

One Click Login: hidden link

En caso de que encuentres el tiempo para recrear el problema de una manera mínima, sería muy útil y ahorraría tiempo.
En el próximo paso, voy a escalar el problema a nuestro equipo de compatibilidad para investigar y trabajar en una solución para el problema.

Por favor, déjame una breve notificación una vez que el sitio esté listo.

Saludos cordiales
Andreas

septiembre 18, 2019 a las 9:13 pm #4599975

Andreas W.
Supporter

Languages: Inglés (English ) Español (Español ) Alemán (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hola,

Además de mi último mensaje, asegúrate de actualizar WPBakery Page Builder a su última versión para ver si el problema persiste.

Asegúrate de instalar cualquier complemento en el sitio de prueba que sea necesario para recrear el problema, para lo cual WPBakery podría no ser una excepción.

Tengas en cuenta que al traducir páginas creadas con el generador de páginas (WPBakery), recomendamos también instalar nuestros complementos:

- traducción de cadenas (String Translation)
- gestión de traducciones (Translation Management)

Puede encontrarlos en Complementos -> agregar nuevo -> Comercial.

Ahora, sincronices el menú nuevamente una vez que se haya instalado la traducción de cadenas y luego traduzcas los elementos que faltan en la traducción de cadenas. Aparecerá una notificación en la parte inferior de WPML -> WP Menus Sync, justo después de sincronizar el menú.

Saludos cordiales
Andreas

septiembre 19, 2019 a las 10:45 am #4603759

jonG-6

Hola,

He actualizado WPBakery a su última verisón, pero el problema persiste.
También he instalado vuestros complementos 'String Translation' y 'Translation Management', pero todo sigue igual.

He instalado el tema en el sitio de prueba que me has dicho y he intentado crear una sencilla estructura con las mismas propiedades que la página original. Y el problema se repite.

Cualquier cosa que necesitéis decidme, y a ver si podemos solucionar el problema!

Muchas gracias por todo!

septiembre 19, 2019 a las 11:33 am #4604307

jonG-6

Se me ha olvidado comentar que cuando he instalado el tema en el sitio de prueba, he intentado actualizar a la última versión el WPBakery, pero no me deja hacerlo. He intentado eliminar el plugin para poder subir la última versión, pero tampoco me deja eliminar... No entiendo porqué. Espero que no sea relevante para poder hacer las pruebas que necesitéis hacer.

septiembre 19, 2019 a las 5:24 pm #4607635

Andreas W.
Supporter

Languages: Inglés (English ) Español (Español ) Alemán (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hola,

Muchas gracias por recrear el mismo problema en el sitio de prueba.

Puedo ver que también en esta nueva instalación de WordPress el problema existe en la página traducida.

Me pondré en contacto con nuestro equipo de compatibilidad para escalar este problema y solicitar una solución.

Una vez que reciba los comentarios de nuestros desarrolladores, estaré en contacto.

Saludos cordiales
Andreas

septiembre 24, 2019 a las 2:30 pm #4632471

Andreas W.
Supporter

Languages: Inglés (English ) Español (Español ) Alemán (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hola,

Nuestro equipo de compatibilidad encontró la razón del problema que se basa en el archivo de tema:

wp-content / themes / phoenix-v1.5 / fastwp / fastwp.user.interface.php en la línea 385

Por favor cambie esta línea a:

  $ href = home_url (). $ href;

Tengas en cuenta que esos cambios pueden sobrescribirse con una actualización del tema. Te recomendaría que te ponga en contacto con el autor del tema para aconsejarle que incluya el cambio en el archivo de su tema.

Saludos cordiales
Andreas