Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

Hoy no hay asistentes de soporte disponibles en el foro Spanish. Siéntase libre de enviar sus tiques y les daremos trámite tan pronto como estemos disponibles en línea. Gracias por su comprensión.

This topic contains 29 respuestas, has 2 mensajes.

Last updated by sergioO-10 hace 3 meses, 2 semanas.

Assigned support staff: Andrés.

Autor Mensajes
mayo 13, 2019 a las 7:51 pm #3801423

sergioO-10

Despues de actualizar a wordpress 5.2 mi website dejo de fundionar y me enciaba error 503. Tuve que entrar a mi hosting ftp al administrador de archivos y desactivar todos los plugins y empezar a activar 1 a 1 para ver cual era el que me ocasionaba este problema. Hasta que finalmente me di cuenta que era el WPML Multilingual CMS. Me toco desactivarlo para poner mi website nuevamente en funcionamiento. Necesito saber que sucede para poder activarlo nuevamente porque necesito mi website traducido al italiano como estaba antes.

mayo 14, 2019 a las 3:22 am #3803063

sergioO-10

Al activar el plugin WPML Multilingual CMS nuevamente se vuelve a caer mi website y tampoco me dejar entrar al administrador wp-admin. Cuando vuelvo a desactivar el plug in por el FTP mi pagina vuelve a funcionar correctamente.

mayo 14, 2019 a las 5:57 am #3803839

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola,

Bienvenido al soporte de WPML.

¿Podrías revisar si existe algún error PHP?

Sería genial si me puedes suministrar la información del debug.log de WordPress (No la confundas con la información de depuración de WPML).

Por favor abre tu archivo wp-config.php y busca la línea que dice: define(‘WP_DEBUG’, false);. y cámbialo por:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

Luego busca en la carpeta /wp-content/ y mira si existe algún archivo debug.log.

Si puedes agregar la información del debug.log en pastebin.com y proveerme el link sería aún mejor (Es la manera más limpia porque algunas veces los logs pueden ser muy largos y la conversación se puede volver desordenar mucho).
https://wpml.org/documentation/support/debugging-wpml/

Un saludo,
Andrés

mayo 14, 2019 a las 7:26 pm #3810323

sergioO-10

Esto debo hacerlo con el plugin que me genera el problema activado ?

mayo 14, 2019 a las 8:28 pm #3810541

sergioO-10

Hola, acabo de hacer lo que me dices con el plugin produciendo el error. A continuación te dejo el link con la información que me solicitaste.

https://pastebin.com/biEN5Znh

Saludos

mayo 15, 2019 a las 1:53 am #3811285

sergioO-10

Hay alguien más del soporte técnico que me pueda ayudar a solucionar el problema ? Ya han pasado mas de 6 horas y sigo sin obtener respuesta.

Muchas gracias.

mayo 15, 2019 a las 5:18 am #3812291

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola,

Disculpa la tardanza en contestar, pero si accedes a nuestros perfiles podrás ver la zona horaria en la que nos encontramos, ¿te gustaría que te transfiera a alguien en América ya que estoy en Europa?

Ahora bien, para continuar:

1. Si desactivas temporalmente nuestro Yoast SEO Multilingual, ¿la situación cambia?

2. Se trata de una nueva instalación y aún no has comenzado a traducir tu contenido, si es así, tal vez puedas considerar reiniciar tu WPML ya que veo varios errores asociados a tu base de datos.

Saludos

mayo 15, 2019 a las 7:36 pm #3819989

sergioO-10

Hola,

Desactivé temporalmente el plugin que me dijiste Yoast SEO Multilingual y la situación sigue siendo exactamente la misma. El plugin que esta causando el problema es WPML Multilingual CMS.

De hecho, acabo de recibir un mensaje de wordpress confirmando que ese es el plug in que esta causando los problemas.

Adjunto el mensaje:

"Howdy!

Since WordPress 5.2 there is a built-in feature that detects when a plugin or theme causes a fatal error on your site, and notifies you with this automated email.

En este caso, WordPress detectó un error con uno de tus plugins, WPML Multilingual CMS.

Detalles del error
==================
Se produjo un error de tipo E_COMPILE_ERROR en la línea 13 del archivo /home/zny97zvu4mox/public_html/wp-content/plugins/sitepress-multilingual-cms/vendor/otgs/installer/includes/class-otgs-installer-autoloader.php. Mensaje de error: require(): Failed opening required '/home/zny97zvu4mox/public_html/wp-content/plugins/sitepress-multilingual-cms/vendor/otgs/installer/includes/otgs-installer-autoload-classmap.php' (include_path='.:/opt/alt/php72/usr/share/pear')

"

Lo segundo que me comentas no se que tan viable es puesto que la web ya esta toda traducida a la version en italiano. Solo que desde que comenzó el problema con este plugin el website ya no aparece en italiano y el que está en español no abre mientras el plugin conflictivo esta activado.

No puedo adjuntarte la WPML debug info porque al tener el plugin descativado no me aparece el menu de WPML y si activo el plugin se cae la web y no me deja acceder ni siquiera al modo administrador.

mayo 16, 2019 a las 4:54 am #3821977

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola,

Gracias de nuevo por tu ayuda. Ahora bien, el nuevo error que reportas indica que faltan archivos de WPML y por ello el problema:

¿Podrías desinstalar e instalar tu paquete WPML manualmente?

=========================
*Realiza un backup de la base de datos*
=========================
Puedes usar un plugin como Duplicator para este propósito. Mira en: http://wordpress.org/plugins/duplicator/

- Desactiva y borra el plugin installer (si lo tienes).
- Desactiva todos los plugin WPML.
- Ingresa via FTP a wp-content/plugins/ folder.
- Borra los directorios WPML.
- Descarga las últimas versiones del paquete WPML Multilingual CMS en http://wpml.org/my-account/downloads/.
- Sube los plugins via FTP a wp-content/plugins/ folder.
(o a través de un archivo .zip a través del Dashboard > Plugins > new > upload).
- Activa el plugin WPML via WP Dashboard > plugins.
- Completa la instalación si es necesario.
- Registra WPML para tu sitio (al final del proceso de instalación da click en el botón de generación de llave).
- Ve a Dashboard > Plugins y localiza WPML Multilingual CMS.
- Da click en el enlace azul que dice "Registro".
- Descarga y activa todos módulos WPML.

Esto no debe generar ningún problema.

En el caso que desees registrar WPML para tu sitio de manera manual, por favor asegúrate de entrar la URL raíz en wpml.org (algo como hidden link)

En el caso extremo, trata de realizar el registro con todos los plugins no relacionados con
WPML desactivados.

También puedes seguir este video:
hidden link

Saludos,
Andrés

mayo 16, 2019 a las 4:32 pm #3828001

sergioO-10

Realicé todo lo que me indica y al volver a instalar WPML con todos los componentes volvio a bloquearse mi website y a salir el mismo error.

mayo 16, 2019 a las 4:42 pm #3828041

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Quisiera descartar que no se trate de un problema asociado a tu servidor. Por esta razón he creado un sitio de prueba en nuestro servidor Cloudways. En el mensaje privado anterior te he enviado las instrucciones para realizar la migración.

Quedo pendiente de confirmación una vez la migración haya terminado.
Saludos

mayo 16, 2019 a las 7:36 pm #3829251

sergioO-10

Hola Andrés, antes de realizar la migración borré todas las paginas que tenia traducidas, borre los plugins de WPML, los reinicie cuando los volvi a instalar y al activarlos vuelve y deja de funcionar mi web. En vista a que esto no funcionó seguí tus instrucciones y migré el sitio como me lo pediste.

Quedo atento.
Gracias.

mayo 17, 2019 a las 6:23 am #3831599

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Muchas gracias por tu ayuda. En este momento acabo de acceder a nuestro sitio de pruebas y todo parecen funcionar correctamente cuando solo WPML está activo.

Como he tenido que desactivar plugins y cambiar los accesos para poder acceder, ¿podrías verificar si todo funciona correctamente o cómo producir el error?

Los accesos están en el mensaje privado anterior.

Saludos

mayo 17, 2019 a las 1:51 pm #3835035

sergioO-10

Buenos dias Andres, no se que sucede que en esa web de prueba no sale el error. Intenté nuevamente desde la original e inmediatamente activo el plugin de Wpml deja de funcionar.

Tambien te queria preguntar porque esta manana me llego un correo de wordpress informando sobre el cambio de contraseña de mi usuario.

mayo 17, 2019 a las 2:56 pm #3835371

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola,

Como puedes ver todo funciona correctamente en nuestro servidor, eso quiere decir que el problema está ligado al tuyo, probablemente no tenga los recursos necesarios.

En tu sitio de prueba podrías revisar que esta situación se presenta cuando:
- Sólo el paquete WPML está activado. Esto nos dirá si hay algún problema de interacción con otro plugin.
- Cambias a un tema por defecto de WordPress como el Twenty Fourteen. Esto nos dirá si hay un problema de interacción con tu tema.
- Si el problema desaparece, activa uno por uno para determinar quién genera esta situación.

Para responder a tu otra pregunta, como no compartiste tus credenciales, tuve que solicitar un nuevo usuario en nuestro sitio de prueba. Por eso has recibido el correo.

Quedo atento a tus hallazgos.
Saludos