This thread is resolved. Here is a description of the problem and solution.

Problem: Al intentar buscar cadenas a traducir en el panel de control, no nos aparece nada.

Solution: Cambiar el "collation" de todas las tablas y de todos los campos a "utf8mb4_general_ci"

Relevant Documentation: Ninguno

Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

This topic contains 8 respuestas, has 2 mensajes.

Last updated by marcalS hace 4 años.

Assigned support staff: Yvette.

Autor Publicaciones
marzo 16, 2016 a las 8:48 am #838942

marcalS

Estamos desarrollando una web que tiene 4 idiomas totalmente traducidos manualmente. Ahora queremos introducir un nuevo idioma que deberán traducir desde la delegación de Polonia. Quisiéramos gestionar la traducción con la administración de traducción.

Hemos creado un usuario traductor y le hemos asignado la traducción del ingles al polaco.

El problema está al intentar buscar documentos a traducir en el panel de control, que no nos aparece nada. Aunque no hagamos ninguna selección y intentemos que nos lo muestre todo, no nos muestra nada.

Alguna solución?

marzo 16, 2016 a las 8:58 pm #839684

Yvette
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+02:00)

Buenos dias.

1. Clarificación
Me podrías clarificar si cuando dices "no nos aparece nada" este implica que igual no aparece nada si creas un nuevo página/poste en un idioma existente que no tiene nignún traducción? o solo que no aparece documentos para traducir a polaco?

2. Requerimientos mínimos
He notado que tu entorno no satisface los requerimientos mínimos para un funcionamiento normal de WPML.
Aqui más información a respeto: https://wpml.org/home/minimum-requirements/

Concretamente,
2.1 El nivel mínimo de PHP y SQL es 5.6 y veo que las versiones que tienes instalado son: PHP 5.4.45 y SQL 5.5.47

2.2 También la cantidad de memoria PHP definido por WordPress debería estar a 128M. Actualmente veo que lo tienes definido a 40M.

Podrías ajustar estos parámetros de configuración para ver si afecta la situación que describas?

Gracias por avisar.

marzo 17, 2016 a las 9:28 am #839983

marcalS

Clarificación: Tenemos las páginas creadas en español y traducidas a catalán, inglés y francés. Ahora hemos configurado un nuevo idioma (polaco) y tenemos la opción de hacer la traducción manual. Pero nos interesa utilizar la administración de traducción para assignar las paginas a traducir al usuario traductor de polaco.

En el panel de traducción hacemos las búsquedas de paginas pero al dar al botón mostrar, no nos muestra nada. Incluso intentando mostrar-lo todo(sin filtrar) no nos aparece nada.

Voy a mirar si puedo cambiar las versiones de php y mysql del servidor.

marzo 17, 2016 a las 9:51 am #840020

Yvette
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+02:00)

Buenos dias.

Este problema puede ser relacionado con este tiquet:
https://wpml.org/forums/topic/no-documents-found-translation-management/

Me gustaría probar el "fix" que ha ayudado a este cliente.

En preparación pido:
1. hacer un "backup" de seguridad de tu sistema (incluyendo el bbdd)
2. Instlalar y activar el plugin Adminer

3 Acceso a tu sistema temporalmente (wp-admin y FTP). Si pudiera ser a un sistema de pruebas donde el problema ha sido duplicado – mejor. Encontrarás los campos necesarios para facilitar este acceso en la area justo debajo la zona de comentarios cuando entras a dejar tu próximo respuesta.
La información será privado. Es decir que los datos será solo visible entre tu y yo.

Muchas gracias por tu colaboración y paciencia.

marzo 18, 2016 a las 4:06 pm #841392

Yvette
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+02:00)

Precisamente.

Aquí las instrucciones como he podido resolver este mismo problema para si quieres intentarlo tu mismo:

https://wpml.org/es/forums/topic/panel-de-traduccion-vacio/

Gracias por avisar si lo harás tu o prefieres que lo hago yo.

marzo 18, 2016 a las 4:09 pm #841394

marcalS

Provaré de solucionar-lo yo mismo. Grácias!!

marzo 18, 2016 a las 4:51 pm #841434

marcalS

Todas las tablas de la base de datos están con "utf8mb4_general_ci"
excepto:

utf8mb4_unicode_ci
wpoxdc_icl_string_packages
wpoxdc_layerslider
wpoxdc_termmeta

utf8_general_ci
wpoxdc_iwp_backup_status

Debo cambiar-las todas a "utf8mb4_unicode_ci" ?

marzo 18, 2016 a las 11:54 pm #841647

Yvette
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+02:00)

Sí...por lo menos las tablas que he indicado en el otro tíquet.

También asegurase que los campos de cada tabla (y no solo las tabla) tiene el "collation" puesto a utf8mb4_unicode_c.

Importante: por favor haz un "backup" de seguridad antes de hacer cualquier cambio.
Gracias.

marzo 21, 2016 a las 9:59 am #842314

marcalS

Bien ya está solucionado.
He cambiado el "collation" de todas las tablas y de todos los campos y parece que ya funciona.

Muchas gracias!!