Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

Hoy no hay asistentes de soporte disponibles en el foro Spanish. Siéntase libre de enviar sus tiques y les daremos trámite tan pronto como estemos disponibles en línea. Gracias por su comprensión.

This topic contains 9 respuestas, has 2 mensajes.

Last updated by paulinaM-2 hace 6 meses, 3 semanas.

Assigned support staff: Yvette.

Autor Publicaciones
marzo 22, 2019 a las 12:38 pm #3440205

paulinaM-2

Hola,

Ha dejado de funcionar el plugin. No aparecen los idiomas que estaban activados y pone que sólo está activo el portugués. He mirado en la base de datos y en la tabla "icl_languages" en la columna "Activate" aparecen activos, pero en el panel de administración de WP han desaparecido.

Un saludo.

marzo 22, 2019 a las 6:16 pm #3443417

Yvette
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hola

Te ayudaré con este problema

1. Memoria PHP
Veo que aún tienes configurado la cantidad de 40M de memoria PHP a tu entorno WordPress que es el valor por defecto. Para que WPML puede funcionar corretamente, necesita que este opción sea 128M mínimo.
https://wpml.org/es/pagina-principal/requerimientos-minimos-2/

Por favor añade este linea a tu archivo wp-config.php

define('WP_MEMORY_LIMIT', '256M');

2. Acceso temporal a tu sistema
Si este no arregla el problema - entonces pido acceso a tu sistema temporalmente (wp-admin y FTP). Si pudiera ser a un sistema de pruebas donde el problema ha sido duplicado - mejor. Encontrarás los campos necesarios para facilitar este acceso en la area justo debajo la zona de comentarios cuando entras a dejar tu próximo respuesta.
La información será privado. Es decir que los datos será solo visible entre tu y yo.

Gracias

marzo 25, 2019 a las 1:43 pm #3454219

paulinaM-2

Hola,

¿Hay alguna novedad?

Un saludo.

marzo 25, 2019 a las 4:02 pm #3455889

Yvette
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hola

Es muy curioso. He podido confirmar que el bbdd indica que tienes los siguientes idiomas activos:

-EN
-PT
-ES
-FR
-IT

Y confirmo que veo los traducciones y también los idiomas en el bbdd. Pero consta que esto no refleja en el dashboard WordPress.

Por favor, realiza los siguientes pasos y corrige el último configuración que no cumple con los requerimientos mínimos del sistema (ver imagen)
- Activar el componente "Extensión de cadenas de caracteres multibyte"

Después:
- Borrar y manualmente re-instalar el plugin WPML CMS desde el panel de Plugins.
- Actualizar todo los plugins instalados en tu sistema
- Confirma que existe el mismo comportamiento si desactivas todo los plugins no-WPML y cambias tu tema activa tempoalmente a Twenty Seventeen.

Gracias

marzo 27, 2019 a las 6:06 am #3467721

paulinaM-2

Estoy a la espera de que gestor del hosting me solucione los problemas de configuración del servidor. Mientras he comprobado que la extensión de PHP simpleXML está activada. También he probado a desactivar todos los plugins menos los de wpml y he reinstalado wpml. Todo sigue igual.

Cuando el hosting corrija el tema de la caracterización de la base de datos vuelvo a hacer todas las comprobaciones y vemos si se soluciona.

Muchas gracias.

Un saludo.

marzo 27, 2019 a las 10:48 am #3469865

paulinaM-2

Hola de nuevo,

Aunque ya está cambiado el conjunto de caracteres a utf8mb4 sigue apareciendo el error en el panel de configuración de WP. Además todo sigue igual.

¿Qué más posibles soluciones podemos probar?

Un saludo.

marzo 27, 2019 a las 11:22 pm #3476119

Yvette
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hola

He intentado connectarme de nuevo con tu sistema per sin exito - me sale el siguiente error (ver imagen).

Puede ser que hay que escalar este caso a nuestro equipo de soporte nivel 2. Así, por favor haz lo siguiente:
https://wpml.org/es/faq/como-proporcionar-una-copia-del-sitio-al-personal-de-soporte/

Abro el area privada para que me envias el "package" del Duplicator. Por favor solo incluye un enlace a donde puede descargar los archivos....usa un servicio de compartir archivos como Fileshare, Dropbox, WeTransfer..etc.

Gracias

marzo 29, 2019 a las 11:44 pm #3495419

Yvette
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hola

Ya he podido re-establecer las idiomas y ahora parece normal.

No obstante, veo que el instalación no cumple con los requerimientos mínimos para un comportamiento normal de WPML (ver imagen).

Puedes ver con tu soporte del servidor como resolver este asunto para evitar otros tipos de errores en el futuro?

abril 1, 2019 a las 6:09 am #3504039

paulinaM-2

Muchísimas gracias Yvette. Que tengas buena semana.

Un saludo.

mayo 28, 2019 a las 12:21 pm #3906807

paulinaM-2

Hola,

Estamos teniendo el mismo problema que tuvimos hace tiempo con un nuevo sitio wordpress.

Un saludo.