Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

Etiquetado: 

This topic contains 5 respuestas, has 2 mensajes.

Last updated by Alejandro hace 3 semanas, 3 días.

Assigned support staff: Alejandro.

Autor Mensajes
septiembre 19, 2019 a las 9:31 am #4603059

mulchandc

Buenos días,

En nuestra web, funcionan todas las traducciones, exceptuando el chino.

Para ser más concreto, en el chino sólo nos funciona la portada, pero en cuanto tratamos de navegar a cualquier punto de menú, obtenemos siempre el mismo error: ERR_TOO_MANY_REDIRECTS

Hemos borrado cokkies, pero nada.

El htaccess es el básico

Podrías echarme un cable,

gracias de antemano,

Luis

septiembre 19, 2019 a las 9:44 am #4603147

Alejandro
Supporter

Languages: Inglés (English ) Español (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hola!
Bienvenido al Soporte WPML.
Haré mi mejor esfuerzo para ayudarte a resolver este problema.

Me parece che el problema es que por alguna razón no se logran codificar bien los URL (ya que el soporte de los carácteres especiales en los browsers y sistemas, para los slugs, todavía tiene algunos problemas).

Prueba aumentando la memoria del sistema, ya que al momento tienes 40M asignados y deberías tener al menos 300M ya que trabajas con WooCommerce + WPML + Elementor

Por favor, agrega este codigo en el archivo wp-config.php de tu instalación, luego de la información de la base de datos

define('WP_MEMORY_LIMIT','300M');
define('WP_MAX_MEMORY_LIMIT','400M');

Y luego revisa si por casualidad el problema desaparece.

septiembre 19, 2019 a las 9:55 am #4603251

mulchandc

Hola Alejandro,

gracias por tu rápida respuesta

Ya lo he modificado en el wp-config, pero el problema persiste.

septiembre 19, 2019 a las 12:38 pm #4604709

Alejandro
Supporter

Languages: Inglés (English ) Español (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ok, let's try something else.

Could you please go to permalinks > change the permalink to just

/%postname%/

and see if that helps, instead?

Also, could you check if by disabling all NON WPML related plugins, the problem continues?

Let me know please so i know how to proceed from there.

septiembre 19, 2019 a las 3:50 pm #4607005

mulchandc

Hola de nuevo Alejandro,

Ya he probado a hacer lo que me comentas y no hay manera, sigue sin estar operativo.

Alguna sugerencia más?

Gracias por tu ayuda

septiembre 20, 2019 a las 4:08 am #4609713

Alejandro
Supporter

Languages: Inglés (English ) Español (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ok. Veamos. En esta fase realizaremos varias cosas.

1) Por favor, activa el log de depuración para ver si logramos registrar algún error que me de una pista del problema. Para eso puedes revisar este artículo y hacer lo que se te sugiere allí http://wpml.org/documentation/support/debugging-wpml/ .

2) Prueba a recrear el problema. En este caso basta visitar un Link en chino, si no me equivoco

3) escribe aquí los pasos que seguiste para recrear el problema.

4) envíame el contenido del registro de depuración "debug.log" (archivo encontrado en el directorio /wp-content/ ) para poder estudiarlo.

5) este paso no se cuanto te será factible pero me gustaría saber el encoding de tu base de datos porque puede ser que este use utf8_general_ci
En vez de: utf8_unicode_ci

Si es así házmelo saber, dame acceso a tu página de WordPresss (usando los. Campos que te acabo de activar) y yo acomodaré eso.

Antes de darme acceso, te pido que hagas un database de la base de datos.

Saludos.

El debate ‘[Cerrado] No funcionan las traducciones en Chino’ está cerrado y no admite más respuestas.