Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

Our next available supporter will start replying to tickets in about 2.71 hours from now. Thank you for your understanding.

Etiquetado: 

This topic contains 5 respuestas, has 2 mensajes.

Last updated by Andrés hace 5 meses.

Assigned support staff: Andrés.

Autor Publicaciones
mayo 16, 2019 a las 3:16 pm #3827425

aldoM-2

Estoy tratando de activar la traducción en mi sitio web, ya tengo los idiomas establecidos y traducidos en cada uno de ellos, activo la vista del plugin en el home, originalmente la pagina esta en ingles. cuando le doy clic en español no me carga nada del contenido de español que ya esta traducido.

URL de (mi) sitio web donde aparece el problema: hidden link

Yo esperaba ver: la traducción en español de las paginas de mi sitio web

En vez de eso, obtuve: no esta traduciendo ningún contenido

mayo 16, 2019 a las 4:28 pm #3827957

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola,

Bienvenido al soporte de WPML.

1. Acabo de visitar tu sitio y pareciera que la página no ha sido traducida aún. Por ejemplo, al ver el código fuente de la página de inicio, las etiquetas hreflang se encuentran vacías (captura de pantalla). ¿Podrías verificar que se encuentra traducida y agregar una captura?

2. Para poderte ayudar más rápidamente he activado la casilla para enviar la información de debug de WPML en este ticket. Por favor, lee el siguiente artículo si tienes dudas de como enviarnos esta información:
https://wpml.org/es/faq/como-proporcionar-informacion-de-depuracion-para-obtener-soporte-mas-rapidamente/

Un saludo,
Andrés

mayo 16, 2019 a las 4:54 pm #3828081

aldoM-2

Lo raro es que active el plugin y en la parte de administración me sale los idiomas y hay fue donde coloque cada idioma y lo modifique, todas las paginas de ingles, las coloque en el idioma español y las modifique con el idioma español y al mostrar el botón en el home, cambio los idiomas y no sirve, te envió la información de depuración.

Te envió el pantallazo de lo que traduje y si te das cuenta en la parte superior esta en español, ya que la información original ya esta en ingles.

mayo 17, 2019 a las 5:30 am #3831485

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Veo también que solo sucede en la página de inicio, las otras páginas parecen funcionar correctamente. Intenta lo siguiente:

1. ¿Podrías ir a tus Ajustes > Enlaces permanentes y guardar tus ajustes de nuevo? No debes cambiar nada, sólo guardarlos de nuevo.

2. Desactiva temporalmente la extensión Gtranslate, ¿la situación cambia?

3. Accede a tu base de datos.
- Abre la tabla wp_options.
- Busca los campos siteurl y home.
- Verifica que tengas en ellos la URL completa de tu sitio.

Espero tus comentarios.

mayo 17, 2019 a las 9:37 pm #3837045

aldoM-2

Hola andres, realizamos la verificación y añadimos el www. Pero no sucedió nada. también seguí las primeras instrucciones y no funciono, tu me podrías que tiene que estar en la configuración del WPML detalladamente, para verificar si esta bien la configuración, de pronto sea eso.

mayo 20, 2019 a las 5:14 am #3843731

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola,

Acabo de visitar tu página de inicio y parece que has resuelto el problema con el procedimiento anterior. Por una parte, las etiquetas hreflang se muestran correctamente, por otra, el selector del pie de página ya te permite el cambio de idioma.

Saludos