Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

Our next available supporter will start replying to tickets in about 2.22 hours from now. Thank you for your understanding.

This topic contains 66 respuestas, has 3 mensajes.

Last updated by Carlos Rojas hace 2 semanas, 5 días.

Assigned support staff: Carlos Rojas.

Autor Publicaciones
febrero 17, 2020 a las 6:14 pm #5509913

josepO

Estoy tratando de:
Un post traducido con el EAT, en catalán no muestra las imágenes.

URL de (mi) sitio web donde aparece el problema:
hidden link

Yo esperaba ver: 20 imágenes

En vez de eso, obtuve: 1 imagen

Gracias

febrero 18, 2020 a las 7:31 am #5512831

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola,

Bienvenido de nuevo. 🙂

1. ¿Me podrías indicar cómo has agregado dichas imágenes originalmente? ¿Acaso hacen parte de un plugin?

2. Por otro lado, por favor revisa que tienes la extensión instalada y activada. Luego de eso ve a WPML > Configuración -> Traducción de multimedia.
y verifica que tus ajustes han sido correctamente activados.

En este sección podrás actualizar y traducir tu contenido anterior:
- Definir información de idioma para los elementos multimedia existentes
x Traducir los elementos multimedia existentes a todos los idiomas
x Duplicar los elementos multimedia existentes para el contenido traducido
x Duplicar las imágenes destacadas para el contenido traducido
- Da click en el botón "Iniciar".

Ahora, para el nuevo contenido verifica que estas opciones también han sido seleccionadas:
- Instrucciones para gestionar elementos multimedia para contenido nuevo:
x Los elementos multimedia subidos a la biblioteca de medios estarán disponibles en todos los idiomas
x Duplicar los elementos multimedia adjuntos para las traducciones
x Duplicar las imágenes destacadas para las traducciones

En el siguiente artículo podrás encontrar más información al respecto:
https://wpml.org/documentation/getting-started-guide/media-translation/

Un saludo,
Andrés

febrero 18, 2020 a las 11:59 am #5514923

josepO

Buenos días Andrés

He intentado realizarlo en 3 ocasiones, y al final, cuando finaliza el proceso, me muestra el mensaje de error, que vuelva a iniciar.

Es normal?

febrero 18, 2020 a las 12:37 pm #5515263

josepO

Y ahora todos los POST ultimos se han doblado.

Si los eliminino, me empiezan a llamar los propietarios de los post, pidiéndome explicaciones,

Desde la ultima vez que hablamos, tengo que comentarte que por temas de agotamiento provocado por las traducciones, he desinstalado todos los pluguins, y solo tengo pluguins recomendados por vosotros.

Gracias

febrero 18, 2020 a las 12:51 pm #5515349

josepO

Mira lo que ha provocado

hidden link

febrero 18, 2020 a las 3:11 pm #5516551

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Con respecto a lo de los posts doblados, es mejor investigarlo en un ticket aparte ya que no está relacionado. Creo recordar que ya ha sucedido antes. Adicionalmente, he visitado tu enlace y todo parece normal. ¿Tal vez reestableciste un backup?

Ahora bien, en efecto, un mensaje de error cuando tratas de duplicar tus imágenes no es normal. :/
Es probable que haya interferencia con una tercera parte, sin embargo, chequeemos primero si existe algún error PHP, ¿te parece?

Por favor abre tu archivo wp-config.php y busca la línea que dice: define(‘WP_DEBUG’, false);. y cámbialo por:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

Luego busca en la carpeta /wp-content/ y mira si existe algún archivo debug.log.

Si puedes agregar la información del debug.log en pastebin.com y proveerme el link sería aún mejor (Es la manera más limpia porque algunas veces los logs pueden ser muy largos y la conversación se puede volver desordenar mucho).
https://wpml.org/documentation/support/debugging-wpml/

Saludos

febrero 18, 2020 a las 3:51 pm #5516923

josepO

Buenas tardes

El debug.log lo tengo activado, el fichero es muy grande, he copiado solo la informacion de hoy, pero no se como funciona el pastebin.com.

Hay alguna otra alternativa

Gracias

febrero 18, 2020 a las 4:00 pm #5516959

josepO

[removed]
[18-Feb-2020 09:08:29 UTC] PHP Notice: Undefined index: amp-alternative-menu in /usr/home/madeinbarcelona/www/wp-content/plugins/wpml-for-amp/wpml_for_amp.php on line 164
[18-Feb-2020 09:08:29 UTC] PHP Notice: ob_end_flush(): failed to send buffer of zlib output compression (1) in /usr/home/madeinbarcelona/www/wp-includes/functions.php on line 4552

febrero 18, 2020 a las 4:18 pm #5517025

josepO

Andres

Hay algo que no funciona, he borrado los Post doblados, y el primer problema mediante el que he abierto este hilo se ha solucionado.
Ahora voy a proceder a realizar de nuevo lo de las imagenes que se cortan
te adjunto imagenes de los Post Doblados

Gracias

febrero 18, 2020 a las 4:46 pm #5517341

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

He tenido que editar tu respuesta anterior debido a la cantidad de errores. Sin embargo, he dejado los dos más representativos. ¿Podrías desactivar la extensión WPML for AMP y tratar de duplicar tus imágenes de nuevo?

Sin embargo, viendo tu última actualización quedo bastante perplejo, ¿está solucionado entonces?

Saludos

febrero 18, 2020 a las 4:52 pm #5517361

josepO

Buenas tardes

Lo de la falta de imágenes en un Post e idioma en concreto solucionado.

Lo de Documentación de Traducción de multimedia ( el Proceso que me has comentado que tenia que realizar) lo estoy realizando de nuevo, hasta el final no salta el error.

La galería Multimedia de WPML, esta semi vacía, no están todas las imágenes, y no se si esto es correcto.

Y el doblar los POst, te he enviado las imagenes para que lo veas, los he borrado, pero no se porque motivo se crean.

Gracias

febrero 18, 2020 a las 4:56 pm #5517377

josepO

Lo siento, te envió la imagen que te comentaba sobre la biblioteca de imágenes.
Concretamente el Post que pertenece a estas imágenes esta traducido a 8 idiomas.

febrero 18, 2020 a las 5:19 pm #5517501

josepO

De nuevo

Mark processed: Please try again (error)

febrero 18, 2020 a las 8:36 pm #5518541

josepO

Acabo de recuperar la copia de seguridad.

LA web estaba inoperativa por errores de redireccion en los diferente idiomas.

Si deseas mirar lo que pasa, te doy acceso, si no el problema esta de nuevo solucionado pero esta dentro del WPML.

Gracias

febrero 18, 2020 a las 10:14 pm #5518957

josepO

Buenas noches, de nuevo se ha colgado la web, he decidido solcitar ayuda al servidor, y me comentan que :

El plugin de traducciones que usas edita el fichero htaccess y crea una redirección, de manera que la web va lanzando redirecciones hasta que se llega al límite de las mismas del servidor, generando un error 500 que provoca que la web no se accesible.

PORFAVOR, son problemas repetitivos, necesito solucionarlo ya, he seguido vuestros consejos y he cambiado los pluguins de Seguridad, de imágenes, y todos los que me habéis solicitado, pero necesito avanzar.
Si deseas que habrá un nuevo ticket, dímelo.

El problema inicial del POst de nuevo esta, ya que se ha recuperado la copia de ayer

Gracias