Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

Our next available supporter will start replying to tickets in about 1.01 hours from now. Thank you for your understanding.

This topic contains 16 respuestas, has 2 mensajes.

Last updated by Alejandro hace 3 semanas, 5 días.

Assigned support staff: Alejandro.

Autor Mensajes
agosto 30, 2019 a las 4:42 pm #4488399

Art Project Group

Tras la obligación de utilizar la nueva herramienta Taxonomy translation es imposible actualizar una taxonomía personalizada que tenga campos personalizados dado que siempre obtengo por respuesta Item not updated.

En este caso concreto la taxonomía posee además de los típicos campos Name, Slug, Parent Category y Description, tiene otros tres campos personalizados y hay uno en concreto que es fundamental poder modificarlo: Featured Image, amen de un segundo campo oculto que está vinculado directamente con él que obtiene el ID de la imagen seleccionada.

El problema es que en la URL hidden link, por ejemplo, es absolutamente imposible hacerlo ya que constantemente recibo el mismo error.

¿Cómo puedo personalizar los campos personalizados de las taxonomías personalizadas sin que la nueva herramienta interfiera?

Muchas gracias de antemano.

Un saludo.

septiembre 2, 2019 a las 6:53 am #4494845

Alejandro
Supporter

Languages: Inglés (English ) Español (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hola!
Bienvenido al Soporte WPML.
Haré mi mejor esfuerzo para ayudarte a resolver este problema.

Es muy probable que al momento de tener este error en el panel de WordPress, se registre un error en el debug.log

Para acertarnos de ello, Por favor, sigue las instrucciones mencionadas en esta página: https://wpml.org/documentation/support/debugging-wpml/

Luego trata de recrear el problema y dirigete a la carpeta wp-content de tu instalación y verifica si se creó un archivo "debug.log" (Se creará solamente cuando encuentre un error en el servidor).

Si se creó el archivo, te pido que lo cargues en una plataforma como Google Drive o Dropbox (puedes elegir la que uses normalmente) y envíame el link (asegurate de que sea accesible publicamente) así puedo analizarlo.

Otra cosa, me puedes decir como se llaman los campos personalizados? puede que los encuentres en WPML > Configuración > Traducción de campos personalizados /Traducción de términos de taxonomía > Busca los campos personalizados o términos de las taxonomias y cambialos de "No traducir" a "traducir"

Avisame como te va.

Muchas gracias.

septiembre 2, 2019 a las 5:03 pm #4499355

Art Project Group

En Registros (donde se ven los registros de error en Plesk) no me muestra ningún tipo de error, y lo he comprobado en tiempo real. Sólo se muestra este HTML en la pantalla:
<div id="message" class="notice notice-error">
<p>Item not updated.</p>
</div>

Ahí ya busqué antes de abrir el ticket, pero ni category_featured_image, ni category_attach_id aparecen en el listado, ni tan si quiera en los campos del sistema.

Vosotros diréis 🙂

Un saludo.

septiembre 3, 2019 a las 11:30 am #4504001

Alejandro
Supporter

Languages: Inglés (English ) Español (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ok, me podrías dar acceso a tu página web y listarme los pasos que tengo que seguir para ver el problema y sobretodo lo que deseas hacer (osea los pasos que realizaste para poder crear y traducir las taxonomías)

Inserta todo en los campos que acabo de activar para ello, así estarán seguras y serán privadas.

Saludos.

septiembre 3, 2019 a las 5:43 pm #4506725

Art Project Group

No me has puesto campos privados 🙁

Te preparo un clon del sitio de producción y te lo explico todo cuando me prepares los campos privados 😉

Un saludo.

septiembre 3, 2019 a las 6:13 pm #4506825

Alejandro
Supporter

Languages: Inglés (English ) Español (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

¿Puedes probar de nuevo?

septiembre 4, 2019 a las 3:40 pm #4512555

Alejandro
Supporter

Languages: Inglés (English ) Español (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Puede revisar de nuevo si ahora las cosas están mejor?

en WPML > Idiomas > Traducción de Taxonomías se debían marcar como "traducibles" los campos que comenzaban por "property_", veo que allí también existe uno para el "Agent" y para el "Agency" asi que si nota el mismo problema, ya sabe que debe hacer lo mismo pero para las taxonomías relacionadas con su problema

Saludos.

septiembre 4, 2019 a las 3:52 pm #4512683

Art Project Group

Perdona pero no he entendido la respuesta. No encuentro la ruta que me indicas ya que no hay nada dentro WPML -> Languages.

Un saludo.

septiembre 5, 2019 a las 10:57 am #4518593

Alejandro
Supporter

Languages: Inglés (English ) Español (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Disculpame, tienes razón, me equivoqué al escribir las dirección. no se trata de WPML > Idiomas sino de WPML > Configuración.

Saludos.

septiembre 5, 2019 a las 11:37 am #4518819

Art Project Group

Las taxonomías que necesitaba que fueran traducibles ya estaban configuradas, por si acaso he añadido otras en el entorno de producción pero sigo teniendo exactamente el mismo error.

¿Otra solución?

Un saludo.

septiembre 5, 2019 a las 11:44 am #4518843

Alejandro
Supporter

Languages: Inglés (English ) Español (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Si, estaban ya configuradas porque yo las había configurado, pero luego d haberlo hecho fui a una de las categorías que me mencionabas y vi que estaban los campos disponibles.

Me parece que hay algo que me falta. Me puedes decir, que es lo que esperabas que sucediese y sobretodo cómo y que error te da? así trato de reproducir el problema, ya que creo que anteriormente he entendido mal o a lo mejor no entedí todo el problema sino solo una parte.

septiembre 5, 2019 a las 11:57 am #4518921

Art Project Group

Vamos a ver.

Los campos personalizados han estado disponibles siempre en hidden link, y en cada una de las taxonomías en cada uno de los idiomas, pero nunca en hidden link, que es donde ahora queréis que se traduzcan las taxonomías.

El problema es que si tratas de editar por ejemplo hidden link editando el campo Featured Image, no te va a funcionar. OJO que hay alguna vez que no devuelve el error descrito, pero casi siempre devuelve el error y no actualiza el dato.

Ese es el problema.

A ver si me podéis decir algo.

Un saludo.

P.D: directamente relacionado con este asunto tengo un hilo abierto desde hace 2 meses y medio en https://wpml.org/es/forums/topic/no-salen-todas-las-imagenes-al-cargar-la-api-de-subida-de-imagenes/.

septiembre 5, 2019 a las 1:45 pm #4519695

Alejandro
Supporter

Languages: Inglés (English ) Español (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Entiendo, y si tienes razón, no se pueden traducir estos campos extras en la traducción de taxonomías de WPML (WPML > Traducción de Taxonomías).

Ahora entiendo el problema. y si, al parecer se trata de un error de compatibilidad.

Probablemente necesitaré enviar este caso a nuestros desarrolladores y para ellos necesito que cargues los plugins o el tema que están creando estas taxonomías en esta página de sandbox:hidden link

Atención, no tienes que migrar toda tu página, solo tienes que cargar las cosas necesarias para poder recrear el problema de las taxonomías. Por lo que veo parece que todo esto viene del tema, pero si no es así, por favor avisame que otro paso hay que seguir, ya que todo esto luego se lo tendré que informar a un desarrollador.

Saludos.

septiembre 16, 2019 a las 10:09 am #4578557

Art Project Group

Tienes un clon exacto de la versión de producción de hoy mismo.

Quedo pendiente de vuestras prontas noticias ya que me urge solucionar esto. El cliente está reclamando que le solucione las traducciones de 4 páginas (2 en alemán y 2 en sueco) y sin este arreglo es imposible.

Un saludo.

septiembre 16, 2019 a las 3:29 pm #4582023

Alejandro
Supporter

Languages: Inglés (English ) Español (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Disculpa pero no estoy seguro si migraste tu página entera a la sandbox que te he dado o me hablas de tu página web pero al momento la sandbox no funciona.

Otra cosa, y esto es muy importante:

No necesito toda la página sino las partes necesarias, ya que antes de poder mandar este caso a nuestros desarrolladores, el problema tiene que ser reproducido en un ambiente limpio (nuevo) ya que sino se hace muy dificil el debug del problema y por ende de su resolución. sin este paso no puedo enviar el caso a nuestros desarrolladores.

Yo no he podido lograr reproducirlo ya que en tu página web tienes 48 plugins activos + un tema que yo no conozco y por lo tanto se me hace imposible tomar solo lo esencial para mostrar esos campos personalizados que se encuentran en las taxonomías (Ver Screenshot).

Así que probemos de nuevo, por favor, carga aquí solo los elementos necesarios para reproducir tu problema: hidden link

luego revisa si el problema se reproduce aquí también y si es así, avisame y por favor escribe los pasos necesarios para reproducir el problema, así yo podré hacer los últimos tests y luego mandarlo a nuestros desarrolladores.

Saludos.

El debate ‘[Cerrado] No puedo actualizar taxonomías’ está cerrado y no admite más respuestas.