Skip Navigation

Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en los foros 6 días a la semana, 22 horas por día.

Our next available supporter will start replying to tickets in about 1.65 hours from now. Thank you for your understanding.

This topic contains 6 respuestas, has 2 mensajes.

Last updated by ivanG-19 hace 2 semanas, 2 días.

Assigned support staff: Alejandro.

Autor Mensajes
abril 16, 2021 a las 1:30 pm #8555661

ivanG-19

Cuéntenos qué está intentando hacer.

Hola,
He creado un par taxonomías con jet engine de crocoblock (comida y bebida) para productos de woocommerce y algunas metaboxes (Alérgenos, opciones, denominación de origen y descripción).

Al acceder a WPML>Configuración > Traducción de taxonomias me apararecen las dos taxonomias que he creado, comidas y bebidas, pero al decirle que las haga traducibles y guardar los cambios no las activa. Vuelvo a recargar la página y vuelven a estar marcadas como no traducibles.

También he intentado desde el producto > configuración del contenido multilingue pero me pasa lo mismo.

¿Hay alguna documentación que está siguiendo?

https://wpml.org/es/documentation-2/guia-de-inicio/traduccion-de-categorias-de-entradas-y-taxonomias-personalizadas/

hidden link

¿Hay algún ejemplo similar que podamos ver?
hidden link
hidden link
hidden link

¿Cuál es el enlace a su sitio?
hidden link

Quedo a la espera de su ayuda

Captura de pantalla 2021-04-16 a las 15.00.08.png
Captura de pantalla 2021-04-16 a las 14.50.43.png
Captura de pantalla 2021-04-16 a las 14.49.28.png
Captura de pantalla 2021-04-16 a las 14.44.28.png
abril 17, 2021 a las 12:00 pm #8561081

Alejandro
Supporter

Languages: Inglés (English ) Español (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hola!

Puedes revisar si tienes algún código en WPML > Configuración > Código XML Personalizado?

lo que mencionas de que cambias una opción, la guardas y luego se cambia a como estaba antes casi siempre es causado por un cache del servidor (OPCache, tal vez).

Puedes tratar de ver si existe un tipo de cache en el servidor (tal vez el hosting te pueda ayudar con ello) y luego si existe deshabilitalo por un momento y haz los cambios de nuevo.

Sino, trata de seguir esta guía: https://wpml.org/documentation/support/language-configuration-files/#custom-taxonomies

y avísame cómo te va.

abril 19, 2021 a las 9:24 am #8569693

ivanG-19

Hola Alejandro:

Muchas gracias por tu correo. Voy por partes.

No tenemos ningún XML personalizado.

He procedido a borrar la cache del navegador incluso he abierto la web en otro ordenador para que no tuviera ninguna cache y sigue sin funcionar.

He contactado con el soporte del hosting y me dicen lo siguiente.

El propio servidor web que usamos cómo proxy inverso, nginx, dispone de un sistema de cache muy volátil que se llama microcache, he procedido a deshabilitarlo por si te pudiese estar afectando, por favor, prueba de nuevo. En el caso de que el los problemas persistan, te recomendaría consultar nuevamente con el soporte del plugin, ya que a nivel de servidor no existe ningún sistema de cache activo y veo que a nivel de WordPress tampoco tienes sistemas de cache.

He probado pero sigue sin funcionar.

La tercera parte no la hemos podido aplicar, desconozco el procedimiento a realizar.

Cualquier ayuda será más que bienvenida.

abril 19, 2021 a las 10:02 am #8570401

Alejandro
Supporter

Languages: Inglés (English ) Español (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

1) Antes de continuar, necesitaré acceso a tu página web.

Acabo de activar las casillas necesarias para que puedas agregar las credenciales en modo seguro y privado.
Así solo nosotros dos podremos observarlas.

Te sugiero que crees un usuario temporal, asi podrás eliminarlo luego de haber cerrado el ticket.

2) Por favor dame los pasos para poder recrear el problema, así puedo ver de cerca lo que sucede y ver como te puedo ayudar.

Saludos.

abril 19, 2021 a las 1:23 pm #8572775

Alejandro
Supporter

Languages: Inglés (English ) Español (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Puedes ir a WPML > Soporte > Solución de problemas y presionar estas opciones:

❌ Antes de continuar, te aconsejo que realices un respaldo completo de tu página web ❌

Dirigete a WPML > Soporte > Resolución de problemas
Presiona los siguientes botones y luego revisa cada vez si el problema se ha resuelto:
• Esta operación restablecerá las tablas de idiomas de WPML y lo reinstalará. Se eliminará todo idioma personalizado que haya agregado.
• "Borrar caché de WPML"
• "Quitar las entradas fantasma de las tablas de traducción"
• "Reparar la intercalación de element_type"
• "Determinar información de idioma"
• "Corrige asignaciones de tipo de entrada para las traducciones"

Luego trata de recrear el problema, para ver si por casualidad se resuelve.

abril 19, 2021 a las 2:08 pm #8573319

ivanG-19

Hola Alejandro:

El paso de "Quitar las entradas fantasma de las tablas de traducción" es el que ha funcionado. Ya puedo traducir.

Gracias

abril 19, 2021 a las 2:09 pm #8573345

ivanG-19

My issue is resolved now. Thank you!