Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: No se carga el editor de textos al activar la traduccion mediante WPML

Solution: Dentro del plugin para Newsletters de Tribulan, hay una opcion que inserta una serie de botones en el editor de textos de WP. Desactivando esta opcion en la configuracion del plugin de Newsletters se ha solucionado el problema.

Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en los foros 6 días a la semana, 22 horas por día.

Hoy no hay asistentes de soporte disponibles en el foro Spanish. Siéntase libre de enviar sus tiques y les daremos trámite tan pronto como estemos disponibles en línea. Gracias por su comprensión.

This topic contains 6 respuestas, has 2 mensajes.

Last updated by Otto hace 4 años, 5 meses.

Assigned support staff: Otto.

Autor Mensajes
febrero 18, 2016 a las 2:03 pm #816748

andoni larrañaga

Al intentar crear o modificar contenido no se carga ni el editor de textos ni toda la barra lateral derecha.

Si desactivo la traduccion por WPML se carga.

Hemos probado con otro Theme y con los plugins desactivados.

Tambien hemos probado lo mencionado aqui pero sigue sin cargarse:
https://wpml.org/errata/adding-links-to-a-post-produces-ajax-fatal-error/

Hemos activado los logs pero no se aprecia ningun error.

Que podemos hacer?

febrero 18, 2016 a las 6:32 pm #817397

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola,

Gracias por contactarte con el foro de soporte!

Podrías incrementar la memoria de tu sitio, sobre todo la WP Memory Limit a 256M.
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

Tienes configurado 40M y el mínimo requerido es 128M.
https://wpml.org/home/minimum-requirements/

Muchas veces estos ajustes son bloqueados directamente desde la administración de tu hosting. En ese caso te remiendo que los contactes directamente y si puedes pedir valores superiores a 128M, sería recomendable.

Nota: 128M es el mínimo necesario para WPML sin otros plugins y con un tema por defecto de WordPress.

Si el problema persiste, por favor haz lo siguiente:
-Sigue las instrucciones de debug que están aquí: http://wpml.org/documentation/support/debugging-wpml/
-Repite la acción que genera el problema
-Copia y pega el contenido del del archivo debug.log. Tal vez puedas usar un servicio como pastebin.com

Muchas gracias por to cooperación.

Quedo a la espera de tus resultados.

Un saludo cordial,

Otto

febrero 24, 2016 a las 10:51 am #822093

andoni larrañaga

Hola!

Ampliando la memoria continua el problema.

Este es el error que se registra en el debug.log:
[24-Feb-2016 11:50:20 Europe/Madrid] Error Column 'context' cannot be null de la base de datos de WordPress para la consulta INSERT INTO `wp_icl_strings` (`language`, `context`, `gettext_context`, `domain_name_context_md5`, `name`, `value`, `status`) VALUES ('en', NULL, '', '9ee0c0d3c4c72bd0e70af0cdd85e1543', '0e3345e8f9c6f3f3adc676ed14e069de', 'Checkboxes List', '0') realizada por include('wp-admin/edit-form-advanced.php'), wp_editor, _WP_Editors::editor, _WP_Editors::editor_settings, apply_filters('tiny_mce_before_init'), call_user_func_array, wpMail->tiny_mce_before_init, __, translate, apply_filters('gettext'), call_user_func_array, icl_sw_filters_gettext, icl_translate, WPML_Admin_String_Filter->translate_by_name_and_context, WPML_Admin_String_Filter->register_string, WPML_Admin_String_Filter->save_string

Muchas gracias!

febrero 24, 2016 a las 1:03 pm #822322

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola,

Muchas gracias por la información.

Para poder investigar mejor el problema necesitaría, si fuera posible, que me permitas acceder a tu sitio temporalmente. Mucho mejor si tuvieras un sitio de pruebas en donde esté replicado el problema.

Encontrarás los campos necesarios debajo del área de comentarios. He marcado la próxima respuesta como privada, por lo que la información que ingreses solo la veremos tu y yo.

Es posible que necesite replicar tu sitio localmente. Para eso voy a necesitar instalar un plugin llamado "Duplicator". Con él podré crear una copia completa de tu web. Una vez que el problema esté resuelto, borraré la copia local. Dime por favor si estás de acuerdo.

** IMPORTANTE **

- Por favor haz un back up completo de tu sitio y base de datos antes de proveer los datos de acceso

- Si no ves este formulario para completar los campos confidenciales NO los publiques, ya que serán visibles en el foro:
hidden link

En ese caso, pídeme que vuelva a habilitar una respuesta privada.

Muchas gracias.

Un saludo cordial,

Otto

febrero 25, 2016 a las 3:55 pm #823582

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola,

He realizado una copia de tu sitio y la he instalado localmente. Y el problema aparecía.

En ella desactivé todos los plugins menos WPML y sus add ons y el problema desaparece. Por lo que presumo que es un problema de compatibilidad con algún plugin.

Te pido que por favor pruebes lo siguiente en tu sitio:
-Haz un back up completo de tu sitio
-Desactiva todos los plugins no relacionados con WPML
-Cambia por un momento a un tema por defecto de WordPress (Twenty-Fourteen por ejemplo)
-Si el problema desaparece, activa uno por uno para comprobar con cuál es el problema de compatibilidad

Muchas gracias por to cooperación.

Quedo a la espera de tus resultados.

Un saludo cordial,

Otto

febrero 29, 2016 a las 10:45 am #825754

andoni larrañaga

Hola Otto;

Muchas gracias por tu atención.

Despues de muchas pruebas he encontrado la solución: Dentro del plugin para Newsletters de Tribulant (en principio compatible con WPML), hay una opcion que inserta una serie de botones en el editor de textos de WP. Desactivando esta opcion en la configuracion del plugin de Newsletters se ha solucionado el problema.

Muchas gracias otra vez.

Un saludo.

febrero 29, 2016 a las 2:13 pm #826071

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola,

Me alegra que lo hayas podido resolver 🙂

Un saludo cordial,

Otto