Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

Our next available supporter will start replying to tickets in about 1.95 hours from now. Thank you for your understanding.

This topic contains 7 respuestas, has 2 mensajes.

Last updated by Andrés hace 4 meses, 1 semana.

Assigned support staff: Andrés.

Autor Mensajes
mayo 29, 2019 a las 1:40 pm #3916027

Juan Manuel

Estoy tratando de:

URL de (mi) sitio web donde aparece el problema:

Yo esperaba ver:

En vez de eso, obtuve:

Hola,

Una vez creo el duplicado un elemento (Anuncio, CPT de listingPro) se deberían mostrar las imágenes del original en la traducción en el dashboard, pero no aparecen. En su lugar muestra como si el enlace estuviera roto. Esto pasa en una galería propia del tema y en la "Imagen destacada".
En el frontend se visualizan perfectamente.
Mirando la consola, veo que aparecen con un error:
"Failed to load resource: net::ERR_SPDY_PROTOCOL_ERROR"

He visto que podía ser por culpa de ver la we b en Chrome, pero he probado en otros navegadores y sigue mostrándolas mal.

Además, aunque en frontend se ven bien, pruebo a entrar para cambiar la imagen... y las muestra todas también bloqueadas / en blanco.

¿Alguna idea de lo que puede estar pasando?

Lo curioso es que en algunos casos en inglés no va bien, pero en alemán si se muestran correctamente (y en castellano, obviamente también, porque es el idioma principal). En otros casos, la mayoría, no se muestran ni en inglés ni alemán.

El multi-idioma está configurado con un dominio por idioma. ¿Puede que esto tenga algo que ver?

El sitio está en desarrollo, pero ya tiene volcada muchísima información.

Gracias,
Un saludo

mayo 30, 2019 a las 5:20 am #3920465

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola,

Bienvenido al soporte de WPML.

Esta situación puede ser ocasionada por que has marcado tus imágenes como "Aparecer traducidas". Intenta lo siguiente:

- Ve a WPML > Configuración > Traducción de tipos de entrada > Traducción de tipos de entradas
+ Medios (attachment)
x Seleccionamos "Traducible - solo mostrar los elementos traducidos" (primera opción).

Un saludo,
Andrés

mayo 30, 2019 a las 6:40 am #3920767

Juan Manuel

Andrés, buenos días,

Está opción la cambié porque tal y como aparecía también se mostraba mal. La he vuelto a poner como indicas y el error persiste.

¿Alguna sugerencia más?

Gracias,

mayo 30, 2019 a las 8:31 am #3921337

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

WPML Media Translation es la extensión de WPML que te permitirá traducir las imágenes de tu librería WordPress.
Por favor revisa que tienes la extensión instalada y activada. Luego de eso ve a WPML > Configuración -> Traducción de multimedia.
y verifica que tus ajustes han sido correctamente activados.

En este sección podrás actualizar y traducir tu contenido anterior:
- Definir información de idioma para los elementos multimedia existentes
x Traducir los elementos multimedia existentes a todos los idiomas
x Duplicar los elementos multimedia existentes para el contenido traducido
x Duplicar las imágenes destacadas para el contenido traducido
- Da click en el botón "Iniciar".

Ahora, para el nuevo contenido verifica que estas opciones también han sido seleccionadas:
- Instrucciones para gestionar elementos multimedia para contenido nuevo:
x Los elementos multimedia subidos a la biblioteca de medios estarán disponibles en todos los idiomas
x Duplicar los elementos multimedia adjuntos para las traducciones
x Duplicar las imágenes destacadas para las traducciones

En el siguiente artículo podrás encontrar más información al respecto:
https://wpml.org/documentation/getting-started-guide/media-translation/

junio 3, 2019 a las 7:33 am #3939817

Juan Manuel

Hola,

Ya las tengo todas marcadas así.
Pero tengo una pregunta: si marco todas las opciones de la primera sección y pulso sobre el botón "inciar" me duplicará por cada idioma, todas la imágenes físicamente en el servidor, ocupando el espacio correspondiente? Lo digo porque actualmente contamos on algo más de 21.000 y no nos sobra espacio precisamente en el alojamiento.

Gracias,

Un saludo

junio 3, 2019 a las 8:18 am #3940091

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola,

Cuando duplicas imágenes con nuestro WPML Media Translation estás realmente duplicando el enlace en la base de datos y no la imagen en si. ¿Responde a tu pregunta?

Documentación:
https://wpml.org/documentation/getting-started-guide/media-translation/

junio 3, 2019 a las 1:12 pm #3942659

Juan Manuel

Vale, ok,

Esto responde a la pregunta, pero las imágenes siguen sin mostrarse en los idiomas duplicados en el dashboard, que era incidencia por la que abrí el ticket de soporte.
He iniciado el proceso y al acabar sigue persistiendo el error.

Gracias,

Un saludo

junio 3, 2019 a las 3:46 pm #3943977

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

1. ¿Si cargas una nueva imagen esta se muestra correctamente?

2. ¿Me puedes confirmar que se trata solo al nivel backend?

3. En tu sitio de prueba podrías revisar que esta situación se presenta cuando:
- Sólo el paquete WPML está activado. Esto nos dirá si hay algún problema de interacción con otro plugin.
- Cambias a un tema por defecto de WordPress como el Twenty Fourteen. Esto nos dirá si hay un problema de interacción con tu tema.
- Si el problema desaparece, activa uno por uno para determinar quién genera esta situación.

Saludos