Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

This thread is resolved. Here is a description of the problem and solution.

El problema: En el administrador de mi sitio no me aparecen las imágenes de la galería cuando cambio de idioma.

La solución: - Ve a WPML > Configuración > Traducción de tipos de entrada > Tipos de entrada. - Marca: x Medios (attachment) x Traducible - solo mostrar los elementos traducidos.

Documentación: https://wpml.org/documentation/getting-started-guide/media-translation/

0% of people find this useful.

This topic contains 8 respuestas, has 2 mensajes.

Last updated by Andrés hace 4 meses, 2 semanas.

Assigned support staff: Andrés.

Autor Publicaciones
mayo 28, 2019 a las 12:00 pm #3906477

goyaP

Hola, en el administrador de mi sitio no me aparecen las imágenes de la galería cuando cambio de idioma. En español, que es el predeterminado si se ve todo, pero si cambio a inglés por ejemplo, aparecen todas las imágenes en gris, no se cargan. Lo mismo pasa si intento utilizar una imagen al crear una página o post.

El problema solo lo he detectado por lo pronto en el administrador. WPML está actualizado. Utilizo un tema hijo de Avada. El tema padre es la versión 5.8.1

Adjunto dos capturas de cómo se ve.

mayo 29, 2019 a las 5:33 am #3911841

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola,

Bienvenido al soporte de WPML.

WPML Media Translation es la extensión de WPML que te permitirá traducir las imágenes de tu librería WordPress.
Por favor revisa que tienes la extensión instalada y activada. Luego de eso ve a WPML > Configuración -> Traducción de multimedia.
y verifica que tus ajustes han sido correctamente activados.

En este sección podrás actualizar y traducir tu contenido anterior:
- Definir información de idioma para los elementos multimedia existentes
x Traducir los elementos multimedia existentes a todos los idiomas
x Duplicar los elementos multimedia existentes para el contenido traducido
x Duplicar las imágenes destacadas para el contenido traducido
- Da click en el botón "Iniciar".

Ahora, para el nuevo contenido verifica que estas opciones también han sido seleccionadas:
- Instrucciones para gestionar elementos multimedia para contenido nuevo:
x Los elementos multimedia subidos a la biblioteca de medios estarán disponibles en todos los idiomas
x Duplicar los elementos multimedia adjuntos para las traducciones
x Duplicar las imágenes destacadas para las traducciones

En el siguiente artículo podrás encontrar más información al respecto:
https://wpml.org/documentation/getting-started-guide/media-translation/

Un saludo,
Andrés

mayo 29, 2019 a las 8:40 am #3913265

goyaP

Hola Andrés,

Ya había realizado esos pasos previamente (y los he vuelto a hacer) sin éxito. Al dar a iniciar después de aplicar la configuración ha duplicado el contenido (26.000 items). Al pasar al siguiente punto, da error y se queda como bloqueado.

Después he probado a marcar solo la primera opción y pulso en iniciar. Da el mensaje de que los archivos han sido duplicados: listo! y después se queda todo el tiempo con un error como la imagen que adjunto. Es el mismo error que aparece cuando inicio el trabajo con las 3 opciones marcadas.

Por otro lado he probado a desactivar todos los plugins y poner el tema por defecto y sigue pasando, solo funciona la galería en el idioma español. La web tiene bastante contenido ( unos 4.200 entradas y miles de imágenes).

Si lo necesitas, puedo conceder acceso al admin de WP.

Gracias.

mayo 29, 2019 a las 1:01 pm #3915727

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Gracias por la aclaración. El error que señalas se debe a que has marcado tus imágenes como "Aparecer traducidas".

Para corregirlo, ve a WPML > Settings > Post Types Translation y márcalas como Translate.

Realiza el procedimiento anterior. ¿Funciona esta vez?

mayo 29, 2019 a las 4:22 pm #3917351

goyaP

Gracias Andrés. Haciendo ese cambio ya ha funcionado. Traduzco tus instrucciones al español por si en el futuro a alguien le pueda servir de ayuda.

WPML > Configuración > Traducción de tipos de entrada > Entradas (post) + Páginas (page) + Medios (attachment) seleccionamos "Traducible - solo mostrar los elementos traducidos" (primera opción). Adjunto captura por si acaso.

Un saludo.

mayo 29, 2019 a las 4:26 pm #3917381

goyaP

Una última cosa, Con este cambio ya veo las imágenes en inglés y español, pero no en francés e italiano, que los tengo ocultos. En el momento que los muestre, tendré que repetir este proceso para que se copien en esos idiomas?

Gracias!

mayo 30, 2019 a las 5:14 am #3920457

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola,

¡Me alegra saber que tu problema está resuelto! 🙂

Ahora bien, no olvides realizar los pasos descritos en mi primera respuesta, y si tienes más problemas, no dudes en abrir un nuevo ticket.
https://wpml.org/es/forums/topic/no-se-muestran-las-imagenes-de-la-galeria-en-otros-idiomas/#post-3911841

Saludos

mayo 30, 2019 a las 7:46 am #3921023

goyaP

Problema resuelto. Gracias!

mayo 30, 2019 a las 9:39 am #3921779

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

¡Perfecto! 🙂
Que tengas un buen día.