Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

Etiquetado: 

This topic contains 19 respuestas, has 2 mensajes.

Last updated by toniF-2 hace 1 año, 9 meses.

Assigned support staff: Otto.

Autor Publicaciones
diciembre 20, 2017 a las 10:20 am #1462398

toniF-2

Hola

En la web: hidden link no se están traduciendo todas los productos, en este caso son viviendas y se tendrían que ver todas la viviendas de la categoría vendidas pero a continuación de la vivienda Albons carrer de l'Oli 22 RESERVADA, faltan estás 4 que marco en la captura de pantalla: Pals Carrer Samaria 55 VENDIDA, ....

En el resto de idiomas, francés, español e inglés esta funcionando correctamente.

saludos
Toni Fornés

diciembre 20, 2017 a las 12:37 pm #1462571

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola Toni,

Prueba lo siguiente por favor:
Haz un back up confiable y que puedas restaurar de tu sitio y base de datos antes de hacerlo.
Ve a WPML > Soporte > Solucionar problemas
En la sección Limpiar > haz click en Sincronizar taxonomías de las entradas luego de seleccionar propiedades.

Antes de hacerlo, podrías incrementar la memoria de tu sitio, sobre todo la WP Memory Limit a 256M.
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

Tienes configurado 40M y el mínimo requerido es 128M.
https://wpml.org/home/minimum-requirements/

Muchas veces estos ajustes son bloqueados directamente desde la administración de tu hosting. En ese caso te remiendo que los contactes directamente y si puedes pedir valores superiores a 128M, sería recomendable.

Nota: 128M es el mínimo necesario para WPML sin otros plugins y con un tema por defecto de WordPress.

Quedo a la espera de tus resultados.

Un saludo cordial,

Otto

diciembre 20, 2017 a las 2:09 pm #1462711

toniF-2

Hola Otto

Acabo de realizar los estos pasos que me indicas, adjunto captura:
"Ve a WPML > Soporte > Solucionar problemas
En la sección Limpiar > haz click en Sincronizar taxonomías de las entradas luego de seleccionar propiedades."

Pero veo que el problema persiste. No se cargan las 4 propiedades que faltan y que estan traducidas en el idioma catalán: hidden link

Algún otra opción?, gracias

Saludos
Toni

diciembre 20, 2017 a las 2:35 pm #1462751

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola Toni,

Es extraño, podrías revisar que estas cuatro propiedades tengan correctamente asignada la categoría en catalán?

Si esto no ayuda, podrías permitirme echar un vistazo al sitio?

Encontrarás los campos necesarios debajo del área de comentarios. He marcado la próxima respuesta como privada, por lo que la información que ingreses solo la veremos tu y yo.

Es posible que necesite replicar tu sitio localmente. Para eso voy a necesitar instalar un plugin llamado "Duplicator". Con él podré crear una copia completa de tu web. Una vez que el problema esté resuelto, borraré la copia local. Dime por favor si estás de acuerdo.

** IMPORTANTE **

- Por favor haz un back up completo de tu sitio y base de datos antes de proveer los datos de acceso

- Si no ves este formulario para completar los campos confidenciales NO los publiques, ya que serán visibles en el foro:
hidden link

En ese caso, pídeme que vuelva a habilitar una respuesta privada.

Muchas gracias.

Un saludo cordial,

Otto

diciembre 20, 2017 a las 6:51 pm #1463048

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola Toni,

Muchas gracias.

Hay algo que no termino de entender (para todos los idiomas).

Acabades o En Rehabilitació son Property Labels, no? Si vas a Properties > Property Labels, y miras para cada idioma, hay cero propiedades en cada una de las categorías.

En venda o Venuda son Property Status. Y hay 13 propiedades en la primera y 5 en la segunda, para cada idioma.

Qué filtro aplicas en hidden link para que muestre 11 propiedades? Es el mismo que estás aplicando en hidden link ?

Quedo a la espera de tu respuesta.

Muchas gracias por tu cooperación.

Un saludo cordial,

Otto

diciembre 20, 2017 a las 7:34 pm #1463101

toniF-2

Hola Otto

Te respondo a tus dudas:

Acabades o En Rehabilitació son Property Labels, no? Si vas a Properties > Property Labels, y miras para cada idioma, hay cero propiedades en cada una de las categorías. ---Si, veo que como bien dices hay cero propiedades en cada una de las categorias.

Qué filtro aplicas en hidden link para que muestre 11 propiedades? Es el mismo que estás aplicando en hidden link ? ------- si entras en cualquier propiedad, por ejemplo: Pals, Carrer Samària 55 · VENUDA · y haces scroll, verás que tiene la opción marcada en property labels de Acabada=Terminada y estos son los filtros que utilizo en todas las páginas, el property label, adjunto captura tambien.

Se te ocurre algo más que puede hacer este error?, muchas gracias

saludos
Toni

diciembre 20, 2017 a las 8:12 pm #1463123

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola,

He actualizado todas las propiedades en Catalán, sin hacer ningún cambio, solo "Update".

Por lo que puedo ver ahora funciona correctamente.

Podrías revisarlo por favor.

Quedo a la espera de tus resultados.

Un saludo cordial,

Otto

diciembre 20, 2017 a las 8:50 pm #1463147

toniF-2

Hola Otto

De momento lo sigo viendo igual, si voy a la página de terminadas idioma catalán siguen sin verse los 4 últimas propiedades vendidas, mirar la primera imagen que adjunte donde marcaba de color verde las propiedades que faltan. Sabes por que ocurre?, muchas gracias

hidden link

saludos
Toni Fornés

diciembre 21, 2017 a las 10:43 am #1463515

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola Toni,

Realmente lo siento. No se si he contado mal o he refrescado la página en Español en lugar de en Catalán. Lo cierto es que, como bien dices, el problema persiste 🙁

El plugin Duplicator no funciona en tu sitio. Al intentar descargar el paquete que he creado me da un error 500.

Podrías proveerme una copia de tu DB y de la carpeta wp-contents (excluyendo "uploads") para que no pese tanto. Con estos archivos podré reproducir tu sitio localmente para seguir investigando.

Envíame ambos archivos (seguramente necesites usar DropBox, Google Drive, o servicios similares ya que el archivo será bastante grande)

Una vez que el problema esté resuelto, borraré la copia local.

Marco la próxima respuesta como privada para que puedas compartir el enlace de manera segura.

Muchas gracias por tu cooperación.

Un saludo cordial,

Otto

diciembre 21, 2017 a las 2:01 pm #1463747

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola Toni,

Muchas gracias.

Es realmente extraño.

He reproducido el problema localmente. He notado que incluso desactivando WPML en Properties > Property labels sigue mostrando 0.

De todos modos, eso no impide que funcione en los otros idiomas...

He probado crear una nueva propiedad y asignarle ese Label, y la propiedad aparece. Podrías probarlo en tu sitio?

Si así fuera, creo que la solución más rápida es recrear estas propiedades. Entiendo que esto es trabajo extra para ti, pero estoy seguro que demorará menos que encontrar la causa de este problema tan extraño.

Dime por favor si te funciona y si te parece una solución razonable para ti.

Un saludo cordial,

Otto

diciembre 21, 2017 a las 5:38 pm #1464018

toniF-2

Hola Otto

Te explico los pasos que he seguido:

1- He ido a Property labels y he creado una nueva llamada venda-cat.
2- He ido a una de las propiedades, concretamente a esta: Pals, Carrer Samària 55 · VENUDA · en su versión en catalán y he modificado la property label a la que acabo de crear Venda-cat.
3- Una vez hecho estos cambios he ido a la pagina de Acabades versión catalán y he añadido otra fila de recent properties para que muestre la property label venda-cat, adjunto captura de pantalla.

Haciendo estos pasos aún sigo sin ver el resto de viviendas. ¿Como lo has hecho tu?, gracias

saludos
Toni Fornés

diciembre 21, 2017 a las 11:55 pm #1464144

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola,

Simplemente he creado una nueva propiedad en Catalán y le he asignado el label. Esta nueva propiedad aparece en la página sin más.

El problema, por lo que yo puedo ver, parece vinculado solo con estas cuatro propiedades. Si funciona para ti también, sería cuestión de recrearlas, borrar las "defectuosas".

Quedo a la espera de tus resultados.

Un saludo cordial,

Otto

diciembre 29, 2017 a las 7:47 am #1467713

toniF-2

Hola Otto

¿Lo podrías reproducir en la web de producción: hidden link o decirme paso a paso como tengo que hacerlo?, gracias

Saludos
Toni Fornés

diciembre 29, 2017 a las 12:04 pm #1467883

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola Toni,

Te pido disculpas por no ser lo suficientemente claro.

Básicamente, lo que te propongo es que elimines las cuatro propiedades que no están funcionando y sus traducciones, y que las vuelvas a crear y traducir. Pero antes de hacerlo, tenemos que comprobar que esto funciona 🙂

He creado una nueva propiedad en tu sitio, le he asignado el label terminada, la he traducido al catalán, le he asignado el label acabada. Y la propiedad aparece. Mira la captura de pantalla que adjunto por favor.

Luego la he borrado para no dejar tu sitio con esa prueba. Original y traducción están en la papelera.

Dime por favor si he sido claro esta vez o si tu obtienes resultados diferentes.

Quedo a la espera de tus resultados.

Un saludo cordial,

Otto

enero 3, 2018 a las 10:11 am #1470247

toniF-2

Hola Otto

Como te comente, en el mensaje anterior, podrías reproducir un ejemplo de lo que te ha funcionado en local en la web en producción?, muchas gracias.

Saludos
Toni Fornés