Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

El problema:
El selector de idiomas aparece correctamente en la web, pero no en dispositivos móviles. El Theme que utilizo es Bridge de QODE y lo he ubicado en el Header Bottom Right.

La solución:
No es posible ver el selector en móviles ya que el tema Bridge agrega por defecto el siguiente CSS para esa emplazamiento:

@media only screen and (max-width: 768px) {
  .header_bottom_right_widget_holder {
      display: none;
  }
}

Para evitar esto, utilizar la opción de agregar tu selector de idiomas al menu principal de tu sitio.
- Ve a WPM > Idiomas.
- Opciones del selector de idiomas
- Selector de idioma en el menú de WP
x Y agrégalo a tu menu de preferencia.

Documentación:
https://wpml.org/documentation/getting-started-guide/language-setup/language-switcher-options/

Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en los foros 6 días a la semana, 22 horas por día.

Hoy no hay asistentes de soporte disponibles en el foro Spanish. Siéntase libre de enviar sus tiques y les daremos trámite tan pronto como estemos disponibles en línea. Gracias por su comprensión.

This topic contains 3 respuestas, has 2 mensajes.

Last updated by Andrés hace 5 años, 10 meses.

Assigned support staff: Andrés.

Autor Mensajes
febrero 3, 2016 a las 2:44 pm #803829

rafaelG-5

He añadido el Widget Language Selector a Header Bottom Right. El selector aparece correctamente en la web, pero no en dispositivos móviles. El Theme que utilizo es Bridge de QODE y es compatible con WPML. ¿Qué debo hacer? Gracias

febrero 3, 2016 a las 3:12 pm #803878

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+01:00)

Hola Rafael,

Bienvenido al soporte de WPML.

No te es posible ver el selector en móviles ya que tu tema agrega por defecto el siguiente CSS para este widgte.

@media only screen and (max-width: 768px) {
  .header_bottom_right_widget_holder {
      display: none;
  }
}

Una posible solución sería cambiarlo por display: block; sin embargo corres el riesgo que tu menu se ubique encima de tu logo.

Otra alternativa sería utilizar la opción de agregar tu selector de idiomas al menu principal de tu sitio.
- Displaying a language switcher in the menu:
https://wpml.org/documentation/getting-started-guide/language-setup/language-switcher-options/

Por favor, también verifica que tu versión del tema Bridge se encuentra debidamente actualizada.

Espero que esta información te sea de ayuda.

Un saludo,
Andrés

febrero 3, 2016 a las 3:49 pm #803934

rafaelG-5

Hola, Andrés:

Gracias por tu respuesta. Lo he solucionado con la alternativa, agregando el selector de idiomas al menú principal.

Un saludo,

Rafa

febrero 3, 2016 a las 4:37 pm #804005

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+01:00)

Perfecto, Rafa.
Que tengas un buen día,
Saludos