Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

Our next available supporter will start replying to tickets in about 1.59 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Le problème : El plugin WPA WooCommerce Product Bundle no copia las opciones en las traducciones de producto.

La solution: - Abre la sección edición de productos > Configuración del contenido multilingüe. - Haz click en el enlace Show system fields. - Marca los siguientes campos como "Copy": x wpa_wcpb x wpa_ebw - Haz click en aplicar. - Guarda de nuevo el producto.

Documentation: https://wpml.org/documentation/support/language-configuration-files/

This topic contains 21 respuestas, has 2 mensajes.

Last updated by manuelC-27 hace 2 meses, 2 semanas.

Assigned support staff: Andrés.

Autor Mensajes
mayo 4, 2019 a las 6:27 pm

manuelC-27

Hola, ya hemos creado todos los productos en dos idiomas y tenemos algunos problemas

1.- El Plugin Product Bundle muestra unos precios que no corresponden con el producto, elimina los decimales para hacer los cálculos y no se vé en el idioma inglés.
2.- El plugin Custom Product Tabs (Shipping and returns) no muestra el contenido en idioma inglés, sólo el título. El contenido está traducido y escrito a través de Woocommerce Multilingual.
3.- Las imágenes de cada galería de color no se ven el idioma inglés.

La web está en desarrollo y para acceder necesitas:
[removed]

mayo 6, 2019 a las 6:12 am #3744981

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola,

Bienvenido al soporte de WPML.

Acabo de editar tu menaje anterior ya que también has compartido tus credenciales fuera del formulario y las has hecho públicas. Te pido que por favor las modifiques para evitar cualquier problema de seguridad.

Por otra parte por normas del foro sólo podemos tratar un asunto a la vez. Esto nos ayuda a brindarte un mejor servicio y también a otros usuarios con problemas similares a los tuyos a que encuentren la información aquí mostrada. Por esta razón debo pedirte que abras un nuevo ticket si necesitas más ayuda, me lo puedes asignar directamente si así lo deseas y seguimos trabajando en ello inmediatamente.

Ahora bien, trataremos aquí el primer problema que mencionas con el plugin WPA WooCommerce Product Bundle. Este plugin no se encuentra en nuestra lista de compatibilidad. Sin embargo esto no significa necesariamente que no lo sea, simplemente nuestro equipo no lo ha probado hasta el momento.
https://wpml.org/documentation/plugins-compatibility/

He creado un sitio de pruebas para ti. Puedes acceder a este simplemente haciendo click en en siguiente enlace:
hidden link

La idea es que cargues tu plugin WPA WooCommerce Product Bundle y nos ayudes a reproducir el problema. De esta manera, si efectivamente se trata de un problema de compatibilidad, podremos acelerar el proceso y contactar a nuestro Equipo de compatibilidad y trabajar con el autor en la resolución de tu problema.


No tienes que recrear tu sitio, simplemente instalar lo mínimo necesario para reproducir el problema.

Un saludo,
Andrés

mayo 6, 2019 a las 10:57 am #3747327

manuelC-27

Buenos días Andrés, cuando os mandé los datos de acceso pensé que estaba en un chat privado. Ya se han cambiado los datos y te doy las gracias.

Ya he instalado en el sitio de pruebas el tema que uso (Claue) y los plugins que incorpora.
Principalmente tengo dos problemas con el idioma y son los plugins de producto agrupado y las galerías de imágenes por cada color.

Yo necesito que cuando se haga una traducción de cada producto, se copien las imágenes y los plugin que se han dado de alta en el idioma principal tal como se hace en el resto de campos.

He creado dos productos y en ellos puedes ver estos problemas.

Muchas gracias

mayo 6, 2019 a las 11:24 am #3747563

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Disculpa el malentendido pero, como te decía anteriormente, solo podemos tratar un problema a la vez. ¿Podrías instalar únicamente la extensión WPA WooCommerce Product Bundle y ayudarnos a reproducir el problema con los precios?

He creado un nuevo sitio de pruebas:
hidden link

Saludos

mayo 6, 2019 a las 11:34 am #3747777

manuelC-27

No puedo instalar esa extensión sola porque está integrada con el tema, lo mismo que las galerías de colores.

mayo 6, 2019 a las 2:49 pm #3750153

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Entiendo tu situación, pero como el autor del tema es diferente al autor del plugin debemos manejarlo por separado. ¿Podrías descargar y cargar el plugin via FTP?

De lo contrario, nosotros lo haremos pero podría tomar más tiempo.

mayo 6, 2019 a las 4:20 pm #3751107

manuelC-27

Si, ya dispongo del plugin. ¿Donde quieres que lo cargue por FTP?

mayo 6, 2019 a las 4:22 pm #3751119

manuelC-27

En cualquier caso, el problema de las galerías de imagen por color corresponde al tema y no es ningún plugin.

Esto si lo podéis ver en la instalación temporal

mayo 6, 2019 a las 4:51 pm #3751307

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Como he dicho anteriormente, solo podemos manejar un problema a la vez. Para tus galerías, por favor abre un nuevo ticket.

Regresando al problema principal, en el Escritorio > WP Sandbox podrás encontrar las credenciales SFTP.

Saludos

mayo 6, 2019 a las 4:54 pm #3751325

manuelC-27

¿Me serviría la instalación temporal o tendría que hacerla de nuevo?

mayo 6, 2019 a las 5:01 pm #3751339

manuelC-27

Ya he puesto el plugin "wpa-woocommerce-product-bundle.zip" en el directorio principal.

mayo 7, 2019 a las 5:44 am #3753983

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Gracias por tu ayuda. Sin embargo, acabo de revisar el sitio de prueba y no encuentro el plugin. ¿Podrías verificarlo de nuevo? Para evitar confusiones, me refiero a este:
hidden link

mayo 7, 2019 a las 6:24 am #3754259

manuelC-27

No Andrés lo subí al hidden link
donde está instalado y también hay un producto de ejemplo

mayo 7, 2019 a las 8:38 am #3755359

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

El objetivo del sitio de pruebas es aislar el problema y eliminar toda interferencia de otros plugins, tema.... Por esta razón debemos realizar las pruebas en el sitio que te menciono. ¿Podrías instalar el plugin y ayudarnos a reproducir el problema?

mayo 7, 2019 a las 10:08 am #3756235

manuelC-27

Ya he creado de nuevo dos productos solo con con el plugin