Skip Navigation

Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en los foros 6 días a la semana, 22 horas por día.

Our next available supporter will start replying to tickets in about 2.26 hours from now. Thank you for your understanding.

This topic contains 4 respuestas, has 2 mensajes.

Last updated by mariluK hace 3 years.

Assigned support staff: Otto.

Autor Mensajes
octubre 13, 2017 a las 12:33 pm #1400274

mariluK

Hi there,
I installed wpml and its modules in rupestre.cl (wordpress with woocommerce), I have not yet created the pages to the second language (english), but, if I go to Appearance> Menu, I get the page without the menu that is created, I can not find the menu that was already created, attached a screenshot. What can this problem be?

octubre 13, 2017 a las 1:39 pm #1400372

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola,

Gracias por contactarte con el foro de soporte!

Podrías incrementar la memoria de tu sitio, sobre todo la WP Memory Limit a 256M.
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

Tienes configurado 40M y el mínimo requerido es 128M.
https://wpml.org/home/minimum-requirements/

Muchas veces estos ajustes son bloqueados directamente desde la administración de tu hosting. En ese caso te remiendo que los contactes directamente y si puedes pedir valores superiores a 128M, sería recomendable.

Nota: 128M es el mínimo necesario para WPML sin otros plugins y con un tema por defecto de WordPress.

Luego has lo siguiente:

Ve a WPML > Soporte > Solucionar problemas y realiza todas la acciones de la sección Limpieza. Fíjate por favor esta captura de pantalla: hidden link

***No ignores la advertencia sobre realizar un back up antes***

Si el problema persiste, ¿podrías revisar si existe algún error?

Para hacerlo sigue estos pasos por favor:
Abre tu archivo wp-config.php y busca la línea que dice: define(‘WP_DEBUG’, false);. y cámbialo por:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

Luego, repite los pasos que generan el problema y busca en la carpeta /wp-content/ si existe algún archivo debug.log.

Si puedes agregar la información del debug.log en pastebin.com y proveerme el link sería aún mejor (Es la manera más limpia porque algunas veces los logs pueden ser muy largos y la conversación se puede volver desordenar mucho).

También, si fuera posible para ti, sería útil esta prueba:
-Haz un back up completo de tu sitio
-Desactiva todos los plugins no relacionados con WPML
-Cambia por un momento a un tema por defecto de WordPress (Twenty-Fourteen por ejemplo)
-Si el problema desaparece, activa uno por uno para comprobar con cuál es el problema de compatibilidad

Quedo a la espera de tus resultados.

Un saludo cordial,

Otto

octubre 13, 2017 a las 10:11 pm #1400794

mariluK

Realicé las acciones de limpieza y el problema persiste, aquí va el debug.log:

https://pastebin.com/trje0vv4

gracias

octubre 13, 2017 a las 10:51 pm #1400800

mariluK

Ah! en el hosting me aumentaron a la memoria php a 128M, entonces en wp-config.php puse la misma cantidad.

octubre 16, 2017 a las 3:46 am #1401481

mariluK

Hola, seguí tus instrucciones y revisé el debug.log ahí ví que el error era este:

[13-Oct-2017 21:48:57 UTC] PHP Fatal error: Call to undefined function wp_doing_ajax() in /home/labsocial/rupestre.cl/wp-content/plugins/sitepress-multilingual-cms/inc/url-handling/wpml-url-filters.class.php on line 338

por lo que actualicé mi wordpress, que era un poco antiguo por el 4.8.2 y limpié la caché de mi navegador. Ahora al acceder, se solucionó el problema, gracias!