Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

Our next available supporter will start replying to tickets in about 2.55 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem: Estamos usando el plugin "Beautiful Taxonomy Filter" y el filtro funciona bien, y muestra el menú desplegable con los términos de la taxonomia en el idioma correcto.

El problema está en la etiqueta de Taxonomía (encima del desplegable) que siempre toma el lenguaje por defecto.

Solution: He agregado el siguiente código a WPML -> Settings -> Custom XML Configuration:

<wpml-config>
    <admin-texts>
        <key name="cptui_taxonomies">
            <key name="*" /></key>
    </admin-texts>
</wpml-config>

- Luego he vuelto a buscar la cadena en WPML -> String Translation y al traducirla se ha resuelto el problema.

Relevant Documentation:

Etiquetado: 

This topic contains 3 respuestas, has 2 mensajes.

Last updated by Carlos Rojas hace 1 mes, 1 semana.

Assigned support staff: Carlos Rojas.

Autor Publicaciones
septiembre 5, 2019 a las 12:14 pm

alvaroL-9

Tenemos un sitio con tipo de contenido personalizado y con algunas taxonomías creadas.

Estamos usando el plugin "Beautiful Taxonomy Filter" y el filtro funciona bien, y muestra el menú desplegable con los términos de la taxonomia en el idioma correcto.

El problema está en la etiqueta de Taxonomía (encima del desplegable) que siempre toma el lenguaje por defecto.

Pensábamos que el problema podía estar en la version de nuestros plugin WPML y hemos contratado la licencia para poder actualizarlo, pero el problema persiste, y no logramos dar con la solución.(creemos que es un error en el propio plugin beautiful filter)

Hemos duplicado el sitio en una dirección de pruebas:
hidden link
El Filtro que nos da problemas está en esta dirección:
hidden link

Encima del desplegable, en lugar de "Areas de Hobetuz", debería aparecer su traducción en idioma euskera definida en la administración: "Hobetuz Arloak"

Nota: el directorio de pruebas está protegido mediante un archivo .htaccess:
usuario: proyectosabaco
contraseña: proyectosabaco123

Les agradeceríamos cualquier orientación para para resolver el problema.
Un cordial saludo, Alvaro

septiembre 5, 2019 a las 2:23 pm #4520103

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola Alvaro,
Muchas gracias por contactar con el servicio de soporte de WPML.

He agregado el siguiente código a WPML -> Settings -> Custom XML Configuration:

<wpml-config>
    <admin-texts>
        <key name="cptui_taxonomies">
            <key name="*" /></key>
    </admin-texts>
</wpml-config>

- Luego he vuelto a buscar la cadena en WPML -> String Translation y al traducirla se ha resuelto el problema.

Puede confirmar que el problema está resuelto?

Saludos,
Carlos

septiembre 5, 2019 a las 4:45 pm #4520861

alvaroL-9

Muchas gracias por la rapidez Carlos.
Hemos replicado el cambio en el sitio en producción siguiendo tus indicaciones y ya funciona correctamente.
Un cordial saludo, Alvaro

septiembre 9, 2019 a las 9:20 am #4535223

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola Alvaro,
Me alegra saber que el problema está resuelto 🙂

Por favor no dude en contactarnos si necesita de nuestra ayuda en el futuro con WPML.
Saludos,
Carlos