Skip Navigation

Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en los foros 6 días a la semana, 22 horas por día.

Hoy no hay asistentes de soporte disponibles en el foro Spanish. Siéntase libre de enviar sus tiques y les daremos trámite tan pronto como estemos disponibles en línea. Gracias por su comprensión.

This topic contains 13 respuestas, has 2 mensajes.

Last updated by Mateus Getulio hace 2 meses.

Assigned support staff: Mateus Getulio.

Autor Mensajes
julio 21, 2022 a las 6:32 am #11706735

gasparG

Hola, he traducido todos los campos de title i alt de las imágenes de toda la web con media translation, ahora necesito hacer cámbios en las páginas y al editar las traducciones con el editor de traducción clásico no me aparecen las traducciones que que realicé con media translation. ¿como puedo hacer para que se sincronicen y no tener que realizar todas las traducciones de nuevo?

julio 21, 2022 a las 7:47 pm #11714007

Mateus Getulio
Supporter

Languages: Inglés (English ) Portugués, Brasil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hola,

¡Bienvenido al foro de soporte de WPML!

¿Podría por favor asegurarse de haber seguido nuestras recomendaciones relacionadas con la traducción de medios aquí? https://wpml.org/es/documentation-2/guia-de-inicio/modulo-media-translation/#id4

Si te refieres a la traducción de títulos y leyendas de imágenes, esto es lo esperado y estos textos podrán traducirse al traducir el resto de la página en el Editor de traducción avanzada.

Ahora, si incluso las imágenes no se traducen, me gustaría pedirle que pruebe una posible solución:

- Por favor vaya a "WPML > Soporte" en su panel de administración "su-sitio-web/wp-admin.php"
- Haga clic en el enlace "solución de problemas" debajo de la lista de versiones del complemento.
- Busque la sección "Limpiar" y haga clic en estos botones:
- Clear the cache in WPML
- "Fix element_type collation" button
- "Set language information" button
- Fix post type assignment for translations

Además, asegúrese de borrar todos los cachés presentes en el sitio web. Luego, verifique si el problema persiste y háganoslo saber.

Esperamos su respuesta. ¡Gracias!

Saludos,
Mateus.

julio 22, 2022 a las 6:38 am #11716391

gasparG

Hola, Mateus.

Ya había leído la documentación y no me queda claro si he realizado de forma correcta las traducciones, lo explico de nuevo a ver si me puedes ayudar.

Una vez he tenido todas las páginas traducidas con el EDITOR DE TRADUCCIÓN CLÁSICO, he ido a MEDIOS > BIBLIOTECA, donde he rellenado en cada una de las imágenes el TÍTULO, correspondiente al atributo Tittle, y TEXTO ALTERNATIVO, correspondiente al atributo alt. no a las leyendas como comentas en tu respuesta.

Al terminar, he ido a WPML >> MEDIA TRANSLATIÓN, he completado todas las traducciones y he comprobado que efectivamente se visualizan en el código html de las diferentes páginas en los diferentes idiomas.

Ahora necesito realizar nuevos cambios en dichas páginas, pero al editar con el EDITOR CLÁSICO cualquier traducción, encuentro que los campos de TEXTO ALTERNATIVO, aparecen vacíos, no se reflejan las traducciones que realicé con media translatión, por tanto no puedo guardar sin rellenar esos campos.

Las pregunta es ¿DEBO RELLENAR ESOS CAMPOS DE NUEVO? o por contra existe alguna manera de sincronizar las traducciones ya realizadas en WPML >> MEDIA TRANSLATION con el EDITOR DE TRADUCCIÓN CLÁSICO.

Espero haberme expresado de manera que puedas enterder mi problema y quedo a la espera de tu respuesta.

Gracias!!

julio 22, 2022 a las 6:54 am #11716565

gasparG

Otra cosa, acabo de ver que estás en São Paulo, ¿existe la posibilidad de transferir este tiket a alguien que esté en una zona horaria más compatible con la mía? (España). Si yo realizo las preguntas durante mi jornada de trabajo, que para ti es de noche y tú me contestas durante tu jornada de trabajo, que para mi es de noche entre cada pregunta y respuesta va a pasar un día entero, y la verdad, necesito tener una respuesta rápida para poder avanzar. Gracias!!

julio 22, 2022 a las 12:32 pm #11719155

Mateus Getulio
Supporter

Languages: Inglés (English ) Portugués, Brasil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hola,

Gracias por su respuesta.

Primero, con respecto a nuestra diferencia horaria, me gustaría pedirle que continúe con nuestra investigación, y si el tiempo entre preguntas y respuestas sigue siendo largo, le reenviaré el boleto a uno de mis colegas. Solicitaré acceso al sitio y con eso la solución del problema no debería tardar mucho.

Ahora, en cuanto a los textos alternativos, como ya los tradujiste en Media Translation, deberían aparecer en el Classic Translation Editor. ¿Podría mostrarnos las páginas e imágenes donde ocurre el problema?

Además, me gustaría solicitar acceso temporal al sitio (wp-admin y FTP) con el objetivo de ver el problema más de cerca. Su próxima respuesta será privada y en ella encontrará los campos correspondientes a las credenciales solicitadas.

Aunque no haya realizado ningún cambio en el sitio siempre es recomendable crear una copia de seguridad del sitio completo antes de compartir las credenciales de acceso.

Saludos,
Mateus.

julio 22, 2022 a las 8:08 pm #11722169

Mateus Getulio
Supporter

Languages: Inglés (English ) Portugués, Brasil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hola,

Gracias por proporcionar las credenciales.

Migramos el sitio web a una copia alojada en nuestros servidores para que el sitio web original no se viera afectado por nuestras pruebas.

Después de algunas actualizaciones en el sitio clonado, pudimos hacer que el texto de las imágenes apareciera en el editor de traducción. ¿Podría probar los mismos pasos en el sitio original? Siga estas instrucciones por favor:

- Asegúrese de tener una copia de seguridad del sitio web antes de continuar
- Ir a hidden link
- Actualice todos los componentes allí. Esto es importante, ya que algunos de ellos están relacionados con Elementor y podrían estar causando el problema
- Luego, vaya a una de sus páginas afectadas y realice una modificación menor en la página/publicación original
- Intente traducir esa página nuevamente y vea si podrá encontrar los textos traducidos

Puede ver en las capturas de pantalla que las traducciones funcionaron bien en el sitio duplicado:

Inglés: hidden link
Francés: hidden link
Alemán: hidden link

Por favor pruebe los pasos anteriores y háganos saber los resultados. ¡Gracias!

Saludos,
Mateus.

julio 25, 2022 a las 6:24 am #11728761

gasparG

Hola, Mateus.

Nada, he actualizado, he realizado un cambio en el idioma original y al ir a las traducciones el problema persiste, en el código html si se visualizan las traducciones, pero en el editor de traducción clásico no.

julio 25, 2022 a las 3:21 pm #11734605

Mateus Getulio
Supporter

Languages: Inglés (English ) Portugués, Brasil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hola,

Revisé esto, pero hasta ahora no pude encontrar una solución.

Les pedí a mis colegas que echaran un vistazo a este problema para ver si hay algo que podamos hacer aquí. Volveré aquí tan pronto como uno de mis colegas me responda (que no debería llevar mucho tiempo).

Gracias,
Mateus.

julio 25, 2022 a las 3:25 pm #11734621

gasparG

Gracias, Mateus, quedo a la espera, a ver si hoy lo podemos solucionar que tengo ya que entregar el proyecto terminado.

julio 26, 2022 a las 11:52 am #11741581

gasparG

Hola, Mateus.

Se me acaba el tiempo, sabemos algo??

julio 26, 2022 a las 12:17 pm #11741827

Mateus Getulio
Supporter

Languages: Inglés (English ) Portugués, Brasil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hola,

Gracias por su paciencia y perdón por la respuesta tardía.

Tras una inspección más detallada, hemos concluido que se espera este comportamiento. Esas cadenas de medios en CTE pertenecen a un paquete de publicación/página y la que guardó en la Media Translation se guarda directamente en los metadatos adjuntos.

Lo que podemos sugerir es traducir medios en Media Translation que no están traducidos y no están adjuntos a la publicación/página. Además, la traducción de CTE debe reflejarse en la traducción de los medios.

Tenemos un ticket similar en nuestro foro, verifíquelo por favor: https://wpml.org/forums/topic/media-translations-are-overridden-when-using-advanced-translation-editor/. El problema se remitió a nuestro equipo de desarrolladores, pero lamentablemente, no tenemos ninguna estimación de una posible solución.

Espero que esta explicación te sea clara y resuelva la duda. Por favor, hágamelo saber si todavía tiene preguntas.

Gracias,
Mateus.

julio 26, 2022 a las 12:23 pm #11741905

gasparG

Hola Mateus, entonces debo entender que no hay solución??? debo traducir de nuevo todas las imásgenes si quiero realizar un cambio en una página????

julio 26, 2022 a las 1:53 pm #11742831

Mateus Getulio
Supporter

Languages: Inglés (English ) Portugués, Brasil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hola,

Gracias por su respuesta.

Me temo que sí, las traducciones realizadas en MT no se sincronizarán con las páginas/publicaciones que ya se han traducido. Hice esta prueba en una instalación nueva de WordPress y, de hecho, no hay sincronización para las páginas traducidas previamente.

Lo que noté es que la sincronización ocurre para nuevas páginas y publicaciones. Por ejemplo, si creamos un post con una imagen de este tipo, las traducciones de sus textos aparecerán en el CTE

Lo mismo ocurre si, por ejemplo, duplicamos la página que ya ha sido traducida. En este caso, cuando abramos la traducción CTE de esta página duplicada, veremos que los textos multimedia traducidos aparecerán tal como los tradujiste en MT.

Alternativamente, no dude en solicitar esta función en el enlace: https://wpml.org/suggest-a-new-feature-for-wpml/. Lo analizaremos y luego de una verificación adicional, puede estar disponible en las futuras versiones de WPML.

Si necesitas algo más no dudes en contactarnos. ¡Gracias!

Saludos,
Mateus.

julio 26, 2022 a las 4:13 pm #11744271

Mateus Getulio
Supporter

Languages: Inglés (English ) Portugués, Brasil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hola de nuevo,

Dado que esto requerirá algo de trabajo en el código, ahora he escalado este problema a nuestros desarrolladores. Ya se ha informado y actualmente se está trabajando en ello.

Estableceré el estado actual del ticket en "Escalado al equipo de desarrolladores de WPML" y me pondré en contacto con usted tan pronto como reciba algún comentario de ellos.

Saludos cordiales,
Mateus.