Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

Etiquetado: 

This topic contains 4 respuestas, has 2 mensajes.

Last updated by davidG-100 hace 1 año, 4 meses.

Assigned support staff: Yvette.

Autor Mensajes
mayo 17, 2018 a las 7:00 pm #2181206

davidG-100

Hola.

Mi web es una página de anuncios clasificados en inglés y español. Como es normal en este tipo de webs hay muchos autores. Lógicamente estas páginas de autor no se traducen ya que cada usuario (autor) se registra por su cuenta.

Si mi web está en ingles (idioma por defecto) cuando entro en la página de un autor la url es así:

hidden link ("ntbarar" es el nombre del autor)

En este caso no aparece la opción de poner la página de autor en español ya que tengo esta opción activada:

How to handle languages without translation --- Skip language

El problema ocurre cuando navego por mi web en Español. En este caso si entro en la página de un autor la url es esta:

hidden link (Hasta aquí todo bien)

El problema es que ahora sí aparece la opción de cambiar al inglés, y es cuando pincho sobre la opción de cambiar al ingles (estando en la página de autor) cuando la URL pasa a ser esta:

hidden link

cuando debería ser:

hidden link

Es decir, le falta la parte final (?type=ads)

Espero que se entienda bien el problema y puedan ayudarme.

Un saludo.

mayo 18, 2018 a las 9:33 am #2188661

Yvette
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hola

Existe un opción para guardar los parametros URL aqui:
WPML -> Languages -> Language switcher options -> Click on 'Preserve URL arguments'

Incluir una lista de argumentos separado por comas que quieres guardar

Puedes intentar usar este opción y ver si resuelva tu problema?
Gracias

mayo 18, 2018 a las 9:35 am #2188662

davidG-100

Thanks!!! ¿Me podrías decir qué debo poner en este caso concreto? ¿Debo añadir "?type=ads"? Gracias.

mayo 18, 2018 a las 9:42 am #2188673

Yvette
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+02:00)

Solo el argumento: "type"

mayo 18, 2018 a las 9:45 am #2188678

davidG-100

Muchas gracias. Ha funcionado!!!