Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

Our next available supporter will start replying to tickets in about 2.37 hours from now. Thank you for your understanding.

This topic contains 27 respuestas, has 2 mensajes.

Last updated by Carlos Rojas hace 4 meses, 3 semanas.

Assigned support staff: Carlos Rojas.

Autor Publicaciones
abril 25, 2019 a las 4:40 pm #3684523

estebanF-3

Hola, excelente día.

Disculpe el día de hoy noté que si trato de editar las páginas de mi sitio hidden link me marca que la página no se encuentra, y al entrar a la versión en inglés hidden link el sitio no responde. Si desinstalo WPML Translation Management puedo acceder al sitio en inglés y puedo editar las páginas pero los productos dejan de funcionar, es decir, no aparecen los productos en el sitio en inglés. Espero puedan ayudarme.

abril 25, 2019 a las 6:57 pm #3685251

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola,
Muchas gracias por contactar con el servicio de soporte de WPML.

En este caso me gustaría solicitar acceso temporal al sitio (wp-admin y FTP) con el objetivo de ver el problema más de cerca. Su próxima respuesta será privada y en ella encontrará los campos correspondientes a las credenciales solicitadas.

Aunque no realizaré ningún cambio en el sitio siempre es recomendable crear una copia de seguridad del sitio completo antes de compartir las credenciales de acceso.

Saludos cordiales,
Carlos

abril 26, 2019 a las 1:35 pm #3691003

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola,
Muchas gracias por la información suministrada.

He visitado el sitio y me aparece el siguiente error:
Bandwidth Limit Exceeded
The server is temporarily unable to service your request due to the site owner reaching his/her bandwidth limit. Please try again later.

Le pido que contacte con sus proveedores de hosting y les pida que resuelvan este problema para poder acceder al sitio.

Quedo a la espera de su respuesta.
Saludos cordiales,
Carlos

abril 26, 2019 a las 6:56 pm #3692927

estebanF-3

Listo Carlos, ya nos reiniciaron el valor del ancho de banda.

Quedo pendiente de sus comentarios.

abril 26, 2019 a las 7:39 pm #3693081

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola,
Muchas gracias por su mensaje.

Me gustaría pedirle que realice los siguientes pasos:
- Cree una copia de seguridad del sitio completo.
- Actualice todos los plugins y temas desactualzados. Funcionalidades desactualizadas pueden causar conflictos en el código.
- Borra la memoria cache.
- Ve a Ajustes -> Enlaces permanentes -> Vuelve a guardar los enlaces permanentes.
- Ve a WPML -> Soporte -> Haz click en el enlace 'solución de problemas' -> Haz click en los botones señalados en la imagen adjunta.
- Ve a Woocommerce -> Woocommerce Multilingual -> Configuración -> Enlace 'Solución de problemas' (abajo a la derecha) -> Sincroniza todos los productos.
- Si el problema persiste entonces:
-- Desactive todos los plugins, excepto los de WPML.
-- Active un tema por defecto de WordPress.
-- Si el problema desapareció comience activando el tema y luego los plugins uno por uno hasta que el problema vuelva a aparecer.

Me puede decir el resultado de los pasos anteriores?

Saludos cordiales,
Carlos

abril 29, 2019 a las 1:41 pm #3703939

estebanF-3

Gracias Carlos, en seguida me pongo a ello y le aviso en cuanto quede y veo si se solucionó.

Lo mantengo al tanto.

abril 29, 2019 a las 3:11 pm #3704817

estebanF-3

Listo, ya realicé todo lo que me mencionó. Con la actualización del tema se solucionó la visualización del segundo lenguaje, el problema de que no dejaba editar (marca que la página de edición no existe) persistió, por lo que seguí con los siguientes pasos que me mencionó, al final vi que parece ser que hay una incompatibilidad entre WPML y WPBakery Page Builder ya que si desactivo este plugin si me permite entrar a la edición de las páginas traducidas, pero prácticamente el sitio esta construido con este plugin.

¿En este caso cómo puedo proceder?

abril 29, 2019 a las 8:44 pm #3706585

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola,
Muchas gracias por su respuesta.

En este caso me gustaría pedirle que visite este enlace y siga los pasos descritos para traducir WPBakery Page Builder: https://wpml.org/documentation/plugins-compatibility/how-to-build-multilingual-sites-with-wpbakery-page-builder-and-wpml/

Saludos,
Carlos

abril 29, 2019 a las 11:00 pm #3706881

estebanF-3

Gracias por su respuesta,

En este punto:

"A notification displays at the top of the WordPress dashboard that enables you to easily activate the WPML Translation Editor with a single click. Simply click the Enable it now button in this message window.", no me aparece esa notificación, ¿hay otra forma para habilitar la traducción de WPBackery?. Me fui a "Localización de temas y plugins" pero no sé si es necesario crear el archivo .po ¿debo de generarlo?

Quedo pendiente.

Saludos!

abril 30, 2019 a las 2:15 pm #3712113

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola,
Muchas gracias por su mensaje.

Para activar el editor de traducción debe realizar los siguientes pasos:
- Ve a WPML -> Configuración -> Cómo traducir entradas y páginas -> Seleccionar la opción 'Usar el editor de traducción clásico de WPML' (que ya está seleccionada) -> Guardar los cambios.

Los pasos anteriores le permitirán utilizar el Editor de Traducción Clásico para traducir los contenidos nuevos en el sitio. Para los contenidos existentes debe realizar estos pasos:
- Edite el contenido (post, página, custom post type, etc) -> Active la opción del Editor de Traducción en el bloque 'Idiomas' que se encuentra en la columna derecha.

Sin embargo el problema al editar las páginas persiste, por lo que le pido que active el modo de depuración siguiendo los pasos descritos en el siguiente enlace: https://codex.wordpress.org/Debugging_in_WordPress y me diga si aparece algún mensaje de error en el archivo debug.log que se encuentra dentro de la carpeta wp-content en la instalación del sitio.

Saludos cordiales,
Carlos

abril 30, 2019 a las 2:48 pm #3712553

estebanF-3

Hola Carlos, gracias por su respuesta.

Ya activé el debug log pero sólo obtengo el siguiente mensaje:

[30-Apr-2019 14:41:14 UTC] PHP Notice: Undefined index: charge_type in /home/etiennedesign/public_html/wp-content/plugins/openpay-cards/openpay_cards_gateway.php on line 50

Si desactivo Openpay y vuelvo a entrar a la edición no guarda ningún error y el problema persiste.

Quedo pendiente de sus comentarios.

Saludos!

abril 30, 2019 a las 8:06 pm #3714733

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola,
Muchas gracias por su respuesta.

Puede crear un sitio de pruebas a partir de una copia del sitio en producción y compartir las credenciales de acceso? De esta manera podré realizar cualquier cambio sin afectar al sitio publicado.

Quedo a la espera de su respuesta.
Saludos,
Carlos

mayo 2, 2019 a las 3:01 pm #3725839

estebanF-3

Gracias Carlos, ya estoy en ello.

Para compartirle el acceso ¿cómo puedo hacerlo de forma privada?

mayo 2, 2019 a las 7:50 pm #3728951

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola,

Su próxima respuesta será privada y en ella encontrará los campos correspondientes a las credenciales solicitadas.

Aunque no realizaré ningún cambio en el sitio siempre es recomendable crear una copia de seguridad del sitio completo antes de compartir las credenciales de acceso.

Saludos,
Carlos

mayo 7, 2019 a las 10:22 pm #3762347

estebanF-3

Hola Carlos, excelente día.

Ya monté el sitio en otro servidor pero ahí sí me permite editar las páginas. Estoy pasando nuevamente el contenido de wp-content ya que varios archivos de plugins y media no se pasaron. Puede que alguno de esos archivos que no se pasaron sea el causante en el otro servidor, pero en caso de que no ¿qué puede estar impidiendo la edición en el servidor original?

Quedo pendiente de sus comentarios.

Saludos!