Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

Our next available supporter will start replying to tickets in about 3.88 hours from now. Thank you for your understanding.

This topic contains 13 respuestas, has 2 mensajes.

Last updated by Carlos Rojas hace 2 meses, 2 semanas.

Assigned support staff: Carlos Rojas.

Autor Publicaciones
agosto 1, 2019 a las 4:17 pm

miguel-a.C

Hello,

Implemented in the domain hidden link WPML with WooCommerce and the order and cart formalization pages have begun to fail.

When accessing gives error 500 and sometimes fails and sometimes not. It usually works in one language and fails in the other. He had to deactivate the add-on, so he could place new orders.

On the other hand, the installation of WordPress is in Spanish and when you deactivate the plugin the entire backoffice has been translated into English and when I reinstall it it is put back into Spanish.

Can you please see the reason for the incident?

I look forward to your news.

thank you

a greeting

agosto 1, 2019 a las 6:43 pm #4324833

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- Please follow this steps;
- Activate 'WPML Multilingual CMS' plugin.
- Go to Woocommerce -> Woocommerce multilingual -> Status tab -> Fix the issues that appear there.

Could you tell me the result of this steps?

2.- To change the language of the backend you have to edit your profile page and select the language you desire under the Languages section.

3.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

agosto 2, 2019 a las 9:41 am #4328673

miguel-a.C

Hi,

I have done all the steps you have indicated, but the WooCommerce pages continue to fail.

In addition, WordPress pages that are outside of WooCommerce also fail.

Please can you check it again?

I await your news.

Thank you

a greeting

agosto 2, 2019 a las 4:53 pm #4331677

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

I kindly ask you to follow this steps:
- Create a full backup of the site before making any change.
- Activate the debug mode by following the steps described in this link: https://codex.wordpress.org/Debugging_in_WordPress
- Try to reproduce the issue and check if there are any errors in the debug.log file.
- Deactivate WPML plugins and double check if the issue persists.

Could you tell me the results of the steps above?

Regards,
Carlos

agosto 2, 2019 a las 5:20 pm #4331789

miguel-a.C

Hi,

I have done the steps that you indicate and when I activate the WPML plugin, it starts giving several errors. Attached I send you screenshot with the different errors.

On the other hand, when I deactivate the WPML plugin, the order device that was previously in Spanish, stays in English, when before it was in Spanish.

I await your news.

Thank you

a greeting

agosto 2, 2019 a las 5:48 pm
agosto 2, 2019 a las 7:48 pm #4332415

miguel-a.C

Hola Carlos,

Ya he realizado la migración del sitio siguiendo los pasos que me has comentado.

Quedo a la espera de vuestras noticias.

Muchas gracias

Un saludo

agosto 5, 2019 a las 12:35 pm #4340573

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola,
Muchas gracias por su respuesta.

Al parecer el sitio no se migró correctamente. Cuando reviso la URL del sitio migrado no me aparece nada.

He aplicado algunos pasos de 'troubleshooting' en el sitio en producción y al parecer el problema desapareció. Puede confirmar si el problema desapareció para usted?

Quedo a la espera de su respuesta.
Saludos cordiales,
Carlos

agosto 5, 2019 a las 1:00 pm #4340685

miguel-a.C

Hola Carlos,

He comprobado y sigue fallando. Para reproducir el error. Navega por la web en español y añade un producto al carrito y dale para procesar el pedido, después selección el idioma ingles y sigue navegando, entonces empieza a fallar todas las paginas y a dar error 500 tanto en la versión española como en ingles.

Puedes trabajar en la web que hay en producción sin problema ninguna, en caso de ser necesario, podemos realizar una copia de seguridad.

Quedo a la espera de tus noticias.

Muchas gracias

Un saludo

agosto 5, 2019 a las 2:49 pm #4341401

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola,

He realizado los pasos que describió en su mensaje anterior pero no he podido reproducir el problema (vea las imágenes adjuntas).

Saludos,
Carlos

agosto 6, 2019 a las 9:09 am #4345639

miguel-a.C

Hola Carlos,

He reproducido el error y grabado la pantalla. ¿Como puedo hacerte llegar el video?

Necesito por favor, que si lo necesitáis, reinstaléis los plugin de WPML y que se vuelva a traducir de nuevo. Ya que estoy viendo que la web no esta estable y nos escriben los clientes comentado que no pueden comprar.

Quedo a la espera de tus noticias.

Muchas gracias

Un saludo

agosto 6, 2019 a las 11:50 am #4347007

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola,

He establecido tu próximo mensaje como privado, en él podrás suministrar un enlace de descarga con el video.

En caso de necesitar resetear los idiomas debes seguir estos pasos:
- Ve a WPML -> Soporte -> Enlace 'Solución de problemas' -> Sección 'Reiniciar'

Saludos,
Carlos

agosto 6, 2019 a las 4:46 pm
agosto 7, 2019 a las 1:06 pm #4355287

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola,
Muchas gracias por la información suministrada.

He vuelto a visitar el sitio tanto como administrador como en modo incógnito y sigo sin reproducir el problema. Sospecho la causa de este problema pueda estar de su lado o en el valor de max_input_vars. Por favor incremente el valor de max_input_vars siguiendo los pasos descritos en Plantilla -> General Options -> Troubleshooting -> How to Increase Input Vars Limit

Me puede decir si el problema persiste luego de incrementar el valor de max_input_vars?

Saludos,
Carlos

agosto 8, 2019 a las 2:11 pm #4363699

miguel-a.C

Hola Carlos,

He comprado con la empresa de hosting y me han comentado que actualmente el max_imput_vars es de 50000 hidden link

Y sigue dando errores ademas de a mi, a otros usuarios que están intentando comprar y escriben con el mismo problema.

Quedo a la espera de tus noticias.

Muchas gracias

Un saludo