Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

Etiquetado: 

This topic contains 5 respuestas, has 2 mensajes.

Last updated by Yvette hace 2 meses.

Assigned support staff: Yvette.

Autor Publicaciones
agosto 9, 2019 a las 5:10 pm #4372143

Galerna

Hola, buenas tardes.

He añadido el plugin a una web en desarrollo, lo he activado, configurado y en un primer momento, configure el mençu para que aparecieran en la zona verde indicada en la captura.

Después, al sincronizar el menú inglés con el de español, desapareció el selector de la zona verde e introdujo esa línea en blanco con enlace a la Home en inglés. Este enlace loi he revisado pero no se encuentra presente en el menú inglés dentro de Apariencia - Menú.

En el pie de página sí se muestran los idiomas pero no en el menú de cabecera, donde debería mostrarse como un selector o desplegable para poder elegir la opción en inglés.

No sé qué parte de la configuración puede estar provocando el problema por lo que he abierto este ticket para ver si me podéis ayudar a identificar el fallo y poder restaurar el selector eliminando el enlace "Home" que se ha agregado en el slider de la página de inicio en inglés.

Quedo a la espera de poder resolver esta incidencia.

Un saludo y gracias.

agosto 12, 2019 a las 8:02 am #4379007

Yvette
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hola

No tenías el buen menu configurado aquÍ:

WPML > Idiomas >Selector de idioma de menú

En vez de "Restaurant Homepage Menu", tenías puesto "Restuarnt General Menu"

Cambié el menu configurado y ahora aparece como esperas

agosto 12, 2019 a las 11:02 am #4380273

Galerna

Hola de nuevo.

Ya he visto la zona de configuración que faltaba pero veo que sigue apareciendo el enlace "Home" dentro del slider que te indicaba en rojo en la imagen que adjunté :
https://wpml.org/wp-content/uploads/2019/08/4372143-menu_error.jpg

He revisado los menúes pero no veo ningún enlace como Home en el menú inglés y no veo tampoco nada raro.

¿A qué puede deberser y desde donde puede eliminarse ese "Home" dentro del slider principal?

Quedo atento, un saludo y gracias.

agosto 12, 2019 a las 1:18 pm #4381221

Yvette
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+02:00)

Esto ha sido debido al "layout settings" que estaba establecido en ES pero no en EN. (ver imagen)

Concretamente, son los "breadcrumbs". Lo he desactivado en la página home para EN y ahora no aparece "Home". No obstante, veo que el layout es un poco distincto (e.g. tamaño del header es más alta en ES que en EN.

Tienes que procurar que cualquier cambio/settimg que estbleces en ES lo hagas igaul en EN.

agosto 12, 2019 a las 3:42 pm #4381947

Galerna

Perfecto, ahora sí.

Pensaba que los estilos los heredaba de la página original (Inicio).

Del hueco, era debido a que estaba utilizando una imagen de logo diferente e inferior en tamaño a la de la versión en español.

Parece que funciona todo bien ahora. Cualquier duda, os comento.

Un saludo y gracias.

agosto 12, 2019 a las 4:05 pm #4382177

Yvette
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+02:00)

Perfecto. Gracias.