Skip Navigation

Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en los foros 6 días a la semana, 22 horas por día.

Etiquetado: 

This topic contains 9 respuestas, has 2 mensajes.

Last updated by arantzazuL hace 5 meses, 4 semanas.

Assigned support staff: Carlos Rojas.

Autor Mensajes
diciembre 10, 2020 a las 5:02 pm #7637467

arantzazuL

Tell us what you are trying to do? Al visualizar las noticias según categoría e idioma solo muestra en 1 idioma. Si visualizo la página en modo admin se ve bien, pero al hacerlo de forma pública solo carga en un idioma.

Is there any documentation that you are following? No

Is there a similar example that we can see?
Logueado como admin: hidden link
En modo público: hidden link

What is the link to your site? hidden link

diciembre 12, 2020 a las 9:02 am #7649575

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hola,
Muchas gracias por contactarnos.

Este comportamiento puede deberse a algún problema de compatibilidad. Le pido que realice los siguientes pasos con el objetivo de aislar la causa del problema:
- Cree una copia de seguridad del sitio completo
- Actualice cualquier funcionalidad desactualizada
- Borre cualquier memoria cache que pueda existir
- Desactive todo los plugins excepto los de WPML
- Active un tema por defecto de WordPress, por ejemplo: Twenty Twenty
- Si el problema desapareció comience activando el tema y luego los plugins uno por uno hasta que el problema vuelva a aparece y encuentre al culpable.

Me puede decir el resultado de los pasos anteriores?

Saludos,
Carlos

diciembre 14, 2020 a las 11:02 am #7659321

arantzazuL

Buenos días:

He hecho todos los pasos y continúa mostrando las noticias en euskera en ambos idiomas.
hidden link

Un saludo.

diciembre 14, 2020 a las 11:16 am #7659485

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hola,
Muchas gracias por su respuesta.

Me gustaría solicitar acceso temporal al sitio (wp-admin y FTP) con el objetivo de ver el problema más de cerca. Su próxima respuesta será privada y en ella encontrará los campos correspondientes a las credenciales solicitadas.

Aunque no realizaré ningún cambio en el sitio siempre es recomendable crear una copia de seguridad del sitio completo antes de compartir las credenciales de acceso.

Saludos,
Carlos

diciembre 14, 2020 a las 11:47 am #7659877

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hola,
Muchas gracias por la información compartida.

Me gustaría pedirle que realice los siguientes pasos:
- Cree una copia de seguridad del sitio completo
- Ve a Plugins -> Add new -> Pestaña 'Commercial' -> Descarga y activa el plugin 'WPML Translation Management'
- Activa el Editor de Traducción cuando edites la página de inicio en Euskera, en el bloque de Idiomas (columna derecha) -> Vuelve a traducir la página de inicio via el Editor de Traducción.

Me puede decir el resultado de los pasos anteriores?

Saludos,
Carlos

diciembre 14, 2020 a las 1:51 pm #7661087

arantzazuL

Hola:

He seguido los pasos pero continúa igual, he realizado algunas traducciones que ya estaban hechas pero al llegar a ese módulo muestra el código de WPBackery Builder. Es extraño porque las noticias tienen las categorías incluidas correctamente.

Un saludo.

diciembre 14, 2020 a las 1:55 pm #7661121

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hola,
Muchas gracias por su mensaje.

Puede crear un sitio staging donde realizar más pruebas sin afectar al sitio en producción? Si necesita ayuda para crear el sitio de pruebas puede contactar con sus proveedores de hosting.

He establecido su próximo mensaje como privado para que pueda compartir las credenciales de acceso al sitio de pruebas.

Saludos,
Carlos

diciembre 14, 2020 a las 3:02 pm #7661611

arantzazuL

Hola!

He creado una copia aquí: hidden link

Saludos!

diciembre 16, 2020 a las 9:04 am #7674733

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hola,
Muchas gracias por compartir el sitio de pruebas.

Puede comprobar que el problema está resuelto en el sitio de pruebas. He realizado los siguientes pasos:
- Desactivar todos los plugins excepto los de WPML
- Activar un tema por defecto de WordPress
- Borrar la memoria cache
- Ir a WPML -> Idiomas -> Activar la cookie de Ajax
- Volver a activar los plugins y el tema.

Saludos cordiales,
Carlos

diciembre 17, 2020 a las 12:22 pm #7685169

arantzazuL

Mi problema está resuelto. Asistencia de sobresaliente, como siempre.